Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Translation pattern fails

Hi I have in a CUCM 8 a Translation-pattern to a internal extension, this fails and the debug shows ´Unallocated/unassigned number´

That extension is registered, and without any problem, i even test the TP with other extension, and fails again.

The call from CUCM to the remote site go through h323 trunk to a CME-SRST site.

ISDN channel are well, and outbound calls runs properly, this is the sh isdn status:

Global ISDN Switchtype = basic-net3

ISDN BRI0/0/0 interface

        dsl 0, interface ISDN Switchtype = basic-net3

    Layer 1 Status:

        ACTIVE

    Layer 2 Status:

        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

    Layer 3 Status:

        0 Active Layer 3 Call(s)

    Active dsl 0 CCBs = 0

    The Free Channel Mask:  0x80000003

ISDN BRI0/0/1 interface

        dsl 1, interface ISDN Switchtype = basic-net3

    Layer 1 Status:

        ACTIVE

    Layer 2 Status:

        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

    Layer 3 Status:

        0 Active Layer 3 Call(s)

    Active dsl 1 CCBs = 0

    The Free Channel Mask:  0x80000003

And the debug isdn q931

Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0x82

                Preferred, B2

        Calling Party Number i = 0x2183, '6xxxxxxxx'

                Plan:ISDN, Type:National

        Calling Party Number i = 0x0183, '6xxxxxxxx'

                Plan:ISDN, Type:Unknown

        Called Party Number i = 0xA1, '91xxxxxxx'

                Plan:ISDN, Type:National

*Aug 22 09:05:42.448: ISDN BR0/0/0 Q931: TX -> CALL_PROC pd = 8  callref = 0xB4

        Channel ID i = 0x8A

                Exclusive, B2

*Aug 22 09:05:42.464: ISDN BR0/0/0 Q931: TX -> DISCONNECT pd = 8  callref = 0xB4

        Cause i = 0x8081 - Unallocated/unassigned number

*Aug 22 09:05:42.620: ISDN BR0/0/0 Q931: RX <- RELEASE pd = 8  callref = 0x34

*Aug 22 09:05:42.620: ISDN BR0/0/0 Q931: TX -> RELEASE_COMP pd = 8  callref = 0xB4

I have other Translation-pattern to other extension but in other sites from cluster and all works fine, why this is failing?

The dial-peer are:

dial-peer voice 100 pots are (only put one for BRI)

dial-peer voice 1 pots

preference 1

destination-pattern 0T

port 0/0/0

!

dial-peer voice 20 pots

destination-pattern 06........

port 0/0/0

forward-digits 9

dial-peer voice 10 pots

preference 1

destination-pattern 09........

port 0/0/0

forward-digits 9

dial-peer voice 100 pots

incoming called-number .

direct-inward-dial

port 0/0/0

dial-peer voice 20 pots
destination-pattern 06........
port 0/0/0
forward-digits 9

!

dial-peer voice 10 pots
preference 1
destination-pattern 09........
port 0/0/0
forward-digits 9

!

dial-peer voice 100 pots
incoming called-number .
direct-inward-dial
port 0/0/0

Into CUCM/DNA show it runs, which could be the cause of this problem??

Thanks!!

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Translation pattern fails

I only see POTS DPs there, where are the VOIP DPs which are the ones you should be interested in??

HTH

java

if this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
5 REPLIES
VIP Super Bronze

Re: Translation pattern fails

Ivan,

This is usually caused by a wrong CSS assigned to the translation pattern. You need to ensure that the CSS on the translation pattern has access to the devices its trying to reach. So check the CSS on it.

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
Community Member

Translation pattern fails

Hi!

No matter what extension I put in the translation-p , always fails, outbounds calls runs well, only fails inbound.

I have checked CSS but seems fine, have all partition asigned.

thanks.

VIP Super Bronze

Translation pattern fails

Ok. Can you send a screen shot of your translation pattern.

This is what you should have . (random example)

Translation Pattern: XXXXXX

parttition: PT_YYYY

CSS: CSS_ZZZ

.

.

Called party transform mask: 7000XXX

You need to ensure that

1. The CSS on your gateway has acess to the Partition of the Xlation pattern

2. The CSS on your xlation pattern has access to the partiton of your called party xform mask

3. Configure your called party xform mask correctly

If you send a screen shot, called and transformed mask I am sure we can fix this

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
Cisco Employee

Translation pattern fails

I only see POTS DPs there, where are the VOIP DPs which are the ones you should be interested in??

HTH

java

if this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
Community Member

Translation pattern fails

Hi!

Finally was resolved the problem, was a dial-peer voip, the call enter in the Router, but it does not know what to do with that number because is associated a extension registered via wan in the CUCM, so in the dial-peer voice voip needed to put as destinattion-p the number of the TP.

dial-peer voice 1234 voip

session-target: ip CUCM

destination-pattern ---> the telephony number of the basic header, and the TP number.

Thanks!!!!

355
Views
0
Helpful
5
Replies
CreatePlease to create content