Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

translation-profile on voice-port doesn't translate...

I am trying to setup a translation-profile and apply it to a voice-port so I can route a particular FXS port out a particular FXO port. Is there any reason why a translation-profile shouldn't work on a voice-port in a UC500?

voice translation-rule 1

rule 1 /^9/ /50509/

voice translation-profile tprof1

translate called 1

voice-port 0/0/0

translation-profile incoming tprof1

So, when I call '9..........' the number isn't translated to '50509..........' But I can test the number fine with 'test voice translation-rule....' TIA.

12 REPLIES
Cisco Employee

Re: translation-profile on voice-port doesn't translate...

You need to fix your translation rule

Currently you have it as

rule 1 /^9/ /50509/

This means a single digit starting with 9

You need to have something like

rule 1 /^'9........../ /50509/

or

rule 1 /^'9.*/ /50509/

Thanks,

Hall of Fame Super Gold

Re: translation-profile on voice-port doesn't translate...

That statement is incorrect.

/^9/ matches anything starting with 9, not only single digit numbers.

Consequently, the translation-rule is correct.

Hall of Fame Super Gold

Re: translation-profile on voice-port doesn't translate...

That should be translation-profile outgoing.

New Member

Re: translation-profile on voice-port doesn't translate...

I tried with outgoing already and that didn't help.

I'm also getting seemingly strange output for 'debug voice translate'

Jul 6 12:12:41 CDT: //-1/05C7C7949C89/RXRULE/regxrule_profile_translate_internal: number= type=unknown plan=unknown numbertype=calling

Jul 6 12:12:41 CDT: //-1/05C7C7949C89/RXRULE/regxrule_get_RegXrule: Invalid translation ruleset tag=0

Jul 6 12:12:41 CDT: //-1/05C7C7949C89/RXRULE/regxrule_profile_match_internal: Error: ruleset for calling number not found

Hall of Fame Super Gold

Re: translation-profile on voice-port doesn't translate...

Please fully clarify the call flow and include DP config.

The error message doesn't mean much, just saying you are not translating calling number.

New Member

Re: translation-profile on voice-port doesn't translate...

I have a phone connected to FXS voice-port 0/0/0 and want it to always call out FXO voice-port 0/1/1. I have verified the port numbers are correct. I want to apply a translation-profile to any called number starting with a 9. I haven't added any dial-peers regarding this configuration because the voice-port should do the translation before hitting the dial-peers. As soon as I can get the translation working then I'll be able to properly route the calls from this FXS port out the FXO port. Here are my DPs but I don't think they will really help with the problem right now.

dial-peer voice 1 pots

description ****OUTBOUND EMERGENCY****

destination-pattern 9[469]11

port 0/1/1

forward-digits 3

dial-peer voice 2 pots

description ****OUTBOUND EMERGENCY****

destination-pattern [469]11

port 0/1/1

forward-digits 3

dial-peer voice 100 voip

description ****OUTBOUND 10-DIGIT****

destination-pattern 9[2-9]..[2-9]......

voice-class codec 1

session protocol sipv2

session target ipv4:x.x.x.x

dtmf-relay rtp-nte

no vad

dial-peer voice 101 voip

description ****OUTBOUND 11-DIGIT****

destination-pattern 91[2-9]..[2-9]......

voice-class codec 1

session protocol sipv2

session target ipv4:x.x.x.x

dtmf-relay rtp-nte

no vad

dial-peer voice 102 voip

description ****OUTBOUND INTERNATIONAL****

destination-pattern 9011T

voice-class codec 1

session protocol sipv2

session target ipv4:x.x.x.x

dtmf-relay rtp-nte

no vad

dial-peer voice 103 voip

description ****INCOMING EXTENSION****

voice-class codec 1

session protocol sipv2

session target ipv4:x.x.x.x

incoming called-number ....

dtmf-relay rtp-nte

no vad

What I will want to add is a dial-peer something like the following.

dial-peer voice 20 pots

destination-pattern 50509[2-9]..[2-9]......

port 0/1/1

Hall of Fame Super Gold

Re: translation-profile on voice-port doesn't translate...

You are correct, it should translate as incoming.

Not sure why it does not, to be honest.

New Member

Re: translation-profile on voice-port doesn't translate...

I have this exact setup on an AS5300 that works without issue. Maybe a reload will help this thing tonight. Do you have any special debugs that might help?

Hall of Fame Super Gold

Re: translation-profile on voice-port doesn't translate...

May have to do with the fact the As5300 received all digits in block.

I could also be a bug in IOS, try another image.

New Member

Re: translation-profile on voice-port doesn't translate...

I figured it out. It accepts the 'translation-rule' commands. So, like this:

conf t

translation-rule 1

Rule 1 ^9 50509

voice-port 0/0/0

translate called 1

But these translation-rules aren't the same as I'm used to. I only see the number 50509 passed to the dial-peer. Does anyone know how to control these translation-rules properly? I don't know regex.

translation-profile on voice-port doesn't translate...

Works great +5

New Member

translation-profile on voice-port doesn't translate...

I know it's late but thanks for posting this last bit. I probably never would have figured out that this was some kind of a bug. Using translation-rule instead of voice translation-rule or voice translation-profile worked for me as well.

I wish I had found this sooner but thanks for posting the work around.

952
Views
5
Helpful
12
Replies