Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Trouble getting IP7941 phone to register with CME 8.6 server?

I am trying to bring up a test CME 8.6 server, but am having issues getting my test IP7941G phone to register with the system. 

The phone definitely gets an IP address from the CME server, but it looks like the problem is that it's not getting its appropriate phone load, even though I appear to have the right files place and the IP7941's load file is exactly the same as the load that the CME server is serving up.   Any ideas?

Here are the config details:

IOS version: c2800nm-spservicesk9-mz.151-4.M7.bin

Content of flash:/phones/

    3  -rw-     2911906  Jan 12 2014 16:25:36 +00:00  apps41.9-1-1TH1-16.sbn

    4  -rw-      517968  Jan 12 2014 16:25:40 +00:00  cnu41.9-1-1TH1-16.sbn

    5  -rw-     2189038  Jan 12 2014 16:25:56 +00:00  cvm41sccp.9-1-1TH1-16.sbn

    6  -rw-      541453  Jan 12 2014 16:26:00 +00:00  dsp41.9-1-1TH1-16.sbn

    7  -rw-     1629575  Jan 12 2014 16:26:10 +00:00  jar41sccp.9-1-1TH1-16.sbn

    8  -rw-         660  Jan 12 2014 16:26:12 +00:00  SCCP41.9-1-1SR1S.loads

    9  -rw-         660  Jan 12 2014 16:26:12 +00:00  term41.default.loads

   10  -rw-         660  Jan 12 2014 16:26:12 +00:00  term61.default.loads

Current configuration : 7653 bytes

!

! Last configuration change at 18:23:38 UTC Sun Jan 12 2014

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname bdc-cme

!

boot-start-marker

boot system flash c2800nm-spservicesk9-mz.151-4.M7.bin

boot-end-marker

!

!

card type t1 0 3

enable secret 4 LcV6aBcc/53FoCJjXQMd7rBUDEpeevrK8V5jQVoJEhU

enable password 7 0313541D0301

!

no aaa new-model

network-clock-participate wic 3

network-clock-select 1 T1 0/3/0

!

dot11 syslog

ip source-route

!

!

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.20.1 10.10.20.20

!

ip dhcp pool VoiceVLAN

network 10.10.20.0 255.255.255.0

option 150 ip 10.10.20.1

default-router 10.10.20.1

!

ip domain name wovensystems.local

ip multicast-routing

no ipv6 cef

multilink bundle-name authenticated

!

isdn switch-type primary-5ess

!

voice service voip

ip address trusted list

  ipv4 10.10.20.0 255.255.255.0

!

license udi pid CISCO2821 sn FTX1051A1KN

archive

log config

  hidekeys

!

controller T1 0/3/0

cablelength long 0db

pri-group timeslots 1-24

!

ip ssh time-out 60

ip ssh rsa keypair-name woven.systems-1

ip ssh version 2

!

interface GigabitEthernet0/0

ip address 10.10.20.5 255.255.255.0

duplex auto

speed auto

no mop enabled

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/3/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-5ess

isdn incoming-voice voice

no cdp enable

!

interface Service-Engine1/0

ip unnumbered GigabitEthernet0/0

service-module ip address 10.10.20.10 255.255.255.0

service-module ip default-gateway 10.10.20.5

!

ip default-gateway 10.10.20.1

ip forward-protocol nd

ip http server

ip http secure-server

ip http timeout-policy idle 120 life 86400 requests 10000

ip http path flash:/gui

!

ip route 10.10.20.10 255.255.255.255 Service-Engine1/0

!

tftp-server flash:gui/admin_user.html

tftp-server flash:gui/admin_user.js

tftp-server flash:gui/CiscoLogo.gif

tftp-server flash:gui/Delete.gif

tftp-server flash:gui/dom.js

tftp-server flash:gui/downarrow.gif

tftp-server flash:gui/ephone_admin.html

tftp-server flash:gui/logohome.gif

tftp-server flash:gui/normal_user.html

tftp-server flash:gui/normal_user.js

tftp-server flash:gui/Plus.gif

tftp-server flash:gui/sxiconad.gif

tftp-server flash:gui/Tab.gif

tftp-server flash:gui/telephony_service.html

tftp-server flash:gui/uparrow.gif

tftp-server flash:gui/xml-test.html

tftp-server flash:gui/xml.template

tftp-server flash:/phones/SCCP41.9-1-1SR1S.loads alias SCCP41.9-1-1SR1S.loads

tftp-server flash:/phones/jar41sccp.9-1-1TH1-16.sbn alias jar41sccp.9-1-1TH1-16.sbn

tftp-server flash:/phones/apps41.9-1-1TH1-16.sbn alias apps41.9-1-1TH1-16.sbn

tftp-server flash:/phones/cnu41.9-1-1TH1-16.sbn alias cnu41.9-1-1TH1-16.sbn

tftp-server flash:/phones/cvm41sccp.9-1-1TH1-16.sbn alias cvm41sccp.9-1-1TH1-16.sbn

tftp-server flash:/phones/dsp41.9-1-1TH1-16.sbn alias dsp41.9-1-1TH1-16.sbn

tftp-server flash:/phones/term41.default.loads alias term41.default.loads

tftp-server flash:/phones/term61.default.loads alias term61.default.loads

tftp-server flash:/ringtones/Analog1.raw alias Analog1.raw

tftp-server flash:/ringtones/Analog2.raw alias Analog2.raw

tftp-server flash:/ringtones/AreYouThere.raw alias AreYouThere.raw

tftp-server flash:/ringtones/AreYouThereF.raw alias AreYouThereF.raw

tftp-server flash:/ringtones/Bass.raw alias Bass.raw

tftp-server flash:/ringtones/CallBack.raw alias CallBack.raw

tftp-server flash:/ringtones/Chime.raw alias Chime.raw

tftp-server flash:/ringtones/Classic1.raw alias Classic1.raw

tftp-server flash:/ringtones/Classic2.raw alias Classic2.raw

tftp-server flash:/ringtones/ClockShop.raw alias ClockShop.raw

tftp-server flash:/ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml

tftp-server flash:/ringtones/Drums1.raw alias Drums2.raw

tftp-server flash:/ringtones/FilmScore.raw alias FilmScore.raw

tftp-server flash:/ringtones/HarpSynth.raw alias HarpSynth.raw

tftp-server flash:/ringtones/Jamaica.raw alias Jamaica.raw

tftp-server flash:/ringtones/KotoEffect.raw alias KotoEffect.raw

tftp-server flash:/ringtones/MusicBox.raw alias MusicBox.raw

tftp-server flash:/ringtones/Piano1.raw alias Piano1.raw

tftp-server flash:/ringtones/Piano2.raw alias Piano2.raw

tftp-server flash:/ringtones/Pop.raw alias Pop.raw

tftp-server flash:/ringtones/Pulse1.raw alias Pulse1.raw

tftp-server flash:/ringtones/Ring1.raw alias Ring1.raw

tftp-server flash:/ringtones/Ring2.raw alias Ring2.raw

tftp-server flash:/ringtones/Ring3.raw alias Ring3.raw

tftp-server flash:/ringtones/Ring4.raw alias Ring4.raw

tftp-server flash:/ringtones/Ring5.raw alias Ring5.raw

tftp-server flash:/ringtones/Ring6.raw alias Ring6.raw

tftp-server flash:/ringtones/Ring7.raw alias Ring7.raw

tftp-server flash:/ringtones/RingList.xml alias RingList.xml

tftp-server flash:/ringtones/Sax1.raw alias Sax1.raw

tftp-server flash:/ringtones/Sax2.raw alias Sax2.raw

tftp-server flash:/ringtones/Vibe.raw alias Vibe.raw

!

control-plane

!

voice-port 0/3/0:23

!

mgcp profile default

!

telephony-service

max-ephones 48

max-dn 48

url services http://10.10.20.10/voiceview/common/login.do

url authentication http://10.10.20.5/CCMCIP/authenticate.asp

load 7941 SCCP41.9-1-1SR1S

load 7961 SCCP41.9-1-1SR1S

time-zone 5

voicemail 9000

max-conferences 8 gain -6

web admin system name admin password password

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-template  1

type 7961

!

ephone  1

!

line con 0

line aux 0

line 66

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

line vty 0 4

password 7 06315F371F404748

login

transport input all

!

scheduler allocate 20000 1000

sntp server 10.10.10.23

end



10 REPLIES
Cisco Employee

Re: Trouble getting IP7941 phone to register with CME 8.6 server

Hello

What do you see in the console log? Did you run the debug tftp event in order to check any error ? If not can you please try run this debug ?

Sent from Cisco Technical Support iPhone App

Br, Nadeem Please rate all useful post.
New Member

Re: Trouble getting IP7941 phone to register with CME 8.6 server

From a console session, I don't see any event messages scrolling while the phone is trying to register.  What are the explicit commands to turn on tftp degbugging and to then be able to see the debug events scroll from a console session?   I'm not familiar with how to do this.

Cisco Employee

Re: Trouble getting IP7941 phone to register with CME 8.6 server

Run the debug on the router "debug tftp event"

Unplug and plug the phone or resetting. Do terminal monitor on the router you will some events and message on the router.

For phone console try clear history before unplug and plug the phone .

Sent from Cisco Technical Support iPhone App

Br, Nadeem Please rate all useful post.
New Member

Re: Trouble getting IP7941 phone to register with CME 8.6 server

Thanks! I will try this shortly and let you know what I find out.

New Member

Re: Trouble getting IP7941 phone to register with CME 8.6 server

Try adding the below and see if it helps. 

telephony-service

ip source-address 10.10.20.5 port 2000

!

no create cnf-file

create cnf-file

Also, your option 150 statement and the default router statement  is pointing to 10.10.20.1.  Shouldn't it be 10.10.20.5?

New Member

Trouble getting IP7941 phone to register with CME 8.6 server?

I modified the option 150, to point to m DHCP server, but when I deleted and recreated the CNF files, they all seem to be getting written to a directory on flash called flash:/its/vrf1.   Is this supposed to happen?  I think the failure to properly generate the CNF files is what's breaking the server.

New Member

Trouble getting IP7941 phone to register with CME 8.6 server?

I stand corrected.  Changing option 150 and adding ip source-address DID allow the phone to register!!!  Progress!  Thank you so much.

New Member

Trouble getting IP7941 phone to register with CME 8.6 server?

No problem.  I struggled with a similar issue for a few hours the other night.  I thought I would save you some time.

Cisco Employee

Trouble getting IP7941 phone to register with CME 8.6 server?

Missed that ip source-address command missing in the config under telephony-service.

telephony-service

max-ephones 48

max-dn 48

url services http://10.10.20.10/voiceview/common/login.do

url authentication http://10.10.20.5/CCMCIP/authenticate.asp

load 7941 SCCP41.9-1-1SR1S

load 7961 SCCP41.9-1-1SR1S

time-zone 5

voicemail 9000

max-conferences 8 gain -6

web admin system name admin password password

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00


Br,
Nadeem 

Please rate all useful post.

Br, Nadeem Please rate all useful post.
New Member

Re: Trouble getting IP7941 phone to register with CME 8.6 server

modified the option 150, to point to m DHCP server, but when I deleted and recreated the CNF files, they all seem to be getting written to a directory on flash called flash:/its/vrf1.   Is this supposed to happen? 

Sorry.  I missed this question.  When you create the cnf files, they get stored in the /its/ virtual directory.  You can see all of the files in that directory with the show telephony-service tftp-bindings command.

715
Views
0
Helpful
10
Replies
CreatePlease to create content