Cisco Support Community
Community Member

Trouble Installing CUPM

I am trying to install Provisioning Manager and I the installation fails everytime with this error:

Postgres install failed with error code 1603

I can't seem to get the thing installed. Any help would be appreciated.



Hall of Fame Super Red

Re: Trouble Installing CUPM

Hi Chris,

Not sure if you had seen this info;

If an error message appears similar to the following appears, it means that the installation has failed:

Postgres install failed with error code 1603

Before trying to install Provisioning Manager again, you must clean up the system

Cleaning Up a Failed New Installation

If Provisioning Manager did not install correctly, you must first clean up the system before trying to

install Provisioning Manager again. These procedures are for a failed new installation of Provisioning

Manager 1.1. If you need to clean up a failed upgrade of Provisioning Manager 1.0 to 1.1, see Restoring

Provisioning Manager 1.0 when Provisioning Manager 1.1 Installation Fails, page 2-16.

After a failed installation, do the following:

Delete the CUPM installation folder. If you selected the default location during installation, it is


Delete the Documents and Settings\cupmuser folder.

Remove the Windows user; cupmuser (cupmuser is the default name provided during installation).

The Windows user name can be different, if you changed it during installation. For instructions on

removing the Windows cupmuser, see Removing the CUPM Windows User,

Removing the CUPM Windows User

Step 1 On the Windows desktop, select Start > Settings > Control Panel.

Step 2 Double-click Administrative Tools.

Step 3 Double-click Computer Management.

Step 4 In the console tree, under Local Users and Groups, click Users.

Step 5 Right click the user account cupmuser and delete it.

Note The Windows username, cupmuser, is the default name provided during installation. The

Windows username can be different, if you changed it during installation.

Step 6 Delete cupmuser's home direcotry. The default location is in the directory C:\Documents and Settings\.

From this doc;

Hope this helps!


Community Member

Re: Trouble Installing CUPM

Yes, thanks I saw that in the installation doc. The problem is that this error occurs every time I try to install. I can do the clean up process as much as I want but still get the same error.




Re: Trouble Installing CUPM

I got it installed after about 5 tries, disabling anti-virus helped and using a server with enough memory.

But now since i got it installed - i can't do anything with it. I get this error everytime i try to configure anything:

Error Code: SHARED-2263

Message: Exception caught storing wizard attributes 1: Batch entry 0 INSERT INTO tableWizardAttributes (wizardID, attribute, value ) VALUES (1, syncInfrastructure-status, NULL) was aborted. Call getNextException to see the cause.

anyone else seen this ?

CreatePlease to create content