Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Trouble registering phones in CCME 4.1

Hello all,

I've been trying to setup a lab CME 4.1 environment.  The CME router is a 3745 with IOS advipservices 12.4-15-T8.  I'm using a 3524XL-PWR for the phones.  I have 3 7970G's that I'm trying to use with this.  I setup interface fa0/0 on the router with 2 subinterfaces, fa0/0.10 and fa0/0.20.  Dot1q encapsulation.  I have also setup the ruter as an NTP server, as well as TFTP server.  The relevant config is:

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.11.1 192.168.11.10

ip dhcp excluded-address 192.168.11.245 192.168.11.254

!

ip dhcp pool LAB1

   network 192.168.11.0 255.255.255.0

   default-router 192.168.11.1

   dns-server 167.206.112.138 167.206.7.4

   option 150 ip 192.168.11.1

!

!

ip name-server 167.206.112.138

ip name-server 167.206.7.4

interface FastEthernet0/0
description Trunkport
no ip address
ip nat inside
ip virtual-reassembly
speed 100
full-duplex
!
interface FastEthernet0/0.1
encapsulation dot1Q 1
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.10
description VOICE
encapsulation dot1Q 10
ip address 192.168.11.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/0.20
description DATA
encapsulation dot1Q 20 native
ip address 192.168.21.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!        
interface FastEthernet0/1
description WAN, to 851
ip address xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
tftp-server flash:/phone/7970-7971/apps70.8-3-2-27.sbn alias apps70.8-3-2-27.sbn
tftp-server flash:/phone/7970-7971/cnu70.8-3-2-27.sbn alias cnu70.8-3-2-27.sbn
tftp-server flash:/phone/7970-7971/cvm70sccp.8-3-2-27.sbn alias cvm70sccp.8-3-2-27.sbn
tftp-server flash:/phone/7970-7971/dsp70.8-3-2-27.sbn alias dsp70.8-3-2-27.sbn
tftp-server flash:/phone/7970-7971/jar70sccp.8-3-2-27.sbn alias jar70sccp.8-3-2-27.sbn
tftp-server flash:/phone/7970-7971/SCCP70.8-3-3S.loads alias SCCP70.8-3-3S.loads
tftp-server flash:/phone/7970-7971/term70.default.loads alias term70.default.loads
tftp-server flash:/phone/7970-7971/term71.default.loads alias term71.default.loads
telephony-service
load 7970 SCCP70.8-3-3S
max-ephones 10
max-dn 50
ip source-address 192.168.11.1 port 2000
max-conferences 8 gain -6
transfer-system full-consult
create cnf-files version-stamp 7960 Jun 27 2010 22:37:52
ephone-dn  1
number 1005
!
ephone-dn  2
number 1006
!
ephone-dn  3
number 1007
!
ephone  1
device-security-mode none
mac-address 0018.18F1.A43F
button  1:1
!
ephone  2
device-security-mode none
mac-address 0018.18BF.3DD1
button  1:2
!
ephone  3
device-security-mode none
mac-address 0018.194D.5D99
button  1:3
And on the switch:
interface FastEthernet0/1
switchport access vlan 20
switchport voice vlan 10
!
interface FastEthernet0/2
switchport access vlan 20
switchport voice vlan 10
!
interface FastEthernet0/3
switchport access vlan 20
switchport voice vlan 10
interface FastEthernet0/24
description Trunk to 3745, fa0/0
duplex full
speed 100
switchport trunk encapsulation dot1q
switchport mode trunk
The problem is that when I plug in the 7970 to the switch it powers up just fine, but never registers to the CME router.  I'm not sure what I'm missing/doing wrong.  I'm trying to get the IP Phones on a voice vlan and use the switchports on the phones for PCs connected that will be on data vlan 20.  If anyone has any suggestions please share, and thanks for the advice. 

1 REPLY

Re: Trouble registering phones in CCME 4.1

Hello friend,

Try adding type command under ephone configuration. Then reboot phones with reset command.

ephone X

   type 7970

   reset

Hope it helps, please rate if it does.

Kind regards,

-- Adrian.

138
Views
0
Helpful
1
Replies
CreatePlease to create content