Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

two CME with IP phones, "unknown number"

Hello everybody.

I have a network with two 2921 routers in it (K22.R1 and K22.R2), each router runs OSPF process with all networks that this router belongs to ncluding voice network), each have it's own CME (9.1), first CME works in VLAN 2 (10.10.22.1), second in VLAN 3 (10.20.22.1). IP phones inside each CME works fine, calls within each router are placed, but when phones from R1 call to R2 or vice versa, i see on the phone  "unknown number", though all dial-peers are in place, and in debug I see that, for example, call from R1 is reaching R2, R2 matches incoming dial-peer, but it seems cannot find dial-peer for local registered phone.

I've modelled my network in PT (see in attached file), and in model it works fine, calls are reaching phones on remote router.

Here's portions of real configs:

! R1

!

interface GigabitEthernet0/0.2

description Voice VLAN 2

encapsulation dot1Q 2

ip address 10.10.22.1 255.255.255.0

!

interface GigabitEthernet0/1

description K22.R2

ip address 10.100.22.1 255.255.255.0

!

ephone-dn 1

number 2200

name Some Name

!

ephone 1

mac-address F41F.C267.8B98

type 7962

button 1:1

!

dial-peer voice 27 voip

destination-pattern 222.

session target ipv4:10.20.22.1

! R2

!

interface GigabitEthernet0/0.3

description Voice VLAN 3

encapsulation dot1Q 3

ip address 10.20.22.1 255.255.255.0

!

interface GigabitEthernet0/1

description K22.R1

ip address 10.100.22.2 255.255.255.0

!

ephone-dn 1

number 2220

name Some Name 1

!

ephone-dn 2

number 2221

name Some Name 2

!

ephone-dn 3

number 2222

name Some Name 3

ephone 1

mac-address 44AD.D9D5.182A

type 7962

button 1:1

!

ephone 2

mac-address 20BB.C092.47FF

type 7962

button 1:2

!

ephone 3

mac-address 5478.1AE1.1786

type 7962

button 1:3

!

dial-peer voice 27 voip

destination-pattern 220.

session target ipv4:10.10.22.1

On the routers i see that all dial-peers are up, calls are reaching remote router, but it cannot find dial-peer and phone shows "Unknown Number".

K22.R1#sh dial-peer voice summary

dial-peer hunt 0

             AD                                    PRE PASS                OUT

TAG    TYPE  MIN  OPER PREFIX    DEST-PATTERN      FER THRU SESS-TARGET    STAT PORT    KEEPALIVE

27     voip  up   up             222.               0  syst ipv4:10.20.22.1

20005  pots  up   up             2200$              0                           50/0/1

K22.R1#ping 10.20.22.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.20.22.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

K22.R2#sh dial-peer voice summary

dial-peer hunt 0

             AD                                    PRE PASS                OUT

TAG    TYPE  MIN  OPER PREFIX    DEST-PATTERN      FER THRU SESS-TARGET    STAT PORT    KEEPALIVE

27     voip  up   up             220.               0  syst ipv4:10.10.22.1

20004  pots  up   up             2220$              0                           50/0/1

20005  pots  up   up             2221$              0                           50/0/2

20006  pots  up   up             2222$              0                           50/0/3

K22.R2#ping 10.10.22.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.22.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

I've tried debugging ccapi, but i didn't see no problem in there. Where else can i look to find the problem?

Please help.

Everyone's tags (3)
4 REPLIES

two CME with IP phones, "unknown number"

Hi,

Just an assumption may be you need to enable caller-id under the dial-peer and ephone-dns

Thanks

Community Member

two CME with IP phones, "unknown number"

But how could it be connected to the dial-peer matching? I thought that caller-id is for cosmetic purposes, and calls are placed without caller-id info?

Community Member

two CME with IP phones, "unknown number"

I keep thinking about it and here's the questions that i come to:

1: Should i configure voice codecs if i have two exactly similar routers and IP phones? Could it be a codec mismatch when call is done between routers?

2: in debug ccapi output on the router R1 that receiving the call from the phone registered on R2 i see a string

cisco-username=192.168.22.254

It's IP address configured on R2 GE 0/0 (on R1 GE 0/0 192.168.22.253 and they are in same VLAN 1). Why this IP appears as cisco-username and not 10.20.22.1 (CME source address)?

Tomorrow i'll post complete debug output of the calls.

Community Member

two CME with IP phones, "unknown number"

I found it! It's a Toll Fraud prevention system!

Added to config

voice service voip

  no ip address trusted authenticate

And that was it.

578
Views
0
Helpful
4
Replies
CreatePlease to create content