Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

UC520 FXO To Auto Attendant Disconnect Problem

We have UC520 with FXO card, and have a problem when we point the inbound call to the Cisco Unity Express Auto Attendant, the problem is if the PSTN caller disconnect, the FXO remain off-hook for along time, and if the PSTN caller dial an extension and then disconnect the phone remain ringing for a long time.

but if we point the inbound call an extention, there is no problem and the phone stop ring when the PSTN caller disconnect.

below is the voice-port, and CUE dial-peer configuration:

voice-port 0/1/2

translate calling 3

compand-type a-law

cptone NL

timeouts interdigit 4

timeouts call-disconnect 5

timeouts wait-release 5

timing hookflash-out 500

connection plar 489

impedance complex2

description LandLine 5105586

caller-id enable

caller-id alerting line-reversal

caller-id alerting dsp-pre-allocate

!

voice-port 0/1/3

translate calling 3

supervisory disconnect dualtone mid-call

compand-type a-law

cptone NL

timeouts interdigit 4

connection plar 489

impedance complex2

description LandLine 5105388

caller-id enable

caller-id alerting line-reversal

caller-id alerting dsp-pre-allocate

!

dial-peer voice 499 voip

description VoiceMail

destination-pattern 498

media flow-around

session protocol sipv2

session target ipv4:10.1.10.2

dtmf-relay sip-notify

codec g711ulaw

no vad

!

so what we can do?

  • IP Telephony
Everyone's tags (3)
10 REPLIES
Hall of Fame Super Gold

UC520 FXO To Auto Attendant Disconnect Problem

You need to configure custom disconnect cptone specifi for country/network.

UC520 FXO To Auto Attendant Disconnect Problem

Ok. i will try the custom disconnect cptone, but why the current configuration work when the inbound is pointed to a phone and not work when the inbound pointed to the auto attendant.

Hall of Fame Super Gold

UC520 FXO To Auto Attendant Disconnect Problem

Should work in both cases, somethign si not configured correctlu if it doesn;t.

Re: UC520 FXO To Auto Attendant Disconnect Problem

I was configure custom disconnect tone refer to this site:

http://ciscoflair.blogspot.com/2009/05/cisco-fxo-disconnect-issue.html

And the tone is in the attachment, and the custom disconnect tone configuration like below:

voice class custom-cptone Disconnect

dualtone disconnect

  frequency 420 420

  cadence 251 255 245 250 249 250 250 250

and the port configuration was like below:

voice-port 0/1/2

supervisory disconnect dualtone mid-call

supervisory custom-cptone Disconnect

cptone NL

timeouts interdigit 4

timeouts call-disconnect 5

timeouts wait-release 5

timing hookflash-out 500

connection plar 334

impedance complex2

caller-id enable

caller-id alerting line-reversal

caller-id alerting dsp-pre-allocate

but it was not working and the phone still ringing after the PSTN caller disconnect.

but i was read about "dualtone-detect-params", and i was add the below command and i do not understand it, but it was solve hte problem:

voice class dualtone-detect-params 1

freq-max-deviation 20

cadence-variation 50

so what it is and how to determine this parameters.

Re: UC520 FXO To Auto Attendant Disconnect Problem

Hi Mohammed,

kindly find the below thread. it will help you

https://supportforums.cisco.com/message/3883674#3883674

if you can't solve the disconnect signal, I think you need to ping the TAC

HTH

Anas

please rate all helpful posts

Re: UC520 FXO To Auto Attendant Disconnect Problem

Hi,

For your Q

Ok. i will try the custom disconnect cptone, but why the current  configuration work when the inbound is pointed to a phone and not work  when the inbound pointed to the auto attendant.

That is because AA is play a continous wav file which won't disconnect the fxo

a phone won't send a continous stream after finishing so the fxo could disconnect the port

If the customer cp tone not working. Contact your telco to subscribe reverse polarity feature. It will do the task

Regards

Haitham

Re: UC520 FXO To Auto Attendant Disconnect Problem

Hello Mohammed,

Best thing you could do is to run a debug on both scenarios to see why when it's answered by an IP phone the call is disconnected and why when is answered by CUE is not disconnected.

I would recommend the following debugs to check if you are receiving call disconnect stimulous from the TELCO.

Router#debug vpm port 0/0/0

Router#debug vpm signal

UC520 FXO To Auto Attendant Disconnect Problem

The configuration is like below:


voice class dualtone-detect-params 1
freq-max-deviation 20
cadence-variation 50

voice class custom-cptone IRIS
dualtone disconnect
  frequency 420 420
  cadence 251 255 245 250 249 250 250 250

voice-port 0/1/2
supervisory disconnect dualtone mid-call
supervisory custom-cptone IRIS
supervisory dualtone-detect-params 1
no battery-reversal
input gain -3
output attenuation -3
compand-type a-law
cptone NL
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 5
timing hookflash-out 500
timing guard-out 300
timing sup-disconnect 50
connection plar opx 498
impedance complex2
caller-id enable
caller-id alerting line-reversal
caller-id alerting dsp-pre-allocate

the current situation is when inbound caller disconnect, the FXO return to "on-hook" immediately regardless where it point, but the problem now with the outbound call, it is disconnect after the second disgit, and when i remove the "timeouts wait-release 5" the outbound success and the inbound take 15 - 2- sec to disconnect after PSTN caller disconncet.


so what can i do?

UC520 FXO To Auto Attendant Disconnect Problem

This sounds like a FXO disconnection probem indeed. The problem here is that the FXO is not receving any disconnect signal, perhaps a Disconnect Tone that the Router sometimes understand and sometimes it doesn't.

It will be necesary to capture debugs on the different scenarios with detailed timestamps to confirm the behavior you described.

If the problem is the disconnect tone, it's neccesary a PCM capture, so you can tune the Custom CP tone configured under the voice-port.

Can you ask your Carrier to use Battery-Reversal or a different suppervisory disconnect?

--
Jorge Armijo

Please remember to rate helpful responses and identify helpful or correct answers.

-- Jorge Armijo Please remember to rate helpful responses and identify helpful or correct answers.
1103
Views
10
Helpful
10
Replies
This widget could not be displayed.