Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

UC520 SIP Trunk

I have a UC520 system that is using a SIP trunk. There is an ISDN for local break out. Everything works fine except for calls that come in via the SIP trunk which then get forwarded back out of the SIP trunk. The call setup works but when the forwarded call is answered there is no voice.

I have attached the UC520 config.

Any help would be appreciated.

Thanks

6 REPLIES
Hall of Fame Super Gold

Re: UC520 SIP Trunk

.

Re: UC520 SIP Trunk

You may actually want to re-enable one of the features:

voice service voip

supp sip refer

-nick

New Member

Re: UC520 SIP Trunk

Hi Nick,

It's the same with supp sip refer on or off. You still get no voice on the forwarded call.

Thanks

Re: UC520 SIP Trunk

I'm guessing you have allow-connections sip-to-sip?

Otherwise, I've seen some issues similar to this where the provider had some problems hairpinning.

It's hard to speculate beyond these common problems without getting on the router, checking the RTP stream, and checking the SIP signaling.

-nick

New Member

Re: UC520 SIP Trunk

Hi Nick

I have the command allow-connections sip to sip on the router.

I have seen posts with people having issues with the SIP provider so I have asked them to debug calls from their end. I have had to configure the use of the g711alaw codec for calls as that is what the provider has asked for so they can debug from their end.

I have attached the response from the SIP trunk provider and debugs for all the ccsip options with and without the supplementary service sip refer command.

thanks

Re: UC520 SIP Trunk

It looks fairly normal - I would probe the provider and maybe get some packet captures to check the audio stream.

-nick

286
Views
0
Helpful
6
Replies