Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

UCCE Communications Manager CUSP

I have a UCCE connected to a CUCM vers 8.6.2  with a cusp running on a ISR gateway. I have a sip trunk to CUSP from CUCM, however when a call comes in , the cusp routes to ICM, ICM then answers the script, sends call to available agent the agent goes reserved however the call drops.

Everything looks okay from configuration  however  I am working with the UCCE team and I am sure something is missing.

I have looked at the CVP SRND guide but I am not 100% sure if all I need is a SIP trunk from CUCM to CUSP. The call flow is actually inbound to a PSTN VXML gateway then the call hits the cusp, then to ICM, ICM transfer call back to cusp and onto CUCM.

Am I missing something?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

UCCE Communications Manager CUSP

Call never goes from CUSP to ICM directly, it goes through CVP. The SIP trunk between CUSP and CUCM is needed as the calls are delivered to CUCM this way, once an agent is selected and reserved by PG, it lets CVP--> CUSP know which label to redirect the call to, in this case the label resides on CUCM (Phone DN) so CVP redirects it to CUSP and CUSP routes it to CUCM across the SIP trunk.  There are many reasons this could fail and is nearly impossible to tell you without looking at logs on CVP, CUSP and CUCM. I would start out with making sure the CSS on the SIP trunk has access to the partition of the phone extension. Also, are you using any sig Digits in your CVP environment? Make sure you take that into consideration as you may need translation patter on CUCM inbound side to strip it.

HTH,

Chris

6 REPLIES
Hall of Fame Super Silver

UCCE Communications Manager CUSP

Call never goes from CUSP to ICM directly, it goes through CVP. The SIP trunk between CUSP and CUCM is needed as the calls are delivered to CUCM this way, once an agent is selected and reserved by PG, it lets CVP--> CUSP know which label to redirect the call to, in this case the label resides on CUCM (Phone DN) so CVP redirects it to CUSP and CUSP routes it to CUCM across the SIP trunk.  There are many reasons this could fail and is nearly impossible to tell you without looking at logs on CVP, CUSP and CUCM. I would start out with making sure the CSS on the SIP trunk has access to the partition of the phone extension. Also, are you using any sig Digits in your CVP environment? Make sure you take that into consideration as you may need translation patter on CUCM inbound side to strip it.

HTH,

Chris

New Member

UCCE Communications Manager CUSP

Chris thanks,,, I have looked at the dial-peers, I have the CSS correct on CUCM, translation inbound is okay. I am going to tray and get all the traces 

The design is that we have two pGs, VXML and CUCM cluster here in Toronto, the UCCE is in US. CUSP in US,

All the config I compared against the UC cluster and looks okay.

I do know that the first error I had was pointing to  no sip trunk, that is fixed,

I iwll say this I don't know if phone is ringing for sure,, I don't see anythinng in CUCM that would indicate is ringing

UCCE does put the phone into reserve.

I am focusing on the link to cucm

Let me get the traces.

Thanks again.

Just a fyi I am working with CDW in the US, they installed the US cluster and UCCE,

New Member

UCCE Communications Manager CUSP

Chris I spent tracing and it looks like the call goes from CVP to CUSP headed for an agent and the CUCM say I dont have that extension

I created the extension as a second line but same symptoms, Here is some of the CUCM trace.

This isn't making sense.

we add '301' as a site code and I strip it at cucm on way back.. I put everything in a single partition with a CSS that has all partitions in it so I know it isn't a CSS plus after 13 years I at least have a handle on that.

We had someone whpo supports the CUCM/UCCE etc from the US and so far we cannot figure it out.

CUSP sip traces also has a 404 doesn't exist. the other weird thing is on way to agent we hear a ' I am sorry the numbber you have dialed is not in service operator 905A1. This is an external intercept and I have all; route patterns in CUCM in a partition that no one has access.

doesnt make sense, Any further thoughts

NVITE

2013/09/09 11:46:48.644|SIPT|0|UDP|OUT|172.29.93.33|5060|CVP-SIP-Trunk|172.31.198.37|5060|3,100,230,1.42364^172.31.198.37^*|84734|599337E1189D11E380E37CAD74389A80-137874160852359963@172.31.207.8|100 Trying

2013/09/09 11:46:48.648|SIPT|53802749|UDP|OUT|172.29.93.33|5060|CVP-SIP-Trunk|172.31.198.37|5060|3,100,230,1.42364^172.31.198.37^*|84735|599337E1189D11E380E37CAD74389A80-137874160852359963@172.31.207.8|404 Not Found

2013/09/09 11:46:48.684|SIPT|53802749|UDP|IN|172.29.93.33|5060|CVP-SIP-Trunk|172.31.198.37|32786|3,100,230,1.42365^172.31.198.37^*|84736|599337E1189D11E380E37CAD74389A80-137874160852359963@172.31.207.8|ACK

2013/09/09 11:46:48.685|CC|REJECT|53802749|53802750|4164782674|30183052506@ca.cucm.agaca.group|30183052506@ca.cucm.agaca.group|1

2013/09/09 11:47:59.350|SIPT|0|UDP|IN|172.29.93.33|5060|CVP-SIP-Trunk|172.31.198.37|32773|3,100,230,1.42367^172.31.198.37^*|84739|84B2A49C189D11E380E47CAD74389A80-137874167922659985@172.31.207.8|INVITE

2013/09/09 11:47:59.351|SIPT|0|UDP|OUT|172.29.93.33|5060|CVP-SIP-Trunk|172.31.198.37|5060|3,100,230,1.42367^172.31.198.37^*|84740|84B2A49C189D11E380E47CAD74389A80-137874167922659985@172.31.207.8|100 Trying

2013/09/09 11:47:59.355|SIPT|53802751|UDP|OUT|172.29.93.33|5060|CVP-SIP-Trunk|172.31.198.37|5060|3,100,230,1.42367^172.31.198.37^*|84741|84B2A49C189D11E380E47CAD74389A80-137874167922659985@172.31.207.8|404 Not Found

2013/09/09 11:47:59.390|SIPT|53802751|UDP|IN|172.29.93.33|5060|CVP-SIP-Trunk|172.31.198.37|32773|3,100,230,1.42368^172.31.198.37^*|84742|84B2A49C189D11E380E47CAD74389A80-137874167922659985@172.31.207.8|ACK

2013/09/09 11:47:59.390|CC|REJECT|53802751|53802752|4164782674|30183052506@ca.cucm.agaca.group|30183052506@ca.cucm.agaca.group|1

2013/09/09 11:48:36.639|SIPT|0|UDP|IN|172.29.93.33|5060|CVP-SIP-Trunk|172.31.199.37|32798|3,100,230,1.42369^172.31.199.37^*|84743|8E243EF2189D11E380E57CAD74389A80-137874171652359999@172.31.207.8|INVITE

New Member

UCCE Communications Manager CUSP

Chris fixed thank you. I needed to put the domain stuff in cucm enterprise parameter " fully qualified domain  name" filed

Thank you

Hall of Fame Super Silver

UCCE Communications Manager CUSP

Yeah, that one got me too once few years back, thanks for the update.

Chris

New Member

Re: UCCE Communications Manager CUSP

Hi Mike / Chris,

i'm  facing issue.

The call was delivering to CTIOS application if we have point the specific target destination(DN) to CUCM server IP address on the CUSP side but the call was not delivering if I have  target destination to CUCM server group On CUSP server.

i have created the SIP Trunk between CUCM server to CUSP and also configured One CUCM server group on CUSP end and added to all the Subcriber.

This is our Call flow.

PSTN------E1------GW-----SIP------CUSP-------SIP------CVP------SIP-------ICM (proces with LABEL)-------SIP-------CVP (prompt)--------SIP-------CUSP--------SIP Trunk----------------CCM-------SCCP---------------IP Phone.

i have Configured Organization Top Level Domain name as cucm.group. ( System---à Enterprise Parameters) on CUCM cluster.

i have debug on CUSP shows that there is no response from CallManager end for the Inivite send.

2013-10-16 21:44:06.687  RX  ACK sip:1111098@sgcusp.erf.thomson.com;transport=udp SIP/2.0

Via: SIP/2.0/UDP 10.22.160.179:5060;branch=z9hG4bKD.QurJDUEhIJf98RE9H9vQ~~41856

Max-Forwards: 70

To: <sip:1111098@sgcusp.erf.thomson.com;transport=udp>;tag=dsb4c219e2

From: "OVERSEAS--CVP_8_5_1_0_1_0_72" <sip:442031806700@10.122.166.179:5060>;tag=dsa8c8fb7c

Call-ID: 5E7DF727359F11E3B99BCF368554EDD5-13819310389052610@10.22.160.179

CSeq: 1 ACK

Content-Length: 0

can you please confirm whether i need to configure server group name which i have configured on CUSP or fully qualified domain name  as "sgcusp.erf.thomson.com".

Thanks in advance.

688
Views
0
Helpful
6
Replies
CreatePlease login to create content