Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

UK CME ISDN Dial Plan Help

Hi

I'm new to the world of CME.  I really could do with some help configuring incoming and outgoing calling, Internal calling works fine.  I have a UK BT ISDN2E line with 2 channels.  At the moment I'm trying to configure a main number in my lab that would be answered by a receptionists.  My assigned number from my provider is 01779478064 if someone could help me get over this hurdle I would be very grateful as I'm a bit confused by the Cisco books and sample dial plans.  Below is my config.  

 

TS-UCME-01#sh run br
Building configuration...


Current configuration : 8797 bytes
!
! Last configuration change at 10:55:40 PCTime Sun May 25 2014 by tsadmin
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TS-UCME-01
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$B2oE$/iD9ywnNv28iVOQx2e2pQ.
!
no aaa new-model
!
clock timezone PCTime 0 0
clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
network-clock-participate wic 0
!
dot11 syslog
ip source-route
!
!
ip cef
ip dhcp excluded-address 192.168.15.1 192.168.15.9
ip dhcp excluded-address 192.168.15.201 192.168.15.254
!
ip dhcp pool UCME
 import all
 network 192.168.15.0 255.255.255.0
 domain-name test.local
 dns-server 8.8.8.8
 option 150 ip 192.168.15.1
 lease 0 10
!
!
!
ip domain name test.local
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type basic-net3
!
!
!
!
voice hunt-group 1 parallel
 list 5401,5402
 pilot 2001
!
!
!
!
voice translation-rule 1
 rule 1 /^.*/ /478064/
!
voice translation-rule 2
 rule 1 /^478064$/ /5402/
!
!
voice translation-profile CALLER_ID_478064
 translate calling 1
!
voice translation-profile In_2
 translate called 2
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-2390328788
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2390328788
 revocation-check none
 rsakeypair TP-self-signed-2390328788
!
!
crypto pki certificate chain TP-self-signed-2390328788
 certificate self-signed 01
!
!
license udi pid CISCO2811 sn FCZ123570ZM
username tsadmin privilege 15 secret 5 $1$h3QN$JDGfI/oPLZGmIRgLk8.K01
!
redundancy
!
!
no ip ftp passive
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description Phone_LAN
 ip address 192.168.15.1 255.255.255.0
 duplex auto
 speed auto
!
interface Service-Engine0/0
 ip unnumbered FastEthernet0/0
 service-module ip address 192.168.15.2 255.255.255.0
 service-module ip default-gateway 192.168.15.1
!
interface FastEthernet0/1
 description Inside LAN
 ip address 192.168.1.253 255.255.255.0
 duplex auto
 speed auto
!
interface BRI0/0/0
 description Test_ISDN_1
 no ip address
 isdn switch-type basic-net3
 isdn protocol-emulate network
 isdn layer1-emulate network
 isdn skipsend-idverify
!
interface BRI0/0/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
!
!
ip route 192.168.15.2 255.255.255.255 Service-Engine0/0
!
!
!
!
!
!
tftp-server flash:phone/sccp6921-6941-6961/SCCP69xx.9-1-1-0.loads alias SCCP69xx.9-1-1-0.loads
tftp-server flash:phone/sccp6921-6941-6961/SCCP69xx.9-1-1-0.zz.sgn alias SCCP69xx.9-1-1-0.zz.sgn
tftp-server flash:phone/sccp6921-6941-6961/DSP69xx.0-0-0-4.zz.sgn alias DSP69xx.0-0-0-4.zz.sgn
tftp-server flash:phone/sccp6921-6941-6961/BOOT69xx.0-0-0-14.zz.sgn alias BOOT69xx.0-0-0-14.zz.sgn
tftp-server flash:phone/sccp7905/CP7905080003SCCP070409A.sbin alias CP7905080003SCCP070409A.sbin
tftp-server flash:phone/sccp7905/CP7905080003SCCP070409A.zup alias CP7905080003SCCP070409A.zup
tftp-server flash:phone/sccp7906-7911/SCCP11.9-1-1SR1S.loads alias SCCP11.9-1-1SR1S.loads
tftp-server flash:phone/sccp7906-7911/apps11.9-1-1TH1-16.sbn alias apps11.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7906-7911/cnu11.9-1-1TH1-16.sbn alias cnu11.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7906-7911/cvm11sccp.9-1-1TH1-16.sbn alias cvm11sccp.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7906-7911/dsp11.9-1-1TH1-16.sbn alias dsp11.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7906-7911/jar11sccp.9-1-1TH1-16.sbn alias jar11sccp.9-1-1TH1-16.sbn
tftp-server flash:term06.default.loads alias term06.default.loads
tftp-server flash:term11.default.loads alias term11.default.loads
tftp-server flash:phone/sccp7915/B015-1-0-4.SBN alias B015-1-0-4.SBN
tftp-server flash:phone/sccp7916/B016-1-0-4.SBN alias B016-1-0-4.SBN
tftp-server flash:P00307020200.bin alias P00307020200.bin
tftp-server flash:phone/sccp7940-7960/P00308010200.loads alias P00308010200.loads
tftp-server flash:phone/sccp7940-7960/P00308010200.bin alias P00308010200.bin
tftp-server flash:phone/sccp7940-7960/P00308010200.sb2 alias P00308010200.sb2
tftp-server flash:phone/sccp7940-7960/P00308010200.sbn alias P00308010200.sbn
tftp-server flash:phone/sccp7941-7961/SCCP41.9-1-1SR1S.loads alias SCCP41.9-1-1SR1S.loads
tftp-server flash:phone/sccp7941-7961/apps41.9-1-1TH1-16.sbn alias apps41.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7941-7961/cnu41.9-1-1TH1-16.sbn alias cnu41.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7941-7961/cvm41sccp.9-1-1TH1-16.sbn alias cvm41sccp.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7941-7961/dsp41.9-1-1TH1-16.sbn alias dsp41.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7941-7961/jar41sccp.9-1-1TH1-16.sbn alias jar41sccp.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7941-7961/term41.default.loads alias term41.default.loads
tftp-server flash:phone/sccp7941-7961/term61.default.loads alias term61.default.loads
!
control-plane
!
!
voice-port 0/0/0
 description Test_ISDN_1
!
voice-port 0/0/1
!
!
!
mgcp profile default
!
!
dial-peer voice 1 voip
 destination-pattern 5499
 session protocol sipv2
 session target ipv4:192.168.15.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 2 voip
 destination-pattern 5498
 session protocol sipv2
 session target ipv4:192.168.15.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 3 pots
 destination-pattern 901779T
!
dial-peer voice 4 pots
 description In
 translation-profile incoming In_2
 incoming called-number 478064
 direct-inward-dial
 port 0/0/0
!
!
!
!
telephony-service
 no auto-reg-ephone
 max-ephones 10
 max-dn 10
 ip source-address 192.168.15.1 port 2000
 system message Tekserv IT
 cnf-file location flash:
 load 7915-12 B015-1-0-4.SBN
 load 7915-24 B015-1-0-4.SBN
 load 7916-12 B016-1-0-4.SBN
 load 7916-24 B016-1-0-4.SBN
 load 7906 SCCP11.8-3-3S.loads
 load 7911 SCCP11.8-3-3S.loads
 load 7920 cmterm_7920.4.0-02-00.bin
 load 7960-7940 P00307020200.loads
 load 7941 SCCP41.9-1-1SR1S.loads
 load 7941GE SCCP41.9-1-1SR1S.loads
 load 7961 SCCP41.9-1-1SR1S.loads
 load 7961GE SCCP41.9-1-1SR1S.loads
 load 6921 SCCP69xx.9-1-1-0.loads
 load 6941 SCCP69xx.9-1-1-0.loads
 load 6961 SCCP69xx.9-1-1-0.loads
 date-format dd-mm-yy
 voicemail 5499
 max-conferences 8 gain -6
 hunt-group logout HLog
 moh flash:/Cisco_CallManagerOHM.au
 multicast moh 239.1.1.1 port 16384 route 192.168.1.253 192.168.15.1
 web admin system name phoneadmin password phoneadmin
 dn-webedit
 transfer-system full-consult
 night-service code *1234
 night-service day Sun 07:31 07:30
 night-service day Mon 17:00 07:30
 night-service day Tue 17:00 07:30
 night-service day Wed 17:00 07:30
 night-service day Thu 17:00 07:30
 night-service day Fri 17:00 07:30
 night-service day Sat 07:31 07:30
 directory entry 1 907890757673 name Phil Rennie - Mobile
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn-template  1
 call-forward busy 5499
 call-forward noan 5499 timeout 18
!
!
ephone-template  1
 softkeys hold  Join Newcall Resume Select
 softkeys idle  Pickup Dnd Cfwdall Gpickup Redial Newcall Login
 softkeys seized  Redial Endcall Cfwdall Pickup Gpickup Callback
 softkeys alerting  Acct Callback Endcall
 softkeys connected  Hold Endcall Trnsfer Confrn Acct Park
!
!
ephone-dn  1  dual-line
 number 5401
 pickup-group 1
 label Ext - 5401
 description Phil Rennie
 name Phil Rennie
 call-forward busy 5499
 call-forward noan 5499 timeout 10
 ephone-dn-template 1
!
!
ephone-dn  2  dual-line
 number 5402
 pickup-group 1
 label Ext - 5402
 description Doug Drury
 name Doug Drury
 call-forward busy 5499
 call-forward noan 5499 timeout 10
 ephone-dn-template 1
!
!
ephone-dn  3
 number 1
 name All
 paging ip 239.0.0.1 port 2000
!
!
ephone-dn  4  dual-line
 number 5403
 label Ext - 5403
 description Test
 name test test
 ephone-dn-template 1
!
!
ephone  1
 device-security-mode none
 mac-address 0012.00EC.B345
 ephone-template 1
 username "phil"
 paging-dn 3
 type 7940
 button  1:1
!
!
!
ephone  2
 device-security-mode none
 mac-address 0012.0101.0C75
 ephone-template 1
 username "doug" password 123456
 paging-dn 3
 type 7940
 button  1:2
 pin 123456
!
!
!
ephone  3
 device-security-mode none
 mac-address 001B.2A89.88B0
 ephone-template 1
 username "test" password 123456
 type 7961
 button  1:4
 pin 123456
!
!
!
!
line con 0
line aux 0
line 194
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
 transport output telnet ssh
!
scheduler allocate 20000 1000
ntp update-calendar
ntp server 194.164.127.6 prefer source FastEthernet0/1
end

TS-UCME-01#

 

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

Hi Douglas.If your ISDN is

Hi Douglas.

If your ISDN is connected to BRI 0/0/0 interface, please modify your config as follows:

remove  isdn protocol-emulate network
 isdn layer1-emulate network 

Add

isdn point-to-point-setup

isdn static-tei 0

 

See if it makes any difference

 

HTH

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"
20 REPLIES
VIP Gold

Incoming calls:If someone

Incoming calls:
If someone dial 01779478064 from outside then on which extension it should connect ?
What digits service provider is sending to CME for incoming calls ? You can find it using "debug isdn q931" command.

Outbound calls: You can apply below changes in dial-peer 3 if you are sending calls out through port 0/0/0 and access code is 9.


dial-peer voice 3 pots
destination-pattern 9T
port 0/0/0

 

Suresh

New Member

Hi Suresh,Thanks for getting

Hi Suresh,

Thanks for getting back to me so soon.

when someone from the outside calls it needs to ring extension 5402.

 

I've made the adjustments you suggested and the desk phone will say "Ring Out" but the call doesn't connect.  I've enabled the debug and made an outgoing call and got the below outout 

TS-UCME-01#debug isdn q931
debug isdn q931 is              ON.
TS-UCME-01#
TS-UCME-01#
TS-UCME-01#
*May 25 12:07:24.423: ISDN BR0/0/0 Q931: Applying typeplan for sw-type 0x1 is 0x                                                                                                                                                             0 0x0, Calling num 5402
*May 25 12:07:24.423: ISDN BR0/0/0 Q931: Sending SETUP  callref = 0x0002 callID                                                                                                                                                              = 0x8004 switch = basic-net3 interface = Network
*May 25 12:07:24.423: ISDN BR0/0/0 Q931: TX -> SETUP pd = 8  callref = 0x02
        Bearer Capability i = 0x8090A2
                Standard = CCITT
                Transfer Capability = Speech
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x8A
                Exclusive, B2
        Progress Ind i = 0x8183 - Origination address is non-ISDN
        Display i = 'Doug Drury'
        Calling Party Number i = 0x0080, '5402'
                Plan:Unknown, Type:Unknown
        Called Party Number i = 0x80, '01771622598'
                Plan:Unknown, Type:Unknown
*May 25 12:07:28.423: ISDN BR0/0/0 Q931: TX -> SETUP pd = 8  callref = 0x02
        Bearer Capability i = 0x8090A2
                Standard = CCITT
                Transfer Capability = Speech
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x8A
                Exclusive, B2
        Progress Ind i = 0x8183 - Origination address is non-ISDN
        Display i = 'Doug Drury'
        Calling Party Number i = 0x0080, '5402'
                Plan:Unknown, Type:Unknown
        Called Party Number i = 0x80, '01771622598'
                Plan:Unknown, Type:Unknown
*May 25 12:07:28.423: ISDN BR0/0/0 **ERROR**: CCBRI_Go: NO CCB Src->L3 call id 0                                                                                                                                                             x8004, event 0x95 ces 0
*May 25 12:07:28.423: ISDN  **ERROR**: Module-CCBRI  Function-_Go  Error-Event r                                                                                                                                                             eceived for an unrecognized call.  Data- 95,  0
*May 25 12:07:32.423: ISDN BR0/0/0 **ERROR**: CCBRI_Go: NO CCB Src->L3 call id 0                                                                                                                                                             x8004, event 0xC4 ces 0
*May 25 12:07:32.423: ISDN  **ERROR**: Module-CCBRI  Function-_Go  Error-Event r                                                                                                                                                             eceived for an unrecognized call.  Data- C4,  0
*May 25 12:07:32.455: ISDN BR0/0/0 **ERROR**: L3_ProcessEvent: UNEXPECTED event                                                                                                                                                              - 0x84 state 22
*May 25 12:07:32.455: ISDN BR0/0/0 **ERROR**: Ux_BadMsg: Invalid Message for cal                                                                                                                                                             l state 22, call id 0x8004, call ref 0x2, event 0x84
*May 25 12:07:32.455: ISDN  **ERROR**: Module-l3_sdl_u  Function-Ux_BadMsg  Erro                                                                                                                                                             r-Source ID =  400  Event =  84
TS-UCME-01#
TS-UCME-01#

 

 

VIP Gold

could you please post "sh

could you please post "sh isdn status".

Inbound calls:

If isdn status is active then plz attach "debug isdn q931" for incoming call so can get to know what service provider is sending exactly.

 

Suresh

 

New Member

Sh isdn statusTS-UCME-01#sh

Sh isdn status

TS-UCME-01#sh isdn status
Global ISDN Switchtype = basic-net3
ISDN BRI0/0/0 interface
        ******* Network side configuration *******
        dsl 0, interface ISDN Switchtype = basic-net3
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 255, SAPI = 0, State = TEI_ASSIGNED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
        CCB:callid=8003, sapi=0, ces=1, B-chan=1, calltype=VOICE
        CCB:callid=8004, sapi=0, ces=1, B-chan=2, calltype=VOICE
    Active dsl 0 CCBs = 2
    The Free Channel Mask:  0x80000000
ISDN BRI0/0/1 interface
        dsl 1, interface ISDN Switchtype = basic-net3
    Layer 1 Status:
        DEACTIVATED
    Layer 2 Status:
        Layer 2 NOT Activated
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 1 CCBs = 0
    The Free Channel Mask:  0x8000

 

When I made an incoming call I got the below outout

TS-UCME-01#BAD FRAME()BAD FRAME()BAD FRAME()BAD FRAME()BAD FRAME()BAD FRAME()BAD FRAME()BAD FRAME()BAD FRAME()BAD FRAME()BAD FRAME()BAD FRAME()BAD FRAME()BAD FRAME()BAD FRAME()

 

I also made an outgoing call and got the below

*May 25 13:12:42.806: ISDN BR0/0/0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Calling num 5402
*May 25 13:12:42.806: ISDN BR0/0/0 **ERROR**: CC_CHAN_GetIdleChanbri: All channels busy

 

The service provider is British Telecom

VIP Gold

That means link is not up,

That means link is not up, layer 2 status should be "MULTIPLE_FRAME_ESTABLISHED".

please refer below link..

http://www.cisco.com/c/en/us/support/docs/dial-access/integrated-services-digital-networks-isdn-channel-associated-signaling-cas/5705-bri-sh-isdn-stat.html

Suresh

New Member

I've entered the below

I've entered the below commands

compand-type a-law

cptone GB

If layer 2 is no active is it a problem with my configuration or a fault with the service provider?

Thanks

VIP Gold

Issue might be at either end,

Issue might be at either end, debug isdn q921 can help you to narrow down the problem.

 

Suresh

New Member

I've run the sh isdn status

I've run the sh isdn status command and I can see layer 2 is showing at not activated now after a reboot of the cme router.  I've attached an up to date copy of the config

TS-UCME-01#sh isdn status

Global ISDN Switchtype = basic-net3
ISDN BRI0/0/0 interface
        ******* Network side configuration *******
        dsl 0, interface ISDN Switchtype = basic-net3
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        Layer 2 NOT Activated
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x80000003
ISDN BRI0/0/1 interface
        dsl 1, interface ISDN Switchtype = basic-net3
    Layer 1 Status:
        DEACTIVATED
    Layer 2 Status:
        Layer 2 NOT Activated
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 1 CCBs = 0
    The Free Channel Mask:  0x80000003
    Total Allocated ISDN CCBs = 0
TS-UCME-01#

 

          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

AIM Module in slot: 0
Service Engine AIM: 0
        Hardware Revision        : 1.0
        Top Assy. Part Number    : 800-20063-06
        Board Revision           : B0
        Deviation Number         : 0
        Fab Version              : 05
        PCB Serial Number        : FOC12420XYQ
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Product (FRU) Number     : AIM-CUE
        Version Identifier       : V03
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 03 8E 41 01 00 C0 46 03 20 00 4E 5F 06
          0x10: 42 42 30 88 00 00 00 00 02 05 C1 8B 46 4F 43 31
          0x20: 32 34 32 30 58 59 51 03 00 81 00 00 00 00 04 00
          0x30: CB 87 41 49 4D 2D 43 55 45 89 56 30 33 20 FF FF
          0x40: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF


TS-UCME-01#sh run
Building configuration...


Current configuration : 10171 bytes
!
! Last configuration change at 15:03:38 PCTime Sun May 25 2014 by tsadmin
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TS-UCME-01
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$B2oE$/iD9ywnNv28iVOQx2e2pQ.
!
no aaa new-model
!
clock timezone PCTime 0 0
clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
network-clock-participate wic 0
!
dot11 syslog
ip source-route
!
!
ip cef
ip dhcp excluded-address 192.168.15.1 192.168.15.9
ip dhcp excluded-address 192.168.15.201 192.168.15.254
!
ip dhcp pool UCME
 import all
 network 192.168.15.0 255.255.255.0
 domain-name Tekserv.local
 dns-server 8.8.8.8
 option 150 ip 192.168.15.1
 lease 0 10
!
!
!
ip domain name tekserv.local
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type basic-net3
!
!
!
!
voice hunt-group 1 parallel
 list 5401,5402
 pilot 2001
!
!
!
!
voice translation-rule 1
 rule 1 /^.*/ /478064/
!
voice translation-rule 2
 rule 1 /^478064$/ /5402/
!
!
voice translation-profile CALLER_ID_478064
 translate calling 1
!
voice translation-profile In_2
 translate called 2
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-2390328788
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2390328788
 revocation-check none
 rsakeypair TP-self-signed-2390328788
!
!
crypto pki certificate chain TP-self-signed-2390328788
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32333930 33323837 3838301E 170D3134 30353132 30393234
  35325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 33393033
  32383738 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  81009CC8 D35F92CF 3159FEE6 3B96DFAF 5D7BF416 141B98E5 A684506D E862C23B
  80453261 E040DFF6 FE899BDB 7B3A116B 1F68AA7E 782A75F6 5CC21DDE B1CA2A97
  F596261B 2DF7BA88 45DC86BB CBC5D74F 68884099 2FCD2082 B82985F3 A00896F3
  2A41F9A7 2D368070 A71BB16F A915B3A7 5D5C4120 A7095506 85768AC6 9FD09A06
  67FF0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 141BEB36 DC11B612 D9F12D68 D62B5BB0 34EE278B 9E301D06
  03551D0E 04160414 1BEB36DC 11B612D9 F12D68D6 2B5BB034 EE278B9E 300D0609
  2A864886 F70D0101 05050003 81810053 819C766F 174DA88E EC3A5535 305C17D5
  EAEA6518 6F6CFF57 B1AE66A3 85F892C6 49253105 E1735271 CB7226B6 213B1647
  B0F9FAC6 3CA1ADEE 2367F15B 185D4BC7 6E05218F 9DE527FB 621CBD41 0E367C79
  2947FE31 BCC07820 663C8AB2 C8CADF5F 6F25C051 E61E1B66 F73C5DB1 6F4A9505
  32966205 206DD62A 03AC01B7 DB75B8
        quit
!
!
license udi pid CISCO2811 sn FCZ123570ZM
username tsadmin privilege 15 secret 5 $1$h3QN$JDGfI/oPLZGmIRgLk8.K01
!
redundancy
!
!
no ip ftp passive
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description Phone_LAN
 ip address 192.168.15.1 255.255.255.0
 duplex auto
 speed auto
!
interface Service-Engine0/0
 ip unnumbered FastEthernet0/0
 service-module ip address 192.168.15.2 255.255.255.0
 service-module ip default-gateway 192.168.15.1
!
interface FastEthernet0/1
 description Inside LAN
 ip address 192.168.1.253 255.255.255.0
 duplex auto
 speed auto
!
interface BRI0/0/0
 description Tekserv_ISDN_1
 no ip address
 isdn switch-type basic-net3
 isdn protocol-emulate network
 isdn layer1-emulate network
 isdn skipsend-idverify
!
interface BRI0/0/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
!
!
ip route 192.168.15.2 255.255.255.255 Service-Engine0/0
!
!
!
!
!
!
tftp-server flash:phone/sccp6921-6941-6961/SCCP69xx.9-1-1-0.loads alias SCCP69xx.9-1-1-0.loads
tftp-server flash:phone/sccp6921-6941-6961/SCCP69xx.9-1-1-0.zz.sgn alias SCCP69xx.9-1-1-0.zz.sgn
tftp-server flash:phone/sccp6921-6941-6961/DSP69xx.0-0-0-4.zz.sgn alias DSP69xx.0-0-0-4.zz.sgn
tftp-server flash:phone/sccp6921-6941-6961/BOOT69xx.0-0-0-14.zz.sgn alias BOOT69xx.0-0-0-14.zz.sgn
tftp-server flash:phone/sccp7905/CP7905080003SCCP070409A.sbin alias CP7905080003SCCP070409A.sbin
tftp-server flash:phone/sccp7905/CP7905080003SCCP070409A.zup alias CP7905080003SCCP070409A.zup
tftp-server flash:phone/sccp7906-7911/SCCP11.9-1-1SR1S.loads alias SCCP11.9-1-1SR1S.loads
tftp-server flash:phone/sccp7906-7911/apps11.9-1-1TH1-16.sbn alias apps11.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7906-7911/cnu11.9-1-1TH1-16.sbn alias cnu11.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7906-7911/cvm11sccp.9-1-1TH1-16.sbn alias cvm11sccp.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7906-7911/dsp11.9-1-1TH1-16.sbn alias dsp11.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7906-7911/jar11sccp.9-1-1TH1-16.sbn alias jar11sccp.9-1-1TH1-16.sbn
tftp-server flash:term06.default.loads alias term06.default.loads
tftp-server flash:term11.default.loads alias term11.default.loads
tftp-server flash:phone/sccp7915/B015-1-0-4.SBN alias B015-1-0-4.SBN
tftp-server flash:phone/sccp7916/B016-1-0-4.SBN alias B016-1-0-4.SBN
tftp-server flash:P00307020200.bin alias P00307020200.bin
tftp-server flash:phone/sccp7940-7960/P00308010200.loads alias P00308010200.loads
tftp-server flash:phone/sccp7940-7960/P00308010200.bin alias P00308010200.bin
tftp-server flash:phone/sccp7940-7960/P00308010200.sb2 alias P00308010200.sb2
tftp-server flash:phone/sccp7940-7960/P00308010200.sbn alias P00308010200.sbn
tftp-server flash:phone/sccp7941-7961/SCCP41.9-1-1SR1S.loads alias SCCP41.9-1-1SR1S.loads
tftp-server flash:phone/sccp7941-7961/apps41.9-1-1TH1-16.sbn alias apps41.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7941-7961/cnu41.9-1-1TH1-16.sbn alias cnu41.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7941-7961/cvm41sccp.9-1-1TH1-16.sbn alias cvm41sccp.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7941-7961/dsp41.9-1-1TH1-16.sbn alias dsp41.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7941-7961/jar41sccp.9-1-1TH1-16.sbn alias jar41sccp.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7941-7961/term41.default.loads alias term41.default.loads
tftp-server flash:phone/sccp7941-7961/term61.default.loads alias term61.default.loads
!
control-plane
!
!
voice-port 0/0/0
 compand-type a-law
 cptone GB
 description Tekserv_ISDN_1
!
voice-port 0/0/1
!
!
!
mgcp profile default
!
!
dial-peer voice 1 voip
 destination-pattern 5499
 session protocol sipv2
 session target ipv4:192.168.15.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 2 voip
 destination-pattern 5498
 session protocol sipv2
 session target ipv4:192.168.15.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 3 pots
 description Out
 destination-pattern 9T
 port 0/0/0
!
dial-peer voice 4 pots
 description In
 translation-profile incoming In_2
 incoming called-number 478064
 direct-inward-dial
 port 0/0/0
!
!
!
!
telephony-service
 no auto-reg-ephone
 max-ephones 10
 max-dn 10
 ip source-address 192.168.15.1 port 2000
 system message Tekserv IT
 cnf-file location flash:
 load 7915-12 B015-1-0-4.SBN
 load 7915-24 B015-1-0-4.SBN
 load 7916-12 B016-1-0-4.SBN
 load 7916-24 B016-1-0-4.SBN
 load 7906 SCCP11.8-3-3S.loads
 load 7911 SCCP11.8-3-3S.loads
 load 7920 cmterm_7920.4.0-02-00.bin
 load 7960-7940 P00307020200.loads
 load 7941 SCCP41.9-1-1SR1S.loads
 load 7941GE SCCP41.9-1-1SR1S.loads
 load 7961 SCCP41.9-1-1SR1S.loads
 load 7961GE SCCP41.9-1-1SR1S.loads
 load 6921 SCCP69xx.9-1-1-0.loads
 load 6941 SCCP69xx.9-1-1-0.loads
 load 6961 SCCP69xx.9-1-1-0.loads
 date-format dd-mm-yy
 voicemail 5499
 max-conferences 8 gain -6
 hunt-group logout HLog
 moh flash:/Cisco_CallManagerOHM.au
 multicast moh 239.1.1.1 port 16384 route 192.168.1.253 192.168.15.1
 web admin system name phoneadmin password phoneadmin
 dn-webedit
 transfer-system full-consult
 night-service code *1234
 night-service day Sun 07:31 07:30
 night-service day Mon 17:00 07:30
 night-service day Tue 17:00 07:30
 night-service day Wed 17:00 07:30
 night-service day Thu 17:00 07:30
 night-service day Fri 17:00 07:30
 night-service day Sat 07:31 07:30
 directory entry 1 907890757673 name Phil Rennie - Mobile
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn-template  1
 call-forward busy 5499
 call-forward noan 5499 timeout 18
!
!
ephone-template  1
 softkeys hold  Join Newcall Resume Select
 softkeys idle  Pickup Dnd Cfwdall Gpickup Redial Newcall Login
 softkeys seized  Redial Endcall Cfwdall Pickup Gpickup Callback
 softkeys alerting  Acct Callback Endcall
 softkeys connected  Hold Endcall Trnsfer Confrn Acct Park
!
!
ephone-dn  1  dual-line
 number 5401
 pickup-group 1
 label Ext - 5401
 description Phil Rennie
 name Phil Rennie
 call-forward busy 5499
 call-forward noan 5499 timeout 10
 ephone-dn-template 1
!
!
ephone-dn  2  dual-line
 number 5402
 pickup-group 1
 label Ext - 5402
 description Doug Drury
 name Doug Drury
 call-forward busy 5499
 call-forward noan 5499 timeout 10
 ephone-dn-template 1
!
!
ephone-dn  3
 number 1
 name All
 paging ip 239.0.0.1 port 2000
!
!
ephone-dn  4  dual-line
 number 5403
 label Ext - 5403
 description Test
 name test test
 ephone-dn-template 1
!
!
ephone  1
 device-security-mode none
 mac-address 0012.00EC.B345
 ephone-template 1
 username "phil"
 paging-dn 3
 type 7940
 button  1:1
!
!
!
ephone  2
 device-security-mode none
 mac-address 0012.0101.0C75
 ephone-template 1
 username "doug" password 123456
 paging-dn 3
 type 7940
 button  1:2
 pin 123456
!
!
!
ephone  3
 device-security-mode none
 mac-address 001B.2A89.88B0
 ephone-template 1
 username "test" password 123456
 type 7961
 button  1:4
 pin 123456
!
!
!
!
line con 0
line aux 0
line 194
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
 transport output telnet ssh
!
scheduler allocate 20000 1000
ntp update-calendar
ntp server 194.164.127.6 prefer source FastEthernet0/1
end

TS-UCME-01#

VIP Gold

Below things you can try but

Below things you can try but you need to attach debug isdn q921.

1. clear interface bri <number>

2. isdn tei-negotiation first-call    -- under the BRI interface

or

isdn tei-negotiation power-up

3. try to change the switch type.

 

Suresh

New Member

I called the service provider

I called the service provider and they could see there was fault on the line and have cleared it.  I've also tried the suggested commands and can made ingoing and outgoing calls.

Outgoing Call
*May 26 09:09:56.980: ISDN BR0/0/0 Q921: Net TX -> UI sapi=0 tei=127
*May 26 09:10:00.980: ISDN BR0/0/0 Q921: Net TX -> UI sapi=0 tei=127

Incoming Call
*May 26 09:10:30.984: ISDN BR0/0/0 Q921: Net RX <- BAD FRAME(0x02017F)
*May 26 09:10:32.992: ISDN BR0/0/0 Q921: Net RX <- BAD FRAME(0x02017F)
*May 26 09:10:34.004: ISDN BR0/0/0 Q921: Net RX <- BAD FRAME(0x02017F)
*May 26 09:11:07.941: ISDN BR0/0/0 Q921: Net RX <- BAD FRAME(0x02017F)
*May 26 09:11:08.937: ISDN BR0/0/0 Q921: Net RX <- BAD FRAME(0x02017F)
*May 26 09:11:09.949: ISDN BR0/0/0 Q921: Net RX <- BAD FRAME(0x02017F)
*May 26 09:11:10.957: ISDN BR0/0/0 Q921: Net RX <- BAD FRAME(0x02017F)

VIP Gold

please post the "show isdn

please post the "show isdn status" again, and put "isdn incoming-voice voice " under BRI interface.

 

Suresh

New Member

I've added the suggested

I've added the suggested command.  I do appropriate your help

TS-UCME-01#sh isdn status
Global ISDN Switchtype = basic-net3
ISDN BRI0/0/0 interface
        ******* Network side configuration *******
        dsl 0, interface ISDN Switchtype = basic-net3
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 255, SAPI = 0, State = TEI_ASSIGNED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x80000003
ISDN BRI0/0/1 interface
        dsl 1, interface ISDN Switchtype = basic-net3
    Layer 1 Status:
        DEACTIVATED
    Layer 2 Status:
        Layer 2 NOT Activated
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 1 CCBs = 0
    The Free Channel Mask:  0x80000003
    Total Allocated ISDN CCBs = 0
TS-UCME-01#

VIP Gold

Layer 2 still is not up, you

Layer 2 still is not up, you need to follow BRI Layer 2 troubleshooting doc and need to work with service provider to get it up.

 

Suresh

Hi DouglasUnder BRI Interface

Hi Douglas

Under BRI Interface, try to add " isdn static-tei 0" and post a show isdn status again

Thanks

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"
New Member

Hi Carlo,I've just added the

Hi Carlo,

I've just added the sugested command.  Below is the sh isdn status

 

TS-UCME-01#sh isdn stat
Global ISDN Switchtype = basic-net3
ISDN BRI0/0/0 interface
        ******* Network side configuration *******
        dsl 0, interface ISDN Switchtype = basic-net3
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x80000003
ISDN BRI0/0/1 interface
        dsl 1, interface ISDN Switchtype = basic-net3
    Layer 1 Status:
        SHUTDOWN
    Layer 2 Status:
        Layer 2 NOT Activated
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 1 CCBs = 0
    The Free Channel Mask:  0x00000000
    Total Allocated ISDN CCBs = 0

Hi Douglas.If your ISDN is

Hi Douglas.

If your ISDN is connected to BRI 0/0/0 interface, please modify your config as follows:

remove  isdn protocol-emulate network
 isdn layer1-emulate network 

Add

isdn point-to-point-setup

isdn static-tei 0

 

See if it makes any difference

 

HTH

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"
New Member

Hi Carlo,Yes all works

Hi Carlo,

Yes all works perfectly!  Thanks you very much for your help.

Thanks

Douglas

Glad that helped

Glad that helped Douglas

Thanks for nice rating

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"
VIP Gold

good to know that :-) +5 to

good to know that :-) +5 to Carlo.

 

Suresh

VIP Gold

Also put below commands under

Also put below commands under voice port 0/0/0 and test..

compand-type a-law

cptone <as per location>

 

Suresh

368
Views
5
Helpful
20
Replies