Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Unable to Call Back from Missed Call Directory

Hi Everyone,

I have had a complaint from our office in Brussels that they are not able to call external people back using the missed call directory.

It appears to be because the leading 0 from the calling number is missing. For example:

 

Call comes in from 025001500, the number that is listed in the directory is 25001500. Internal calls/callback works fine.

Can anyone give me any pointers? Using CM v10.

Many thanks

Phil
 

6 REPLIES
Cisco Employee

Hi Phil, ++ Can you provide

Hi Phil,

 

++ Can you provide me complete call flow ex: IP Phone -SCCP- CUCM -- SIP Trunk -- VG

++ What number do you see in Missed Calls

++ Are you trying to dial out to PSTN or Internal Phone

 

++ Can you grab Detailed CCM SDL trace for a sample call along with call details. Screen shot from IP Phone or Video Recording.

 

Trying using translation pattern to prefix leading digits.

 

Regards,

 

Mohammed Noor

 

New Member

Call Flow is: PSTN > MGCP GW

Call Flow is:

 

PSTN > MGCP GW > CUCM > IP Phone (SCCP). 

So as mentioned, if the calling number is 025001500, when scrolling through the directory and trying to call back it just lists the number as 25001500 without the leading 0. 

So the user is trying to call back externally to the PSTN. I dont have the ability to get any traces today but think this is just a config issue somewhere. Hope this is of some help?

Cisco Employee

Hi Phil,If i have understood

Hi Phil,

If i have understood correctly while phone rings you see number as "025001500" and on Missed calls you see it a s"25001500". Checki if you have any Calling Party Transformation configured on the phone which is striping "0". Try removing it.

HTH,

Regards,

Mohammed Noor

 

New Member

When the call is coming in

When the call is coming in from the PSTN, from say a mobile: 0494571544 it is showing as ringing on the phone with the number 494571544. No leading 0. 

I have looked and cannot seem to see any Calling Party Transformations that would appear to remove a 0. I did a Route Plan Report searching for all patterns that start 4, 04 or 0.04 and the only results were the route patterns to allow internal user to reach the PSTN GW to make calls to those numbers.

Am I looking in the right place?

you need translation rule for

you need translation rule for incoming calling numbers. 

you need to add leading 0 to incoming calling numbers. because probably provider some where stripes leading 0 

 

I had problem like this but I have h323 voice gateway to pstn

and I dont know exactly how to fix it on mgcp gateway

 

in my case provider sends me leading digit sometimes twice, sometimes one, sometimes no.

I made translation rule to do correct incoming calling number in any case.

Hi Phil, will the inbound

Hi Phil,

 

will the inbound call match any translation pattern before it is delivered to IP phone extensions?

 

if so, you can try prefix the leading 0 there under "Calling Party Transformations"

//Suresh Please rate all the useful posts.
328
Views
0
Helpful
6
Replies