Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

Unable to Configure E1 Line

Hi Guys,

I have a CME router 2911. The router has two PVDM cards. One card is a PVDM 64 on slot 0 and the other card is a PVDM 32 on slot 1.

I am configuring two E1 lines to be used on the router. On the first E1 controller I can configure primary pri-group timeslots 1-31 but on the other E1 controller, when I try to do the same, it tells me I have insufficient resources and therefore I am only able to configure pri-group timeslots 1-16.

I thought with two PVDM resources (64 and 32) I would be able to configure 30 channels on both E1 controllers.

What could be issue? Is it PVDM related? When I do the show voice dsp voice group all, below is the output I get. I can see that there are no DSP groups on slot 1 where the PVDM 32 is connected. How do I activate DSPs on this PVDM?

CMS_VG#show voice dsp group all

DSP groups on slot 0:

dsp 1:

  State: UP, firmware: 33.1.0

  Max signal/voice channel: 32/32

  Max credits: 480, Voice credits: 480, Video credits: 0

  num_of_sig_chnls_allocated: 32

  Transcoding channels allocated: 0

  Group: FLEX_GROUP_VOICE, complexity: FLEX

    Shared credits: 480, reserved credits: 0

  Slot: 0

  Device idx: 0

  PVDM Slot: 0

  Dsp Type: SP2600

dsp 2:

  State: UP, firmware: 33.1.0

  Max signal/voice channel: 32/32

  Max credits: 480, Voice credits: 480, Video credits: 0

  num_of_sig_chnls_allocated: 17

  Transcoding channels allocated: 0

  Group: FLEX_GROUP_VOICE, complexity: FLEX

    Shared credits: 288, reserved credits: 0

  Group: FLEX_GROUP_CONF, complexity: CONFERENCE

    Shared credits: 0, reserved credits: 192

  Slot: 0

  Device idx: 0

  PVDM Slot: 0

  Dsp Type: SP2600

dsp 7:

  State: UP, firmware: 33.1.0

  Max signal/voice channel: 32/32

  Max credits: 480, Voice credits: 480, Video credits: 0

  num_of_sig_chnls_allocated: 0

  Transcoding channels allocated: 0

  Group: FLEX_GROUP_CONF, complexity: CONFERENCE

    Shared credits: 0, reserved credits: 480

  Slot: 0

  Device idx: 0

  PVDM Slot: 1

  Dsp Type: SP2600

DSP groups on slot 1:

This command is not applicable to slot 1

  0 DSP resource allocation failure

Below is the show run for the router.

aaa session-id common

clock timezone EAT 3 0

network-clock-participate wic 1

!

ip cef

!

!

!

!

!

!

no ip domain lookup

ip domain name catalystprincipal.com

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-net5

!

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

voice rtp send-recv

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service sip handle-replaces

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

sip

  registrar server

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g729br8

codec preference 3 g711alaw

codec preference 4 g711ulaw

!

!

voice iec syslog

voice register global

mode cme

source-address 192.168.10.1 port 5060

max-dn 5

max-pool 5

dialplan-pattern 1 9.T extension-length 3

dialplan-pattern 2 8.T extension-length 3

tftp-path flash:

create profile sync 0001884471822112

!

voice register dn  1

number 100

name ATA

label 100

mwi

!

voice register dn  2

number 101

name ATA

label 101

mwi

!

voice register pool  1

id mac C062.6B62.A3C7

type ATA-187

number 1 dn 1

number 2 dn 2

codec g711ulaw

!

!

!

voice translation-rule 1

rule 1 /^730142/ //

rule 2 /^4296/ //

!

!

voice translation-profile INCOMING-E1

translate called 1

!

!

!

license udi pid CISCO2911/K9 sn FCZ161370N2

hw-module pvdm 0/0

!

hw-module pvdm 0/1

!

hw-module sm 1

!

!

!

file privilege 0

username catalyst privilege 15 secret 4 zlHhRXnglmT4VQW9BZtAYpfuLXYE6B6GmalIBPH2I0k

!

redundancy

!

!

controller E1 0/1/0

framing NO-CRC4

pri-group timeslots 1-31

description AIRTEL ISDN

!

controller E1 0/1/1

pri-group timeslots 1-16

description ORANGE ISDN

!

ip ftp password 7 03065002041A2645

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description LINK_TO_CAT3560_SWITCH

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.10

description CMS_VG INTERFACE FOR VOICE VLAN

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0

!

interface GigabitEthernet0/0.20

description CMS_VG INTERFACE FOR DATA VLAN

encapsulation dot1Q 20

ip address 192.168.20.1 255.255.255.0

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/2

description $ES_LAN$

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bchan-number-order ascending

isdn sending-complete

no cdp enable

!

interface Serial0/1/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn sending-complete

no cdp enable

!

interface SM1/0

description "Unity Express Module"

ip unnumbered GigabitEthernet0/0.10

ip virtual-reassembly in

service-module ip address 192.168.10.2 255.255.255.0

!Application: CUE Running on SM

service-module ip default-gateway 192.168.10.1

!

interface SM1/1

description Internal switch interface connected to Service Module

no ip address

!

interface Vlan1

no ip address

!

ip forward-protocol nd

!

ip http server

no ip http secure-server

ip http path flash:GUI

!

ip route 0.0.0.0 0.0.0.0 192.168.20.254

ip route 192.168.10.2 255.255.255.255 SM1/0

ip route 192.168.30.3 255.255.255.255 192.168.10.254

!

!

control-plane

!

!

voice-port 0/0/0

!

voice-port 0/0/1

!

voice-port 0/0/2

!

voice-port 0/0/3

!

voice-port 0/1/0:15

translation-profile incoming INCOMING-E1

!

voice-port 0/1/1:15

!

!

mgcp behavior rsip-range tgcp-only

mgcp behavior comedia-role none

mgcp behavior comedia-check-media-src disable

mgcp behavior comedia-sdp-force disable

!

mgcp profile default

!

sccp local GigabitEthernet0/0.10

sccp ccm 192.168.10.1 identifier 1 priority 1 version 7.0

sccp

!

sccp ccm group 1

bind interface GigabitEthernet0/0.10

associate ccm 1 priority 1

associate profile 1 register conf_dsp_1

!

dspfarm profile 1 conference 

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 7

associate application SCCP

!

dial-peer cor custom

name Airtel_Mobile

name Safcom_Mobile

name Airtel_PSTN

name Telkom_PSTN

name None_PSTN

!

!

dial-peer cor list AirtelMobile

member Airtel_Mobile

!

dial-peer cor list SafcomMobile

member Safcom_Mobile

!

dial-peer cor list AirtelPSTN

member Airtel_PSTN

!

dial-peer cor list TelkomPSTN

member Telkom_PSTN

!

dial-peer cor list NonePSTN

member None_PSTN

!

!

dial-peer voice 500 voip

description "Voicemail Dialpeer"

destination-pattern 5..

session protocol sipv2

session target ipv4:192.168.10.2

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 1 voip

corlist outgoing SafcomMobile

description "Safaricom GSM Dialpeer"

destination-pattern 907[0-2].......

session protocol sipv2

session target ipv4:192.168.30.3

dtmf-relay rtp-nte

codec g711ulaw

no vad

!

dial-peer voice 2 voip

corlist outgoing AirtelMobile

description "Airtel GSM Dialpeer"

destination-pattern 907[3,8].......

session protocol sipv2

session target ipv4:192.168.30.3

dtmf-relay rtp-nte

codec g711ulaw

no vad

!

dial-peer voice 4 pots

corlist outgoing AirtelPSTN

description "Airtel PSTN Dial Peer"

destination-pattern 8.T

incoming called-number 9T

direct-inward-dial

port 0/1/0:15

!

dial-peer voice 5 pots

corlist outgoing TelkomPSTN

description "Telkom PSTN Dialpeer"

destination-pattern 9T

incoming called-number 9.T

direct-inward-dial

port 0/1/1:15

!

sip-ua

!

gatekeeper

shutdown

!

telephony-service

sdspfarm conference mute-on *1 mute-off *2

sdspfarm units 5

sdspfarm tag 1 conf_dsp_1

no privacy

conference hardware

no auto-reg-ephone

max-ephones 50

max-dn 100

ip source-address 192.168.10.1 port 2000

no service directed-pickup

system message Catalyst Management Services

cnf-file location flash:

load 7915-12 B015-1-0-4.SBN

load 7915-24 B015-1-0-4.SBN

load ata ATA187.9-2-3-1.loads

time-zone 31

date-format dd-mm-yy

voicemail 500

mwi relay

max-conferences 8 gain -6

moh "music-on-hold.au"

web admin system name cmsadmin password admin

dn-webedit

transfer-system full-consult

transfer-pattern 9.T

transfer-pattern ...

after-hours block pattern 1 9T 7-24

after-hours block pattern 2 9 7-24

after-hours block pattern 3 907[0-2]....... 7-24

after-hours block pattern 4 907[3,8]....... 7-24

after-hours day Sun 00:00 23:59

after-hours day Mon 00:00 23:59

after-hours day Tue 00:00 23:59

after-hours day Wed 00:00 23:59

after-hours day Thu 00:00 23:59

after-hours day Fri 00:00 23:59

after-hours day Sat 00:00 23:59

directory entry 1 000 name Reception

directory entry 2 001 name Paul Kavuma

directory entry 3 002 name Biniam Yohannes

directory entry 4 003 name Rajal Upadhyaya

directory entry 5 004 name Marlene Ngoyi

directory entry 6 005 name Vaishal Shah

directory entry 7 006 name Rosemary Ngure

directory entry 8 007 name Nixon Muthangya

directory entry 9 008 name Nyawira Gitau

directory entry 10 009 name Stephen Macharia

directory entry 12 011 name Bernard Ouma

directory entry 13 030 name Main Boardroom

directory entry 14 016 name Server Room

directory entry 15 020 name Vincent Rague

directory entry 16 021 name Seeta Shah

directory entry 17 030 name Main Boardroom

directory entry 18 031 name Meeting Room

directory entry 19 032 name Cubby Hole

directory entry 11 010 name Martha Osier

create cnf-files version-stamp 7960 Jul 01 2013 21:37:23

!

ephone-template  1

softkeys hold  Resume Newcall

softkeys idle  Redial Newcall Cfwdall Dnd

softkeys seized  Endcall Meetme

softkeys alerting  Callback Endcall

softkeys connected  Hold Trnsfer Endcall Confrn

softkeys ringing  Answer Dnd

!

ephone-template  2

softkeys hold  Resume Newcall

softkeys idle  Redial Newcall Cfwdall Dnd Pickup

softkeys seized  Endcall Meetme

softkeys alerting  Callback Endcall

softkeys connected  Hold Endcall Trnsfer Confrn

after-hours exempt

type 7942

!

ephone-template  3

softkeys hold  Resume Newcall

softkeys idle  Redial Newcall

softkeys seized  Endcall Meetme

softkeys alerting  Callback Endcall

softkeys connected  Hold Endcall Trnsfer Confrn

!

ephone-dn  1  dual-line

number 000

pickup-group 10

label Reception - 000

description Reception

name Reception

!

ephone-dn  2  dual-line

number 001

pickup-group 10

label Paul Kavuma - 001

description Paul Kavuma

name Paul Kavuma

!

ephone-dn  3  dual-line

number 002

pickup-group 10

label Biniam Yohannes - 002

description Biniam Yohannes

name Biniam Yohannes

!

ephone-dn  4  dual-line

number 003

pickup-group 10

label Rajal Upadhyaya - 003

description Rajal Upadhyaya

name Rajal Upadhyaya

!

ephone-dn  5  dual-line

number 004

pickup-group 10

label Marlene Ngoyi - 004

description Marlene Ngoyi

name Marlene Ngoyi

!

ephone-dn  6  dual-line

number 005

pickup-group 10

label Vaishal Shah - 005

description Vaishal Shah

name Vaishal Shah

!

ephone-dn  7  dual-line

number 006

pickup-group 10

label Rosemary Ngure - 006

description Rosemary Ngure

name Rosemary Ngure

!

ephone-dn  8  dual-line

number 007

pickup-group 10

label Nixon Muthangya - 007

description Nixon Muthangya

name Nixon Muthangya

!

ephone-dn  9  dual-line

number 008

pickup-group 10

label Nyawira Gitau - 008

description Nyawira Gitau

name Nyawira Gitau

!

ephone-dn  10  dual-line

number 009

pickup-group 10

label Stephen Macharia - 009

description Stephen Macharia

name Stephen Macharia

!

ephone-dn  21  dual-line

number 101

label Main Boardroom - 101

description Main Boardroom

name Main Boardroom

!

!

ephone-dn  22

number 501..

mwi-type visual

mwi on

!

!

ephone-dn  23

number 502..

mwi-type visual

mwi off

!

!

ephone-dn  24  octo-line

number 200

description Meet-Me Conference Number

conference meetme

no huntstop

!

ephone-dn  25  octo-line

number 201

description Meet-Me Conference Number

conference meetme

no huntstop

!

ephone-dn  26  octo-line

number 202

description Meet-Me Conference Number

conference meetme

no huntstop

!

ephone-dn  27  octo-line

number 203

description Meet-Me Conference Number

conference meetme

preference 1

no huntstop

!

ephone-dn  28  octo-line

number 204

description Meet-Me Conference Number

conference meetme

preference 2

!

ephone-dn  29  octo-line

number 205

description Meet-Me Conference Number

conference meetme

no huntstop

!

ephone-dn  30  dual-line

number A000

description Ad-Hoc Conference Number

conference ad-hoc

no huntstop

!

ephone-dn  31  dual-line

number A000

description Ad-Hoc Conference Number

conference ad-hoc

preference 1

no huntstop

!

ephone-dn  32  dual-line

number A000

description Ad-Hoc Conference Number

conference ad-hoc

preference 2

no huntstop

!

ephone-dn  33  dual-line

number A000

description Ad-Hoc Conference Number

conference ad-hoc

preference 3

no huntstop

!

ephone-dn  34  dual-line

number A000

description Ad-Hoc Conference Number

conference ad-hoc

preference 4

!

ephone-dn  35  dual-line

number 106

pickup-group 10

label Lounge - 106

description Lounge Phone

name Lounge

!

ephone  1

mac-address C8F9.F9D6.0259

ephone-template 1

after-hours exempt

type 7962 addon 1 7915-24

button  1:1 7m2 8m3 9m4

button  10m5 11m6 12m7 13m8

button  14m9 15m10 16m11 17m15

button  18m16 19m13 20m21 21m14

button  22m20

!

ephone  2

mac-address A418.7529.8391

ephone-template 2

after-hours exempt

type 7942

button  1:2

!

ephone  3

mac-address A418.758A.10F2

ephone-template 2

after-hours exempt

type 7942

button  1:3

!

ephone  4

mac-address A418.758A.2F76

ephone-template 2

after-hours exempt

type 7942

button  1:4

!

ephone  5

mac-address A418.7529.8386

ephone-template 2

after-hours exempt

type 7942

button  1:5

!

ephone  6

mac-address A418.7529.8441

ephone-template 2

after-hours exempt

type 7942

button  1:6

!

ephone  7

mac-address A418.7529.8450

ephone-template 2

after-hours exempt

type 7942

button  1:7

!

ephone  8

mac-address A418.7529.83AC

ephone-template 2

after-hours exempt

type 7942

button  1:8

!

ephone  9

mac-address A418.7529.8462

ephone-template 2

after-hours exempt

type 7942

button  1:9

!

ephone  10

mac-address F4EA.6749.B07D

ephone-template 2

after-hours exempt

type 7942

button  1:10

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Unable to Configure E1 Line

Hi Andrew,

You can use the DSP calculator to callcuate teh requirement.

http://www.cisco.com/web/applicat/dsprecal/dsp_calc.html

regds,

aman

7 REPLIES
New Member

Unable to Configure E1 Line

Hi Guys,

Below is the error I am getting:

Not enough DSP resources available to configure pri-group on controller E1 0/1/1

% The remaining dsp resources are enough for 17 time slots.

% For current codec complexity, 1 extra  dsp(s) are required to create this voice port.

VIP Purple

Unable to Configure E1 Line

Hi Andrew,

On PVDM3-64 , u can have max. 960 credits  while with PVDM3-32, u can have total 480 credits.

In the output, u have shared they all are consumed.

regds,

aman

New Member

Unable to Configure E1 Line

Hi,

Is there any way I can distribute more resources to the E1 line?

Andrew

Unable to Configure E1 Line

Shutdown the Conference Profile, then try again.

--
Jorge Armijo

Please remember to rate helpful responses and identify helpful or correct answers.

-- Jorge Armijo Please remember to rate helpful responses and identify helpful or correct answers.
New Member

Unable to Configure E1 Line

Hi Jorge,

I disabled the conference profile and then I was able to configure the full 30 channels on the E1 line.

My concern is this: The client still needs to be able to conference. Is it possible to still have the conference profile and still be able to configure the E1 line?

VIP Purple

Unable to Configure E1 Line

Hi Andrew,

You can use the DSP calculator to callcuate teh requirement.

http://www.cisco.com/web/applicat/dsprecal/dsp_calc.html

regds,

aman

New Member

Unable to Configure E1 Line

Thanks everyone for your help.

I now understand better  DSP resourcing and utilization.

692
Views
0
Helpful
7
Replies
CreatePlease to create content