Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Unable to forward the Calls from IP Phone to Mobile

Hi All,

We  have Using CCM 4.0 .All the Call from out side will Come to the  Reception IP Phone (Model 7940). From there We are unable to forward the  call to my mobile. From Extenson we are able to forward the Call to  mobile

Thanks

Roopesh

2 ACCEPTED SOLUTIONS

Accepted Solutions
Green

Re: Unable to forward the Calls from IP Phone to Mobile

Hi Roopesh,

From your config the components for ISDN/PRI 2/1:15

!
controller E1 2/1
framing NO-CRC4
clock source internal
pri-group timeslots 1-31
description for Income
!
interface Serial2/1:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
no cdp enable
!
!
voice-port 2/1:15
connection plar 500
!
dial-peer voice 106 voip
destination-pattern 5..
session target ipv4:10.10.14.11
dtmf-relay h245-alphanumeric
codec g711ulaw
ip qos dscp cs5 media
no vad
!

I would change/add a couple items

!
controller E1 2/1
framing NO-CRC4
no clock source internal
pri-group timeslots 1-31
description for Income
!

The ISDN/PRI should be taking it clock from line not internally

I would also add a dial peer to match incoming calls from this PRI

!
dial-peer voice 2 pots
description *** FOR INCOMING DIAL PEER MATCHING ***
incoming called-number .
direct-inward-dial
port 2/1:15
!

Please nort that this line
(incoming called-number .)
Needs to include the "space" and the fullstop "."

Can you also confirm that the ISDN is in service and Up

show isdn status


Regards
Alex

Regards, Alex. Please rate useful posts.
Green

Re: Unable to forward the Calls from IP Phone to Mobile

Roopesh,

Glad to be of assistance.

Good to hear of success

Regards

Please rate useful posts

Regards, Alex. Please rate useful posts.
33 REPLIES
Green

Unable to forward the Calls from IP Phone to Mobile

Hi,

Depending on you SP this may be that the forwarded call is being sent to the mobile with a "Calling Number" that is not supported by you SP.

Can you share any traces/debugs

on the gateway --- debug isdn q931

Or at least more info re your network connectivity ISDN/FXO SIP trunk etc.

etc.

Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

Unable to forward the Calls from IP Phone to Mobile

Hi  Alex,

Thanks for the Replay

Please find the Result of Debug

oh-rt2#debug isdn q931

debug isdn q931 isON.

*Mar  7 22:04:13: %PS-3-MULTFAIL: There is more than one failure with the  Power System 1; please resolve problems immediately

*Mar  7 22:04:17: ISDN Se4/0:15 Q931: TX -> SETUP pd = 8  callref = 0x0728

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech 

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA9839F

Exclusive, Channel 31

Progress Ind i = 0x8183 - Origination address is non-ISDN 

Calling Party Number i = 0x0181, '125'

Plan:ISDN, Type:Unknown

Called Party Number i = 0x80, '8970325670'

Plan:Unknown, Type:Unknown

*Mar  7 22:04:17: ISDN Se4/0:15 Q931: RX <- SETUP_ACK pd = 8  callref = 0x8728

Channel ID i = 0xA9839F

Exclusive, Channel 31

*Mar  7 22:04:18: ISDN Se4/0:15 Q931: RX <- CALL_PROC pd = 8  callref = 0x8728

*Mar  7 22:04:24: ISDN Se4/0:15 Q931: RX <- ALERTING pd = 8  callref = 0x8728

Progress Ind i = 0x8488 - In-band info or appropriate now available

*Mar  7 22:04:35: ISDN Se4/0:15 Q931: RX <- CONNECT pd = 8  callref = 0x8728

Date/Time i = 0x0B0A0C1419

*Mar  7 22:04:35: %ISDN-6-CONNECT: Interface Serial4/0:30 is now connected to 8970325670 N/A

*Mar  7 22:04:35: ISDN Se4/0:15 Q931: TX -> CONNECT_ACK pd = 8  callref = 0x0728

*Mar  7 22:04:43: %PS-3-MULTFAIL: There is more than one failure with the  Power System 1; please resolve problems immediately

*Mar  7 22:05:13: %PS-3-MULTFAIL: There is more than one failure with the  Power System 1; please resolve problems immediately

*Mar  7 22:05:33: %ISDN-6-DISCONNECT: Interface Serial4/0:30  disconnected from 8970325670 , call lasted 57 seconds

*Mar  7 22:05:33: ISDN Se4/0:15 Q931: TX -> DISCONNECT pd = 8  callref = 0x0728

Cause i = 0x8090 - Normal call clearing

*Mar  7 22:05:33: ISDN Se4/0:15 Q931: RX <- RELEASE pd = 8  callref = 0x8728

*Mar  7 22:05:33: ISDN Se4/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x0728

*Mar  7 22:05:43: %PS-3-MULTFAIL: There is more than one failure with the  Power System 1; please resolve problems immediately

% Type "show ?" for a list of subcommands

oh-rt2#sh debug isdn q931

*Mar  7 22:06:13: %PS-3-MULTFAIL: There is more than one failure with the  Power System 1; please resolve problems immediatelyterm mon       en     

oh-rt2#ensh debug isdn q931term mon       en      term mondebug isdn q931sh             en   ensh debugging

The following ISDN debugs are enabled on all DSLs:

debug isdn error isON.

debug isdn q931 isON.

Thanks

Roopesh

Green

Unable to forward the Calls from IP Phone to Mobile

Hi,

This call looked like a good call taht was set up outbound and cleared by the gateway
and lasted 1 minute 16 secs

*Mar  7 22:04:17: ISDN Se4/0:15 Q931: TX -> SETUP pd = 8  callref = 0x0728
*Mar  7 22:05:33: ISDN Se4/0:15 Q931: TX -> DISCONNECT pd = 8  callref = 0x0728

Regards
Alex

Regards, Alex. Please rate useful posts.
New Member

Re: Unable to forward the Calls from IP Phone to Mobile

HI

Green

Unable to forward the Calls from IP Phone to Mobile

Hi,

As you can not supply a trace at this time there are a couple of things you can
check.

1) CUCM Admin

Service ---> Service Parameters
PUB ADDRESS Service Call Manager

Advanced

Then look for the parameter

Block Offnet to Offnet --- Set to FALSE

Then Update

This allows external calls to be transferred both internally & externaly

2) Look at the Call Forwarding CSS on the line you are calling
Does this CSS have the Partitions which allow MOBILE calls

Regards
Alex

Please rate useful posts

Regards, Alex. Please rate useful posts.
New Member

Re: Unable to forward the Calls from IP Phone to Mobile

Hi Alex,

Under

Service ---> Service Parameters i was not able to see the option

PUB ADDRESS Service Call Manager. We are using CCm 4.0.

Thanks,

Roopesh

Green

Unable to forward the Calls from IP Phone to Mobile

Hi,

I just mean select the PUBLISHER server (You may have more than 1 server in the drop down depending on the build of your cluster), then the CALL MANAGER service

HTH

Alex

Regards, Alex. Please rate useful posts.
New Member

Re: Unable to forward the Calls from IP Phone to Mobile

Hi ,Now we are able to Forward the Call to mobile.But We gets onle One ring in mobile and Call is Disconnecting Automatically.

Thanks

Roopesh

Green

Unable to forward the Calls from IP Phone to Mobile

Hi Roopesh

At least we are moving on a bit.

Can we see the debug isdn q931 of a forwarded call.

Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

Re: Unable to forward the Calls from IP Phone to Mobile

Hi Alex,

Do i need to do Normal debug Coomand

debug isdn q931 or any thing else

Thanks,

Roopesh

Green

Re: Unable to forward the Calls from IP Phone to Mobile

Roopesh

We want to see the forwarded call to try to work out why it is being cleared

router#

!

term mon

debug isdn q931

!

Make forwarded call

When you finish taking the trace

router#

!

un all

term no mon

!

Please include a few words of what numbers were called and what the destination of the forwarding should be.

Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

Re: Unable to forward the Calls from IP Phone to Mobile

Hi Alex,

Here it is

oh-rt2#term mon

oh-rt2#debug isdn

*Mar  1 20:48:51: %PS-3-MULTFAIL: There is more than one failure with the  Power System 1; please resolve problems immediatelyq931

debug isdn q931 isON.

oh-rt2#

*Mar  1 20:49:10: ISDN Se4/0:15 Q931: RX <- ALERTING pd = 8  callref = 0x822F

Progress Ind i = 0x8488 - In-band info or appropriate now available

*Mar  1 20:49:16: ISDN Se4/0:15 Q931: RX <- CONNECT pd = 8  callref = 0x822F

Date/Time i = 0x0C01181202

*Mar  1 20:49:16: %ISDN-6-CONNECT: Interface Serial4/0:30 is now connected to 64568381 N/A

*Mar  1 20:49:16: ISDN Se4/0:15 Q931: TX -> CONNECT_ACK pd = 8  callref = 0x022F

*Mar  1 20:49:21: %PS-3-MULTFAIL: There is more than one failure with the  Power System 1; please resolve problems immediately

*Mar  1 20:49:51: %PS-3-MULTFAIL: There is more than one failure with the  Power System 1; please resolve problems immediately

*Mar  1 20:50:15: ISDN Se4/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0x822F

Cause i = 0x8290 - Normal call clearing

Progress Ind i = 0x8288 - In-band info or appropriate now available

*Mar  1 20:50:15: %ISDN-6-DISCONNECT: Interface Serial4/0:30  disconnected from 64568381 , call lasted 59 seconds

*Mar  1 20:50:15: ISDN Se4/0:15 Q931: call_disc: PI received in disconnect; Postpone sending RELEASE for callid 0x80FF

*Mar  1 20:50:15: ISDN Se4/0:15 Q931: TX -> RELEASE pd = 8  callref = 0x022F

*Mar  1 20:50:15: ISDN Se4/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x822F

*Mar  1 20:50:21: %PS-3-MULTFAIL: There is more than one failure with the  Power System 1; please resolve problems immediately

*Mar  1 20:50:51: %PS-3-MULTFAIL: There is more than one failure with the  Power System 1; please resolve problems immediately

*Mar  1 20:51:21: %PS-3-MULTFAIL: There is more than one failure with the  Power System 1; please resolve problems immediately

*Mar  1 20:51:40: ISDN Se4/0:15 Q931: RX <- SETUP pd = 8  callref = 0x68E2

Sending Complete

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech 

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA9839F

Exclusive, Channel 31

Calling Party Number i = 0x2181, '9886770029'

Plan:ISDN, Type:National

Called Party Number i = 0x81, '6300'

Plan:ISDN, Type:Unknown

High Layer Compat i = 0x9181

*Mar  1 20:51:40: ISDN Se4/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0xE8E2

Channel ID i = 0xA9839F

Exclusive, Channel 31

*Mar  1 20:51:40: ISDN Se4/0:15 Q931: TX -> SETUP pd = 8  callref = 0x0230

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech 

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA9839E

Exclusive, Channel 30

Progress Ind i = 0x8183 - Origination address is non-ISDN 

Calling Party Number i = 0x2181, '9886770029'

Plan:ISDN, Type:National

Called Party Number i = 0x80, '9902025093'

Plan:Unknown, Type:Unknown

*Mar  1 20:51:40: ISDN Se4/0:15 Q931: RX <- SETUP_ACK pd = 8  callref = 0x8230

Channel ID i = 0xA9839E

Exclusive, Channel 30

*Mar  1 20:51:40: ISDN Se4/0:15 Q931: RX <- CALL_PROC pd = 8  callref = 0x8230

*Mar  1 20:51:43: ISDN Se4/0:15 Q931: TX -> PROGRESS pd = 8  callref = 0xE8E2

Progress Ind i = 0x8181 - Call not end-to-end ISDN, may have in-band info

*Mar  1 20:51:43: ISDN Se4/0:15 Q931: RX <- ALERTING pd = 8  callref = 0x8230

Progress Ind i = 0x8488 - In-band info or appropriate now available

*Mar  1 20:51:43: ISDN Se4/0:15 Q931: TX -> ALERTING pd = 8  callref = 0xE8E2

Progress Ind i = 0x8188 - In-band info or appropriate now available

*Mar  1 20:51:43: ISDN Se4/0:15 Q931: TX -> DISCONNECT pd = 8  callref = 0xE8E2

Cause i = 0x80AF - Resource unavailable, unspecified

*Mar  1 20:51:43: ISDN Se4/0:15 Q931: TX -> DISCONNECT pd = 8  callref = 0x0230

Cause i = 0x80AF - Resource unavailable, unspecified

*Mar  1 20:51:43: ISDN Se4/0:15 Q931: RX <- RELEASE pd = 8  callref = 0x68E2

*Mar  1 20:51:43: ISDN Se4/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0xE8E2

*Mar  1 20:51:43: ISDN Se4/0:15 Q931: RX <- RELEASE pd = 8  callref = 0x8230

*Mar  1 20:51:43: ISDN Se4/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x0230

*Mar  1 20:51:51: %PS-3-MULTFAIL: There is more than one failure with the  Power System 1; please resolve problems immediately

*Mar  1 20:52:21: %PS-3-MULTFAIL: There is more than one failure with the  Power System 1; please resolve problems immediately

oh-rt2#un all

All possible debugging has been turned off

oh-rt2#ter

*Mar  1 20:52:51: %PS-3-MULTFAIL: There is more than one failure with the  Power System 1; please resolve problems immediatelym       term no mon

oh-rt2#exit

Thanks,

Roopesh

Green

Re: Unable to forward the Calls from IP Phone to Mobile

Hi,

We see the 2 calls being set up 

Call Refs  incoming 68E2 & outgoing 0230

The router is clearing both of these calls with a cause code

0x80AF - Resource unavailable, unspecified

This usually infers that there is a codec issue

Can you post the show runn from the gateway

Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

Re: Unable to forward the Calls from IP Phone to Mobile

Hi Alex,

Please find the result for sh run

oh-rt2#sh run

Building configuration...

Current configuration : 6276 bytes

!

version 12.3

service timestamps debug datetime

service timestamps log datetime

service password-encryption

!

hostname oh-rt2

!

boot-start-marker

boot system flash c3745-advipservicesk9-mz.123-26.bin

boot-end-marker

!

logging buffered 4096 notifications

enable secret 5 $1$AgBh$dCd1NSglSXBbZXmjcdO/I.

!

clock timezone IST 5 30

no network-clock-participate slot 2

no network-clock-participate slot 4

voice-card 2

dspfarm

!

--More--         voice-card 4

dspfarm

dsp services dspfarm

!

no aaa new-model

ip subnet-zero

ip cef

!

!

!

ip domain name A.com

ip audit po max-events 100

!

isdn switch-type primary-net5

!

!

voice hunt user-busy

voice rtp send-recv

!

voice class codec 1

!

!

!

--More--         !

!

!

!

!

!

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.10.14.11 

ccm-manager config

fax interface-type fax-mail

!

!

controller E1 2/0

!

controller E1 2/1

framing NO-CRC4

clock source internal

pri-group timeslots 1-31

description for Income

!

controller E1 4/0

framing NO-CRC4

--More--          pri-group timeslots 1-31

description For Outgoing

!

ip tcp synwait-time 13

!

!

!

!

!

interface Multilink1

bandwidth 256

ip address 172.16.16.45 255.255.255.252

ip tcp header-compression iphc-format

ppp multilink

ppp multilink group 1

ip rtp header-compression iphc-format

!

interface FastEthernet0/0

ip address 10.10.14.5 255.255.255.0

ip broadcast-address 10.10.14.255

ip accounting output-packets

ip nbar protocol-discovery

ip route-cache flow

--More--          no ip mroute-cache

duplex auto

speed auto

h323-gateway voip bind srcaddr 10.10.14.5

!

interface Serial0/0

description Circuit #1 initiating in India via Bharti

bandwidth 128

no ip address

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

clock rate 2000000

ppp multilink

!

interface FastEthernet0/1

ip address 10.10.3.8 255.255.255.0

duplex auto

speed auto

no cdp enable

!

interface Serial0/1

--More--          description Circuit #2 initiating in India via BSNL

bandwidth 128

no ip address

no ip route-cache cef

no ip route-cache

no ip mroute-cache

clock rate 2000000

!

interface Serial0/2

description initiating in India via TATA

bandwidth 128

no ip address

encapsulation ppp

clock rate 2000000

ppp multilink

ppp multilink group 1

!

interface Serial0/3

no ip address

shutdown

clock rate 2000000

no cdp enable

!

--More--         interface Serial2/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Serial4/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

ip classless

ip route 10.10.0.0 255.255.0.0 10.10.14.1

ip route 172.18.252.0 255.255.255.192 10.10.14.1

!

ip http server

no ip http secure-server

!

logging trap errors

access-list 1 permit 10.10.3.18 log

--More--         access-list 1 deny   any

access-list 2 permit 10.10.3.18 log

access-list 2 deny   any

dialer-list 1 protocol ip permit

!

!

!

snmp-server community public RO 1

snmp-server community private RW 2

snmp-server location OH/BLR/IN/

snmp-server contact

snmp-server enable traps tty

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/1/0

cptone IN

timeouts interdigit 3

connection plar 100

!

voice-port 1/1/1

--More--          cptone IN

timeouts interdigit 3

connection plar 100

!

voice-port 2/1:15

connection plar 500

!

voice-port 4/0:15

connection plar 500

!

mgcp

mgcp call-agent 10.10.14.11 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

--More--         !

sccp local FastEthernet0/0

sccp

sccp ccm 10.10.14.11 priority 1

!

dspfarm rtp timeout 60

!

dial-peer cor custom

!

!

!

dial-peer voice 3 pots

application mgcpapp

incoming called-number 8025053.T

direct-inward-dial

!

dial-peer voice 4 pots

application mgcpapp

!

dial-peer voice 5 pots

application mgcpapp

!

dial-peer voice 3000 voip

--More--          destination-pattern 3...

session target ipv4:160.100.160.151

!

dial-peer voice 9999 voip

destination-pattern 9T

session target ipv4:160.100.160.151

!

dial-peer voice 6 pots

application mgcpapp

!

dial-peer voice 2 voip

destination-pattern ...

session target ipv4:10.10.14.11

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

no vad

!

dial-peer voice 14 pots

destination-pattern 0T

progress_ind setup enable 3

progress_ind progress enable 8

progress_ind connect enable 8

--More--          direct-inward-dial

port 4/0:15

!

dial-peer voice 101 voip

destination-pattern 7..

session target ipv4:10.10.14.11

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

no vad

!

dial-peer voice 102 voip

destination-pattern 8..

session target ipv4:10.10.14.11

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

no vad

!

dial-peer voice 103 voip

destination-pattern 9..

session target ipv4:10.10.14.11

dtmf-relay h245-alphanumeric

--More--          codec g711ulaw

ip qos dscp cs5 media

no vad

!

dial-peer voice 104 voip

session target ipv4:10.10.14.11

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

no vad

!

dial-peer voice 105 voip

destination-pattern 6..

session target ipv4:10.10.14.11

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

no vad

!

dial-peer voice 106 voip

destination-pattern 5..

session target ipv4:10.10.14.11

dtmf-relay h245-alphanumeric

--More--          codec g711ulaw

ip qos dscp cs5 media

no vad

!

dial-peer voice 30 pots

preference 2

destination-pattern *5T

!

dial-peer voice 77 pots

preference 2

destination-pattern *7T

!

dial-peer voice 29 pots

preference 1

destination-pattern *5T

port 1/1/0

!

dial-peer voice 78 pots

preference 1

destination-pattern *7T

port 1/1/1

!

num-exp 8025053... ...

--More--         gateway

!

!

banner motd ^C

!!!AUTHORIZED ACCESS ONLY !!!

Hostname : OH-RTR2.

Location : OH/BLR/IN

Contact  :IS Helpdesk

!!! AUTHORIZED ACCESS ONLY !!!

^C

!

line con 0

transport output all

line aux 0

transport preferred none

transport output none

line vty 0 5

password 7 1511021F0725

login

transport input all

transport output all

!

ntp clock-period 17180604

--More--         ntp server 10.10.8.1

Thnks

Roopesh

Green

Re: Unable to forward the Calls from IP Phone to Mobile

Hi Roopesh,

From what I can see the call come from the PSTN to you and uses PLAR to dial 500
500 matches dial peeer 106 and sent to CUCM on IP address 10.10.14.11

The forwarded call comes to the router as 0.9902025093
This matches dial peer 14 and sent out on the ISDN 4/0:15


To ensure correct codecs can you try pasting the following lines into
the config

conf t
!
!
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
!
voice class h323 1
  h225 timeout tcp establish 3
!
!
dial-peer voice 1 pots
description *** FOR INCOMING DIAL PEER MATCHING ***
incoming called-number .
direct-inward-dial
port 4/0:15
!
!
dial-peer voice 106 voip
destination-pattern 5..
session target ipv4:10.10.14.11
incoming called-number .
dtmf-relay h245-alphanumeric
no codec g711ulaw
voice-class codec 1
voice-class h323 1
ip qos dscp cs5 media
no vad
!
!
end
!
!


Then retry the test call

HTH
Alex

Regards, Alex. Please rate useful posts.
New Member

Re: Unable to forward the Calls from IP Phone to Mobile

Thank you Very Much Alex,

I will make the Change and i Will update the same to you.

I have one more problem .

I was not able to Dial the Pri Line NO 25053500. Can you Find the above configuration and sugggest any thing wrong with this.

Thanks,

Roopesh

Green

Re: Unable to forward the Calls from IP Phone to Mobile

Roopesh

If 25053500 is an outbound call it needs to have a leading "0" -- IE 0.25053500 to match

dial peeer 14 and the ISDN/PRI

!

dial-peer voice 14 pots

destination-pattern 0T

progress_ind setup enable 3

progress_ind progress enable 8

progress_ind connect enable 8

direct-inward-dial

port 4/0:15

!

Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

Re: Unable to forward the Calls from IP Phone to Mobile

Hi Alex,

The thing Is We have Two line One is For incomming and one is for Out going

25053500 is for only incomming And now it is connected to Controller E1 like

controller E1 2/1

framing NO-CRC4

clock source internal

pri-group timeslots 1-31

description for Income

Once i Dialed this no It used lonch on Reception .

Now it is not hapening.

Thanks

Alex.

Green

Re: Unable to forward the Calls from IP Phone to Mobile

Hi Roopesh,

From your config the components for ISDN/PRI 2/1:15

!
controller E1 2/1
framing NO-CRC4
clock source internal
pri-group timeslots 1-31
description for Income
!
interface Serial2/1:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
no cdp enable
!
!
voice-port 2/1:15
connection plar 500
!
dial-peer voice 106 voip
destination-pattern 5..
session target ipv4:10.10.14.11
dtmf-relay h245-alphanumeric
codec g711ulaw
ip qos dscp cs5 media
no vad
!

I would change/add a couple items

!
controller E1 2/1
framing NO-CRC4
no clock source internal
pri-group timeslots 1-31
description for Income
!

The ISDN/PRI should be taking it clock from line not internally

I would also add a dial peer to match incoming calls from this PRI

!
dial-peer voice 2 pots
description *** FOR INCOMING DIAL PEER MATCHING ***
incoming called-number .
direct-inward-dial
port 2/1:15
!

Please nort that this line
(incoming called-number .)
Needs to include the "space" and the fullstop "."

Can you also confirm that the ISDN is in service and Up

show isdn status


Regards
Alex

Regards, Alex. Please rate useful posts.
New Member

Re: Unable to forward the Calls from IP Phone to Mobile

Thanks For the replay Alex,

I will make the Changes in Gateway And i will come back to you.

Thanks

Roopesh

New Member

Re: Unable to forward the Calls from IP Phone to Mobile

Hi Alex,

Thank you very much .We Completed our first task successes fully .Now we are able to forward the Call to Mobiles. Thank you for your extended support.

Thanks

Roopesh

Green

Re: Unable to forward the Calls from IP Phone to Mobile

Roopesh,

Glad to be of assistance.

Good to hear of success

Regards

Please rate useful posts

Regards, Alex. Please rate useful posts.
New Member

Re: Unable to forward the Calls from IP Phone to Mobile

Hi Alex ,

Our Second issue PRI line Dosent seems working after making the requsted change . But One improvment is there it is now the call is conecting but unable to here the sound from both side.

Regards

Roopesh

Green

Re: Unable to forward the Calls from IP Phone to Mobile

Roopesh,

To refresh us as what is happening

You receive a call on the ISDN/PRI 2/1:15

This should call your reception desk.

On the voice port for 2/1:15 you are using PLAR

!

voice-port 2/1:15

connection plar 500

!

So this meens all calls coming in on this PRI will route to Number 500

So there is a matching dial peer "106"

!

dial-peer voice 106 voip

destination-pattern 5..

session target ipv4:10.10.14.11

What is number 500 in the CUCM ?

Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

Re: Unable to forward the Calls from IP Phone to Mobile

Hi Alex,

If I Dailed 500 it will reach Reception(100).Now If dailed 025053500 it is connecting to reception but not able to hear.

Thanks

Roopesh

Green

Re: Unable to forward the Calls from IP Phone to Mobile

Roopesh,

Can you post the latest config

Show runn

Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

Re: Unable to forward the Calls from IP Phone to Mobile

Hi Alex,

Here is the Running Configuration and ISDN Status.

Current configuration : 6792 bytes

!

version 12.3

service timestamps debug datetime

service timestamps log datetime

service password-encryption

!

hostname oh-rt2

!

boot-start-marker

boot system flash c3745-advipservicesk9-mz.123-26.bin

boot-end-marker

!

logging buffered 4096 notifications

enable secret 5 $1$AgBh$dCd1NSglSXBbZXmjcdO/I.

!

clock timezone IST 5 30

no network-clock-participate slot 2

no network-clock-participate slot 4

voice-card 2

dspfarm

!

     voice-card 4

dspfarm

dsp services dspfarm

!

no aaa new-model

ip subnet-zero

ip cef

!

!

!

ip domain name

ip audit po max-events 100

!

isdn switch-type primary-net5

!

!

voice hunt user-busy

voice rtp send-recv

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

codec preference 3 g729r8

--More--         !

!

!

voice class h323 1

h225 timeout tcp establish 3

!

!

!

!

!

!

!

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.10.14.11 

ccm-manager config

fax interface-type fax-mail

!

!

controller E1 2/0

framing NO-CRC4

clock source internal

pri-group timeslots 1-24

--More--          description for BSnl

!

controller E1 2/1

framing NO-CRC4

clock source internal

pri-group timeslots 1-31

description for Income

!

controller E1 4/0

framing NO-CRC4

pri-group timeslots 1-31

description For Outgoing

!

ip tcp synwait-time 13

!

!

!

!

!

interface Multilink1

bandwidth 256

ip address 172.16.16.45 255.255.255.252

ip tcp header-compression iphc-format

--More--          ppp multilink

ppp multilink group 1

ip rtp header-compression iphc-format

!

interface FastEthernet0/0

ip address 10.10.14.5 255.255.255.0

ip broadcast-address 10.10.14.255

ip accounting output-packets

ip nbar protocol-discovery

ip route-cache flow

no ip mroute-cache

duplex auto

speed auto

h323-gateway voip bind srcaddr 10.10.14.5

!

interface Serial0/0

description Circuit #1 initiating in India via Bharti

bandwidth 128

no ip address

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

--More--          clock rate 2000000

ppp multilink

!

interface FastEthernet0/1

ip address 10.10.3.8 255.255.255.0

duplex auto

speed auto

no cdp enable

!

interface Serial0/1

description Circuit #2 initiating in India via BSNL

bandwidth 128

no ip address

no ip route-cache cef

no ip route-cache

no ip mroute-cache

clock rate 2000000

!

interface Serial0/2

description initiating in India via TATA

bandwidth 128

no ip address

encapsulation ppp

       clock rate 2000000

ppp multilink

ppp multilink group 1

!

interface Serial0/3

no ip address

shutdown

clock rate 2000000

no cdp enable

!

interface Serial2/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Serial2/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

--More--         !

interface Serial4/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

ip classless

ip route 10.10.0.0 255.255.0.0 10.10.14.1

ip route 172.18.252.0 255.255.255.192 10.10.14.1

!

ip http server

no ip http secure-server

!

logging trap errors

access-list 1 permit 10.10.3.18 log

access-list 1 deny   any

access-list 2 permit 10.10.3.18 log

access-list 2 deny   any

dialer-list 1 protocol ip permit

!

!

      !

snmp-server community public RO 1

snmp-server community private RW 2

snmp-server location OH/BLR/

snmp-server contact

snmp-server enable traps tty

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/1/0

cptone IN

timeouts interdigit 3

connection plar 100

!

voice-port 1/1/1

cptone IN

timeouts interdigit 3

connection plar 100

!

voice-port 2/0:15

connection plar 100

--More--         !

voice-port 2/1:15

connection plar 500

!

voice-port 4/0:15

connection plar 500

!

mgcp

mgcp call-agent 10.10.14.11 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

sccp local FastEthernet0/0

sccp

sccp ccm 10.10.14.11 priority 1

!

dspfarm rtp timeout 60

!

dial-peer cor custom

!

!

!

dial-peer voice 3 pots

application mgcpapp

incoming called-number 8025053.T

direct-inward-dial

!

dial-peer voice 4 pots

application mgcpapp

!

dial-peer voice 5 pots

application mgcpapp

!

dial-peer voice 3000 voip

destination-pattern 3...

session target ipv4:160.100.160.151

!

     dial-peer voice 9999 voip

destination-pattern 9T

session target ipv4:160.100.160.151

!

dial-peer voice 6 pots

application mgcpapp

!

dial-peer voice 14 pots

destination-pattern 0T

progress_ind setup enable 3

progress_ind progress enable 8

progress_ind connect enable 8

direct-inward-dial

port 4/0:15

!

dial-peer voice 101 voip

destination-pattern 7..

session target ipv4:10.10.14.11

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

no vad

!

  dial-peer voice 102 voip

destination-pattern 8..

session target ipv4:10.10.14.11

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

no vad

!

dial-peer voice 103 voip

destination-pattern 9..

session target ipv4:10.10.14.11

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

no vad

!

dial-peer voice 104 voip

session target ipv4:10.10.14.11

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

no vad

!

  dial-peer voice 105 voip

destination-pattern 6..

session target ipv4:10.10.14.11

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

no vad

!

dial-peer voice 106 voip

incoming called-number .

destination-pattern 5..

voice-class codec 1

voice-class h323 1

session target ipv4:10.10.14.11

dtmf-relay h245-alphanumeric

ip qos dscp cs5 media

no vad

!

dial-peer voice 30 pots

preference 2

destination-pattern *5T

!

dial-peer voice 77 pots

    preference 2

destination-pattern *7T

!

dial-peer voice 29 pots

preference 1

destination-pattern *5T

port 1/1/0

!

dial-peer voice 78 pots

preference 1

destination-pattern *7T

port 1/1/1

!

dial-peer voice 2 pots

application mgcpapp

incoming called-number 8025053.T

direct-inward-dial

!

dial-peer voice 1 pots

description **** For Income Dial Peer***

incoming called-number .

direct-inward-dial

port 4/0:15

--More--         !

num-exp 8025053... ...

gateway

!

!

oh-rt2#sh isdn status

Global ISDN Switchtype = primary-net5

ISDN Serial2/0:15 interface

dsl 0, interface ISDN Switchtype = primary-net5

    Layer 1 Status:

DEACTIVATED

    Layer 2 Status:

TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

    Layer 3 Status:

0 Active Layer 3 Call(s)

    Active dsl 0 CCBs = 0

    The Free Channel Mask:  0x00000000

    Number of L2 Discards = 0, L2 Session ID = 0

--More--         ISDN Serial2/1:15 interface

dsl 1, interface ISDN Switchtype = primary-net5

    Layer 1 Status:

ACTIVE

    Layer 2 Status:

TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

    Layer 3 Status:

0 Active Layer 3 Call(s)

    Active dsl 1 CCBs = 0

    The Free Channel Mask:  0xFFFF7FFF

    Number of L2 Discards = 0, L2 Session ID = 0

--More--         ISDN Serial4/0:15 interface

dsl 2, interface ISDN Switchtype = primary-net5

    Layer 1 Status:

ACTIVE

    Layer 2 Status:

TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

    Layer 3 Status:

1 Active Layer 3 Call(s)

CCB:callid=81EB, sapi=0, ces=0, B-chan=31, calltype=VOICE

    Active dsl 2 CCBs = 1

    The Free Channel Mask:  0xBFFF7FFF

    Number of L2 Discards = 0, L2 Session ID = 1

--More--             Total Allocated ISDN CCBs = 1

oh-rt2#exit

Thanks

Roopesh

Green

Re: Unable to forward the Calls from IP Phone to Mobile

Roopesh,

Can you change the clocking for PRI 2/1:15

!
controller E1 2/1
clock source line
!

Also if the call is setting Ok like
ringing then answering but no speach and the call stays up.
Usually this is an IP routing/connectivity issue between the RTP
endpoints.

Can you get the IP address of the Called phone.
Can you ping (extended) this from the gateway using a source Ip address
10.10.14.5 (Your H323 binding address)

Regards
Alex

Regards, Alex. Please rate useful posts.
New Member

Re: Unable to forward the Calls from IP Phone to Mobile

Hi Alex,

I will update you on monday.

Happy Weak end.

Thanks

Roopesh

1821
Views
0
Helpful
33
Replies
CreatePlease to create content