Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

unable to register mgcp gateway on cucm 9.1

It just sits in this state of Registering with CM. 

Router is a 3845 running ios: c3845-spservicesk9-mz.124-24.T8.bin

On the CUCM, I enter the router as the 3845, specify MGCP, and the ports (fxo/fxs) that are on it, and enter the FQDN, copied directly from the router so it is exactly the same.

On the DNS server, I have an A record and a PTR for the router.  The router successfully downloads a config from the tftp server, a lot of the configuration below was downloaded via tftp from the cucm.  On the CUCM under the transcoder, under XCODER, I see the router successfully registered with the routers IP address.  But the router never goes beyond registering with cm.

I changed the domain name below, but has the same number of characters/dots in case that is important.

Problem:

voiptest1#sh ccm

MGCP Domain Name: voiptest1.companys.aaa.int

Priority        Status                   Host

============================================================

Primary         Registering with CM      192.168.49.81

First Backup    None

Second Backup   None

router config:

hostname voiptest1

ip domain name companys.aaa.int

ccm-manager fallback-mgcp

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 192.168.49.81

ccm-manager config

!

mgcp

mgcp call-agent 192.168.49.81 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

no mgcp explicit hookstate

mgcp bind control source-interface GigabitEthernet0/0

mgcp bind media source-interface GigabitEthernet0/0

!

mgcp profile default

!

sccp local GigabitEthernet0/0

sccp ccm 192.168.49.81 identifier 1 priority 1 version 7.0

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register XCODER

associate profile 2 register CONFERENCE

!

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

unable to register mgcp gateway on cucm 9.1

Hi Clark,

Do u have any E1/T1 card on router since MGCP does not directly control FXS/FXO ports as compared to E1/T1?

regds,

aman

5 REPLIES
Purple

unable to register mgcp gateway on cucm 9.1

Hi Clark,

Do u have any E1/T1 card on router since MGCP does not directly control FXS/FXO ports as compared to E1/T1?

regds,

aman

Community Member

unable to register mgcp gateway on cucm 9.1

I hadnt added it yet, I just put it in the router and added it in the MGCP configuration on the server, still nothing.

Community Member

unable to register mgcp gateway on cucm 9.1

It registered after I applied the config to the PRI from the Server.  Thank you for the help.

unable to register mgcp gateway on cucm 9.1

Hi Beau,

Is the Domain name entered on the gateway page on cucm the same as on gateway i.e voiptest1.companys.aaa.int ?

Is there any firewall between the gateway and callmanager 192.168.49.81 ?

Config on the gateway loos good, you can try bouncing mgcp ( no mgcp / mgcp ) and collect debug mgcp packets for the same to get some additional pointers.

HTH

Manish

Purple

unable to register mgcp gateway on cucm 9.1

Hi Clark,

thanks for update.

If possible,please share show diag and complete show config of router.

a. show ccm-manager

b. show controller E1

regds,

aman

957
Views
0
Helpful
5
Replies
CreatePlease to create content