Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Unable to register MGCP gateway with CCM 4.1(3)

Hi All,

I have a lab set up having cisco 2821 router configured as MGCP gateway and have installed CCM 4.1(3). All cisco IP Phones are registered with CCM and are able to call from one IP Phone to other. Now I am planning to establish intercluster call and for that i need to register MGCP gateway with CCM. I have a gateway configuration as mentioned below and added the gateway in ccm 4.1(3) using Device>gateway>2821 + MGCP> [Domain name as 2811 hostname] + [call manager device pool]. But still the MGCP gateway is not getting registered with CCM. if you see the debug mgcp packets it looks like the CCM is not sending GW-1(hostname of Gateway) to MGCP gateway, which looks odd.Please help me if you have any idea on how to resolve this issue.

Gateway configuration

mgcp

mgcp call-agent 10.10.10.100

ccm-manager mgcp

GW-1#sh ccm-manager

MGCP Domain Name: GW-1

Priority Status Host

============================================================

Primary Registering with CM 10.10.10.100

First Backup None

Second Backup None

Current active Call Manager: None

Backhaul/Redundant link port: 2428

Failover Interval: 30 seconds

Keepalive Interval: 15 seconds

Last keepalive sent: 01:35:37 UTC Feb 11 2009 (elapsed time: 00:25:47

)

Last MGCP traffic time: 02:01:05 UTC Feb 11 2009 (elapsed time: 00:00:19

)

Last failover time: None

Last switchback time: None

Switchback mode: Graceful

MGCP Fallback mode: Not Selected

Last MGCP Fallback start time: None

Last MGCP Fallback end time: None

MGCP Download Tones: Disabled

Configuration Error History:

FAX mode: cisco

======================================================================================

debug mgcp packets

*Feb 11 01:59:05.775: MGCP Packet received from 10.10.10.100:2427--->

500 455185391

<---

*Feb 11 01:59:35.767: MGCP Packet sent to 10.10.10.100:2427--->

RSIP 455185393 *@GW-1 MGCP 0.1

RM: restart

<---

======================================================================================

GW-1#sh mgcp statistics

UDP pkts rx 70, tx 79

Unrecognized rx pkts 0, MGCP message parsing errors 0

Duplicate MGCP ack tx 0, Invalid versions count 0

CreateConn rx 0, successful 0, failed 0

DeleteConn rx 0, successful 0, failed 0

ModifyConn rx 0, successful 0, failed 0

DeleteConn tx 0, successful 0, failed 0

NotifyRequest rx 0, successful 0, failed 0

AuditConnection rx 0, successful 0, failed 0

AuditEndpoint rx 0, successful 0, failed 0

RestartInProgress tx 71, successful 71, failed 0

Notify tx 0, successful 0, failed 0

ACK tx 0, NACK tx 0

ACK rx 0, NACK rx 70

IP address based Call Agents statistics:

IP address 10.10.10.100, Total msg rx 22,

successful 0, failed 22

System resource check is DISABLED. No available statistic

====================================================================================

I have also referred to below link from cisco

<A HREF="javascript:newWin('http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a00805a316c.shtml')">http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a00805a316c.shtml</A>

<A HREF="javascript:newWin('http://supportwiki.cisco.com/ViewWiki/index.php/The_MGCP_gateway_does_not_register')">http://supportwiki.cisco.com/ViewWiki/index.php/The_MGCP_gateway_does_not_register</A>

FYI gateway and CCM are reachable and routing inside the network is perfect.

Thanks and Regards

Mangesh Bhende

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Unable to register MGCP gateway with CCM 4.1(3)

ok, you need and endpoint to register a GW

you don't have a PRI/FXS/FXO!

WHAT are you trying to register then?

only adding a GW with no endpoints won't register anything

Also this is absolutely wrong:

added the gateway in ccm 4.1(3) using Device>gateway>2821 + MGCP> [Domain name as 2811 hostname] + [call manager device pool].

you need the DOMAIN NAME NOT THE DEVICE POOL, also that only mentions you add a GW, NO ENDPOINTS

HTH

java

if this helps, please rate

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
10 REPLIES

Re: Unable to register MGCP gateway with CCM 4.1(3)

Hi Manghesh,

Is this exactly how you have defined the gateway in CCM:

GW-1

If you add a domain name or use the IP address it will not work.

-nick

New Member

Re: Unable to register MGCP gateway with CCM 4.1(3)

Hi Nick,

Yes I have added GW-1 correctly in CCM with 2821 MGCP in CCM as well as on 2821 router.

if you see the debug mgcp packets the CCM is not sending GW-1 in its mgcp message and i think that is the reason why it is not getting registered. Any idea why CCM is doing like that?

Regards

Mangesh Bhende

Cisco Employee

Re: Unable to register MGCP gateway with CCM 4.1(3)

exactly what endpoint are you attempting to register???

the 3 lines of config you posted are not enough

if this a PRI you need to config the MGCP there and backhaul the info to CCM

if FXS/FXO you need to configure the necessary dial-peers

HTH

java

if this helps, please rate

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

Re: Unable to register MGCP gateway with CCM 4.1(3)

Hi Java,

In my setup I dont have any PRI or FXS/FXO interfaces, only have IP Phones with which I am planning to establish intercluster calls.

In terms of configuration I have only ip address assignment and pure IP routing is enabled.

Cisco Employee

Re: Unable to register MGCP gateway with CCM 4.1(3)

ok, you need and endpoint to register a GW

you don't have a PRI/FXS/FXO!

WHAT are you trying to register then?

only adding a GW with no endpoints won't register anything

Also this is absolutely wrong:

added the gateway in ccm 4.1(3) using Device>gateway>2821 + MGCP> [Domain name as 2811 hostname] + [call manager device pool].

you need the DOMAIN NAME NOT THE DEVICE POOL, also that only mentions you add a GW, NO ENDPOINTS

HTH

java

if this helps, please rate

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

Re: Unable to register MGCP gateway with CCM 4.1(3)

Hi java,

Please correct me if i am wrong, For me to route the VOIP calls to other CCM cluster i need to register gateway then form trunk and then route the calls using route pattern. Is that correct?

Regards

Mangesh A. Bhende

New Member

Re: Unable to register MGCP gateway with CCM 4.1(3)

Hi Java/Nick

it was my misunderstanding that I need to register MGCP gateway with ccm for doing call routing with other CCM cluster. After your comment I havr created a trunk and then route pattern to route the calls. It was sussussfull. This has solved my problem. Thank you very much for your wonderfull comments.

Re: Unable to register MGCP gateway with CCM 4.1(3)

That's not the reason. It's hard to speculate why CUCM is sending a 500 message back to us without detailed CCM traces. It's almost always a configuration issue.

What version are you on?

New Member

Re: Unable to register MGCP gateway with CCM 4.1(3)

Hi Nick,

You mean on CCM or on router?

Regards

Mangesh A. Bhende

Re: Unable to register MGCP gateway with CCM 4.1(3)

Or you could post a screenshot of your MGCP configuration page - that would help.

I don't think it's version related, the MGCP debugs would look different, on second thought.

-nick

259
Views
0
Helpful
10
Replies