Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Unable to use touchtone service Cisco CME 7.1

Hi,

The  config below is a for a 2911 v/sec-k9 rtr with CME 7.1...I have  everything working..I can make outbound and receive inbound calls.  However when I call-in  to leave a message and hit the # key or call an  external number from my  cisco phone, I cannot seem to get the DTMF  (touchtone)  to work for answering AA prompts. Can someone look at my  config and please and tell me what I am doing wrong? I have another PBX  connected to the same provider, and I can answer DTMF prompts from the  AA.

Last configuration change at 16:48:01 EST Tue Jul 16 2013
logging buffered 51200
logging console critical

clock timezone EST -5
clock summer-time EST recurring

ip source-route
ip cef

!
ip dhcp excluded-address 10.52.35.1 10.52.35.69
ip dhcp excluded-address 10.52.35.200 10.52.35.254
!
ip dhcp pool MyLCLPool
import all
network 10.52.35.0 255.255.255.0

    domain-name myweb.net
dns-server 64.151.85.68 216.246.37.202
default-router 10.52.35.1
option 150 ip 10.52.35.1
option 66 ip 10.52.35.1
!

ip domain name myweb.net
ip name-server 209.18.47.61
ip name-server 64.151.85.68
!
multilink bundle-name authenticated
!
password encryption aes
voice-card 0

dspfarm
dsp services dspfarm
!

voice call send-alert
voice rtp send-recv
!
voice service voip
dtmf-interworking rtp-nte
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
supplementary-service h450.12
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none
sip
registrar server expires max 600 min 60
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
codec preference 3 g729br8
!

voice register global
mode cme
source-address 10.52.35.1 port 5060
max-dn 50
max-pool 30
timezone 13
time-format 24
dst start Apr day 1 time 02:00
dst stop Oct day 1 time 02:00
create profile sync 0014215810250381
!

voice translation-rule 1
rule 1 /9911/ /911/
rule 2 /9411/ /411/
!
voice translation-rule 2

rule 1 /97XX/ /7XX/<br />!<br />voice translation-rule 3<br /> rule 1 /9/ //
!
voice translation-rule 4
rule 1 /91/ /1/<br />!<br />voice translation-rule 5<br /> rule 1 /9011/ /011/
!
voice translation-rule 6
rule 1/17XXXXXXXX/ /1.../
!
voice translation-rule 7
rule 1 /1.../ /17XXXXXXXX/
!
!
voice translation-profile Incoming
translate calling 7
translate called 6
!
voice translation-profile Internationl
translate calling 7
translate called 5
!
voice translation-profile Local10
translate calling 7
translate called 2
!
voice translation-profile Local7
translate calling 7
translate called 3
!
voice translation-profile LongDistance
translate calling 7
translate called 4
!
voice translation-profile Services
translate calling 7
translate called 1
!
voice translation-profile voip-in
translate calling 2
translate called 1
!
!hw-module pvdm 0/0
energywise activitycheck
!
hw-module sm 1
!

redundancy

!
!
no ip ftp passive
ip ssh version 2
!
interface Loopback0
description created for NME-CUE loopback
ip address 10.52.21.1 255.255.255.0
!
!
interface GigabitEthernet0/0
description WAN
ip address dhcp client-id GigabitEthernet0/0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
!
interface GigabitEthernet0/1
description Internal Voice Lan$ETH-LAN$
ip address 10.52.35.1 255.255.255.0
ip helper-address 10.52.35.1
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!

!
interface Integrated-Service-Engine1/0
description Cisco NME-CUE 8.0 loopback
ip unnumbered Loopback0
ip virtual-reassembly
service-module ip address 10.52.21.2 255.255.255.0
!Application: CUE Running on NME
service-module ip default-gateway 10.52.21.1
no keepalive
!
!
!
ip forward-protocol nd
!
ip http server
ip http secure-server
ip http path flash:/GUI
!
ip nat inside source list 3 interface GigabitEthernet0/0 overload
ip route 10.52.21.2 255.255.255.255 Integrated-Service-Engine1/0
!
access-list 1 remark CCP_ACL Category=16
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 2 remark CCP_ACL Category=2
access-list 2 permit 10.52.35.0 0.0.0.255
access-list 3 remark CCP_ACL Category=2
access-list 3 permit 10.52.35.0 0.0.0.255
!
!
tftp-server flash:term06.default.loads alias term06.default.loads
tftp-server flash:term11.default.loads alias term11.default.loads
tftp-server flash:B015-1-0-3.SBN alias B015-1-0-3.SBN
tftp-server flash:B016-1-0-3.SBN alias B016-1-0-3.SBN
tftp-server flash:CP7921G-1.3.3.LOADS alias CP7921G-1.3.3.LOADS
tftp-server flash:APPS-1.3.3.SBN alias APPS-1.3.3.SBN
tftp-server flash:GUI-1.3.3.SBN alias GUI-1.3.3.SBN
tftp-server flash:MISC-1.3.3.SBN alias MISC-1.3.3.SBN
tftp-server flash:SYS-1.3.3.SBN alias SYS-1.3.3.SBN
tftp-server flash:TNUX-1.3.3.SBN alias TNUX-1.3.3.SBN
tftp-server flash:WLAN-1.3.3.SBN alias WLAN-1.3.3.SBN
tftp-server flash:term31.default.loads alias term31.default.loads
tftp-server flash:apps37sccp.1-3-4-0.bin alias apps37sccp.1-3-4-0.bin
tftp-server flash:term41.default.loads alias term41.default.loads
tftp-server flash:term61.default.loads alias term61.default.loads
tftp-server flash:term42.default.loads alias term42.default.loads
tftp-server flash:term62.default.loads alias term62.default.loads
tftp-server flash:term45.default.loads alias term45.default.loads
tftp-server flash:term65.default.loads alias term65.default.loads
tftp-server flash:term75.default.loads alias term75.default.loads
tftp-server flash:term70.default.loads alias term70.default.loads
tftp-server flash:term71.default.loads alias term71.default.loads
tftp-server flash:p00307020300.bin
tftp-server flash0:dsp45.9-2-1TH1-13.sbn alias dsp45.9-2-1THT1-13.sbn
tftp-server flash0:jar45sccp.9-2-1TH1-13.sbn alias jar45sccp.9-2-1THT1-13.sbn
tftp-server system:/its/SEPDEFAULT.cnf alias SEPDEFAULT.cnf
tftp-server system:/its/vrf1/ATADefault.cnf.xml
tftp-server system:/its/united_states_7960-tones.xml
tftp-server system:/its/united_states alias United_States_7960-tones.xml
!
control-plane
!
call threshold global cpu-avg low 68 high 75
call threshold global total-mem low 75 high 85
call threshold global total-calls low 1 high 2
!
dspfarm profile 1 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
maximum sessions 5
associate application SCCP
!
dial-peer voice 100 voip
description Connect to voicemail
destination-pattern 5...
session protocol sipv2
session target ipv4:10.52.21.2
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 10 voip
translation-profile outgoing Services
destination-pattern 9[49]11
session protocol sipv2
session target dns:sip.provider.com
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 11 voip
translation-profile outgoing Local10
destination-pattern 9718[2-9]......
session protocol sipv2
session target dns:sip.provider.com
dtmf-relay rtp-nte
dtmf-interworking rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 12 voip
translation-profile outgoing Local7
destination-pattern 9[2-9]......
session protocol sipv2
session target dns:sip.provider.com
incoming called-number .
dtmf-relay rtp-nte
dtmf-interworking rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 13 voip
translation-profile outgoing LongDistance
destination-pattern 91[2-9]..[2-9]......
session protocol sipv2
session target dns:sip.provider.com
dtmf-relay rtp-nte
dtmf-interworking rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 14 voip
translation-profile outgoing International
destination-pattern 9011T
session protocol sipv2
session target dns:sip.provider.com
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 1 voip
description *** Incoming call from SIP Trunk ***
translation-profile incoming Incoming
destination-pattern 1...
session protocol sipv2
session target sip-server
session transport tcp
incoming called-number 17XX......
voice-class codec 1
dtmf-relay rtp-nte
no vad
!
dial-peer voice 101 voip
description *** CUE VOICEMAIL AA NUMBER ***
destination-pattern 5002
session protocol sipv2
session target ipv4:10.52.21.2
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 102 voip
description *** CUE aVT PILOT NUMBER ***
destination-pattern 5003
session protocol sipv2
session target ipv4:10.52.21.2
dtmf-relay sip-notify
codec g711ulaw
no vad
!
sip-ua
credentials username username 7 0050312A5C0 realm sip.provider.com
  authentication username username password 7 0879271E033A
no remote-party-id
retry register 3
registrar dns:sip.provider.com expires 300
sip-server dns:sip.provider.com
!
telephony-service
authentication credential vmail xxxxxx
max-ephones 30
max-dn 50
ip source-address 10.52.35.1 port 2000
calling-number initiator
system message Fix Me!!
  url services http://10.52.21.2/voiceview/common/login.do
url authentication http://10.52.21.1/CCMCIP/authenticate.asp  
cnf-file location flash:
load 7915-12 B015-1-0-3.SBN
load 7915-24 B015-1-0-3.SBN
load 7916-12 B016-1-0-3.SBN
load 7916-24 B016-1-0-3.SBN
load 7906 SCCP11.8-5-3S.loads
load 7911 SCCP11.8-5-3S.loads
load 7921 CP7921G-1.3.3.LOADS
load 7931 SCCP31.8-5-3S.loads
load 7937 apps37sccp.1-3-4-0.bin
load 7941 SCCP41.8-5-3S.loads
load 7941GE SCCP41.8-5-3S.loads
load 7942 SCCP42.8-5-3S.loads
load 7945 SCCP45.8-5-3S.loads
load 7961 SCCP41.8-5-3S.loads
load 7961GE SCCP41.8-5-3S.loads
load 7962 SCCP42.8-5-3S.loads
load 7965 SCCP45.9-2-1S.loads
load 7970 SCCP70.8-5-3S.loads
load 7971 SCCP70.8-5-3S.loads
load 7975 SCCP75.8-5-3S.loads
time-zone 13
voicemail 5001
max-conferences 4 gain -6
call-forward pattern .T
call-forward pattern 9.T
call-forward system redirecting-expanded
moh flash:/music-on-hold.au
web admin system name vmail password xxxxxxxx
web admin customer name user password xxxxxxx
dn-webedit
time-webedit
transfer-system full-consult
transfer-pattern .T
secondary-dialtone 9
create cnf-files version-stamp 7960 Jul 14 2013 02:03:20
!

ephone-dn 1 dual-line
number 1001
call-forward busy 5002
call-forward noan 5001 timeout 15
!
ephone-dn 2 dual-line
number 1002
call-forward busy 5001
call-forward noan 5001 timeout 15
!
ephone-dn 3 dual-line
number 1003
!
ephone 1
device-security-mode none
mac-address 0022.555E.9ED1
button 1:1 2:2 3:3
!

line 67
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh

ntp master


end

2 REPLIES
VIP Super Bronze

Unable to use touchtone service Cisco CME 7.1

Can you do a test call and send the following:

debug ccsip messages

debug voip rtp session-named event

Include the calling and called number and the digits you pressed

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Re: Unable to use touchtone service Cisco CME 7.1

HI sorry for not responding earlier. Please see the attached debug file.....

329
Views
0
Helpful
2
Replies