Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Unity Connection AXL connection to CUCM fails with unhelpful error message

Customer has a Unity Connection server connected to two different CUCM clusters.  Existing system is set up with the phone systems including the AXL setup.

We are upgrading and virtualizing by doing a parallel build and will then use COBRAS to migrate.

 

After the new system was built, we set up one of the CUCM clusters, and configured it for AXL, and it was fine.  The second is being a problem.

The setup to the second cluster fails on the AXL setup.  I get a very cryptic error message that says "Failed to send message to remote AXL server.  Please check error log for more details."  Doesn't say what error log, and doesn't say on what device.  I've dug around in the Unity Connection logs, and found nothing helpful.  CUCM has a little more.  I see the AXL request coming in, but for some reason, the query itself never does.

I've restarted the AXL service on CUCM, reset passwords, verified permissions, and cannot figure out what the problem is.  There is one indication of a similar problem 5 years ago on a forum message, but that solution wasn't helpful for this situation.  Google offered nothing else either.

 

Since it works on one CUCM cluster (the v9 cluster) and doesn't work on the other (the v8 cluster), but the existing system works with both, I'm completely baffled as to why it's not working.

Any clues would be appreciated.

 

-Cliff

Everyone's tags (1)
11 REPLIES
Cisco Employee

Hi Cliff,Where are you seeing

Hi Cliff,

Where are you seeing this error message? When you are trying to key in the AXL creds and submit them, can you have a packet capture running on the UC server so you can see if the UC is trying to reach CUCM, and if CUCM then sends an RST back to CUC?

 

Hantale

Sree

I get the error message on

I get the error message on the page after adding the ip address of the CUCM publisher and the AXL login credentials.

Not running a packet capture, but I see the beginning of the AXL communications between the servers in the AXL log on CUCM.  Whatever is happening seems to be occurring within Unity Connection, but I'm not sure why.

Cisco Employee

What's the version of CUC?Can

What's the version of CUC?

Can you check the port numbers being used and make sure that the password is correct? I've seen issues like this related to config.

Are you using hostnames or IP addresses?

How about restarting AXL on the CUC?

CUC version 9.1Port number is

CUC version 9.1

Port number is correct.  Same setup works on existing v7 UCxN server.

Using IP addresses.

There is no option to restart AXL on UCxN v9 under connection servicability or under the platform servicability.

Cisco Employee

Have you tried to delete the

Have you tried to delete the config and re-add it?

Also, can you try pulling the axl logs from the UC and upload them here?

Several times.Tac is

Several times.

Tac is suggesting it may be a bug:  CSCug64397

Still chasing...

TAC has confirmed it is in

TAC has confirmed it is in fact that bug.  They had me turn up the CUCA micro traces, and then pull the Tomcat logs after repeating the problem.

 

The logs showed the following (which the TAC engineer says matches the defect description):

 

22:01:53.104 |28405,,,Cuca,1,ERROR [http-bio-443-exec-1] com.cisco.unity.admin.actions.MediaRemoteServiceDispatchAction  - AXLException caught: message = com.sun.xml.internal.messaging.saaj.SOAPExceptionImpl: Bad response: (599null

22:01:53.105 |28405,,,Cuca,1,com.cisco.unity.axlconnector.AXLConnector.parseException(Unknown Source)

22:01:53.105 |28405,,,Cuca,1,com.cisco.unity.axlconnector.AXLConnector.sendSqlQuery(Unknown Source)

22:01:53.105 |28405,,,Cuca,1,com.cisco.unity.axlconnector.AXLConnector.executeSqlQuery(Unknown Source)

 

Hope this helps someone else.  Finding information about this was a real pain in the neck.

 

Cliff

New Member

Hi Cliff,I currently have a

Hi Cliff,

I currently have a support case open for this however its not going to well. 

 

How was your issue fixed?

 

Issue was identified as a bug

Issue was identified as a bug: CSCug64397

The details are in the notes near the bottom of this thread.

The latest patch that was on CCO was affected by this bug, so the TAC engineer had to publish an ES build to me.  Applied that, and it fixed the issue.

 

New Member

Thanks, I just ran the logs

Thanks, I just ran the logs and can see the same Reponses. I'll show this to the case officer.

 

I couldn't see the workaround in the bug report.

 

Cheers for the prompt reply.

 

Andrew

Sorry about that.I will tell

Sorry about that.

I will tell you that the initial TAC response was to upgrade to the latest code on CCO.  I was already there, so that caused me to raise my eyebrows and point out the obvious (he had this info).

He verified the problem still existed, and then published this version out to me:

UCSInstall_UCOS_9.1.2.12033-1.sgn.iso

It's an ES, and not on CCO.  So you'll have to get the engineer to provide it to you.

Good luck.

1756
Views
5
Helpful
11
Replies
CreatePlease to create content