Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Unity Connection Voice Mail Issue

Hi,

I have a weird Unity Connection Voice Mail issue and would appriciate any help i can get. Many thanks in advance.

I have Unity connection 7.0 and CUCM 7.0 integrated in a lab enviroment and here is what happens.

When I place a call internally say from 2001 to 2002, things work as expected, 2002 rings and it goes to voicemail where I can leave voicemail and listen to it from 2002.

However, if I place call from the PSTN to the same number 2002 (or any other number in other sites etc) the call again rings in 2002 and goes to voicemail, unity cnx plays the greetings for 2002 and says record your message as usual. Everything up to point is fine, then when the time on the PSTN phone is showing around 14 seconds into the call unity starts playing, "to send this message press one", if I press one nothing happens.

I have rebuilt unity and cucm, even just configured the bare minimum in the lab and still getting the same result. I tried calling from E1 connection and T1 connection but with the same results.

I have run out of ideas...

===============================

Here is a call trace from an internal call:

CallData, 1, CallerId=2003, CalledId=2002, RedirectingId=2002, Origin=16, Reason=4, CallGuid=8B7859FD6C16417A9A07F507418DD25B, CallerName=, LastRedirectingId=2002, LastRedirectingReason=4, PortDisplayName=PhoneSystem-1-001

Application, 1, 2003, AttemptForward

State, 1, 2003, State - AttemptForward.cde!Dummy

State, 1, 2003, Event is [NULL]

Application, 1, 2003, PHTransfer

State, 1, 2003, State - PHTransfer.cde!LoadInfo

State, 1, 2003, Event is [TrueEvent]

Application, 1, 2003, PHGreeting

State, 1, 2003, State - PHGreeting.cde!PlayGreeting

Display, 1, 2003, Call answered if needed

Display, 1, 2003, Playing greeting for Subscriber:  hq2

Display, 1, 2003, No DTMF received

Display, 1, 2003, Playing greeting for Subscriber:  hq2

State, 1, 2003, Event is [RecordMsgEvent]

State, 1, 2003, State - PHGreeting.cde!RecordMsg

State, 1, 2003, Event is [NULL]

State, 1, 2003, State - PHGreeting.cde!RunEditMsg

Application, 1, 2003, -->MessageEditing

State, 1, 2003, State - MessageEditing.cde!CheckMsgMenuOpt

State, 1, 2003, Event is [EditMessageMenuEvent]

State, 1, 2003, State - MessageEditing.cde!PlayEditMenu

State, 1, 2003, Event is [HangupEvent]

State, 1, 2003, State - MessageEditing.cde!CheckMsgLength

State, 1, 2003, Event is [ManyEvent]

State, 1, 2003, State - MessageEditing.cde!SendMsg

State, 1, 2003, Event is [TrueEvent]

State, 1, 2003, State - MessageEditing.cde!ConfirmSend

State, 1, 2003, Event is [HangupEvent]

Application, 1, 2003, <--MessageEditing

State, 1, 2003, Event is [HangupEvent]

Display, 1, 2003, Idle

Display, 1, , Dialing (MWI) '2002'

Display, 1, , Idle

--------------------------------------------------------------------

and here is a trace from an external (PSTN) call

Trying 142.100.64.13, 5000 ... Open

CallData, 1, CallerId=911, CalledId=2002, RedirectingId=2002, Origin=16, Reason=4, CallGuid=CA3DFD90846C4FE7B0D68298A7698287, CallerName=PSTN Emergency, LastRedirectingId=2002, LastRedirectingReason=4, PortDisplayName=PhoneSystem-1-001

Application, 1, 911, AttemptForward

State, 1, 911, State - AttemptForward.cde!Dummy

State, 1, 911, Event is [NULL]

Application, 1, 911, PHTransfer

State, 1, 911, State - PHTransfer.cde!LoadInfo

State, 1, 911, Event is [TrueEvent]

Application, 1, 911, PHGreeting

State, 1, 911, State - PHGreeting.cde!PlayGreeting

Display, 1, 911, Call answered if needed

Display, 1, 911, Playing greeting for Subscriber:  hq2

Display, 1, 911, No DTMF received

Display, 1, 911, Playing greeting for Subscriber:  hq2

State, 1, 911, Event is [RecordMsgEvent]

State, 1, 911, State - PHGreeting.cde!RecordMsg

State, 1, 911, Event is [NULL]

State, 1, 911, State - PHGreeting.cde!RunEditMsg

Application, 1, 911, -->MessageEditing

State, 1, 911, State - MessageEditing.cde!CheckMsgMenuOpt

State, 1, 911, Event is [EditMessageMenuEvent]

State, 1, 911, State - MessageEditing.cde!PlayEditMenu

State, 1, 911, Event is [HangupEvent]

State, 1, 911, State - MessageEditing.cde!CheckMsgLength

State, 1, 911, Event is [NULL]

Application, 1, 911, <--MessageEditing

State, 1, 911, Event is [NULL]

State, 1, 911, State - PHGreeting.cde!AfterMsg

State, 1, 911, Event is [NULL]

Display, 1, 911, Idle

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Unity Connection Voice Mail Issue

Sounds like one way audio from PSTN to your Unity Connection, couple of things to check:

1. ensure your protocols are bound properly on the GW, i.e. SIP/H323/MGCP

2. Make sure IP routing is OK between Unity and the voice gateway

HTH,

Chris

2 REPLIES
Hall of Fame Super Silver

Unity Connection Voice Mail Issue

Sounds like one way audio from PSTN to your Unity Connection, couple of things to check:

1. ensure your protocols are bound properly on the GW, i.e. SIP/H323/MGCP

2. Make sure IP routing is OK between Unity and the voice gateway

HTH,

Chris

New Member

Unity Connection Voice Mail Issue

Hi Chris,

Your pointer gave me good food for thought and eventually it turned out to be an access list on the PSTN side blocking the PSTN phone from sending any auido. Appriciated.

Many thanks,

308
Views
0
Helpful
2
Replies