Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Unity does not responds to DTMF from Motorolla and Apple iPhones.

I have a H.323 gateway connected to PSTN and CUCM in other end, the CUCM is integrated with the Unity.

The set up is like, whenever my extensions are busy, the IVR setup in the unity must work.

PSTN CLOUD >> H.323 G/W >> CUCM >> UNITY

Things are working when the calls made from landline and mobile phones, but when a call made from Motorola mobile phones and Apple iPhone, the unity does not responds to the DTMF.

Call manager version - 6.1.2

Unity version : 5.0(1)

H.323 g/w version : c2800nm-advipservicesk9-mz.124-9.T3.bin

Anyone have an idea what could be the reason ?

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Unity does not responds to DTMF from Motorolla and Apple iPhones

What are you using for your PSTN connection? PRI? SIP trunk? Analog line?

First, you will want to ensure you are receiving the DTMF at the gateway.  The debug commands will vary based on what kind of PSTN connection you have.

3 REPLIES
Silver

Unity does not responds to DTMF from Motorolla and Apple iPhones

What are you using for your PSTN connection? PRI? SIP trunk? Analog line?

First, you will want to ensure you are receiving the DTMF at the gateway.  The debug commands will vary based on what kind of PSTN connection you have.

New Member

Unity does not responds to DTMF from Motorolla and Apple iPhones

Hi Meade,

its a PRI line, i have tried the below debug output, but unable to get DTMF related logs...is there any other debug to capture the DTMF signal hitting the h.323 gateway?

 

debug vpm signal

debug vtsp session

debug vtsp dsp

debug voip ccapi inout

debug h245 asn1

debug voip rtp

debug cch323 rtp

debug voip ccapi inout
debug h245 asn1
debug voip rtp
debug cch323 rtp

Silver

Unity does not responds to DTMF from Motorolla and Apple iPhones

Try these-

debug vtsp dsp

debug voip rtp session named-event

Make sure you have term mon turned on if you are connecting via telnet/ssh.

If you still do not see anything, your carrier may not be sending the digits at all so you will need to work with them.

Brian Meade

426
Views
0
Helpful
3
Replies
CreatePlease to create content