Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Updating CUCM users via BAT

I am running CUCM 9.1(2) and I am trying to update the user to ensure device association and group membership.  I created a CSV file based on a BAT export and updated the group and associated device fields and for the PIN, Password and Digest Credentials fields I have used the # symbol coupled with the "Value for fields to be ignored" option.

When i run the BAT job i get the following error for almost all of the records

 

[user id]  Missing key in referenced table for referential constraint (informix.fk_enduser_fkucserviceprofile).

 

I am not using a user template for the BAT update and my users are all LDAP sync'ed

 

I have not been able to find anything helpful online, does anyone have any ideas?

 

Thanks in advance

 

 

6 REPLIES
Cisco Employee

I think you may be hitting

I think you may be hitting this bug. CSCue02300

Have you filled in anything on the MLPP attrib column?

New Member

Thanks Sreekanth,The 3 MLPP

Thanks Sreekanth,

The 3 MLPP columns are all blank but it does look like a similar bug

Set the Bulk Provisioning

Set the Bulk Provisioning Service traces to Detailed/Debug level under Unified Serviceability->Trace->Configuration then run the BAT job again and pull the BPS traces via RTMT.  That should have more details on what the issue is.

Hi,Please look for the bug

Hi,

Please look for the bug CSCue81148, CSCud9100.

Even I had the issue for the CUCM 9.1.1 version when I was trying to associate the User with their respective devices. (not with group).

I see your is 9.1.2.

 

Regards,

Raaj.

 

 

 

 

Bronze

 Hi,Just another thing that

 

Hi,

Just another thing that could be worth checking "fk_enduser_fkucserviceprofile" sounds like is referencing the UC Service Profile for IM&P are you populating, ignoring with a #, or is it blank? If you are ignoring with a # try just setting it to blank.

 

I found when enabling users with IM&P I had to specify the UC Service profile and not just use the system default

 

New Member

Thanks Heathrw, I actually

Thanks Heathrw, I actually missed that the service profile was listed in the error.  I reached out to TAC and they suggested that i convert the users to local users, run the BAT update and then resync with the AD.

It worked but not the best solution so i will try again with another set of users and this time add a UC service profile.

 

thanks

 

449
Views
2
Helpful
6
Replies
CreatePlease login to create content