Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Upgrade Cisco Unity Express from 3.x to 7.1.x

I have successufully upgraded a cisco unity express (AIM-CUE) from 3.x to 7.1.x, however it now asks for the upload of software licenses. I have alredy uploaded the Mail-Box Licenses and IVR licences, but the unit reports it cannot activate them since it has no port licenses, do these licenses have to be purchased separately or do they come with the AIM-CUE , if so how can I reactivate them.

4 REPLIES
Hall of Fame Super Red

Re: Upgrade Cisco Unity Express from 3.x to 7.1.x

Hi Duarte,

It looks like you are seeing this issue;

Note Each IVR session consumes one port and thus reduces the number of ports available for use by voicemail or auto-attendant applications. Please carefully consider how many IVR session licenses you need and only install or activate licenses for that number of IVR sessions.

If the number of IVR session licenses is greater than or equal to the number of ports, then voicemail and auto-attendant applications will be disabled due to the lack of available ports. The show license status application command will indicate this condition by stating the error message "voicemail disabled, ivr session quantity (x) is equal to or exceeds available ports (Y)" where X is the number of IVR sessions and Y is the number of ports. To change this condition, either reduce the number of IVR sessions via the command license activate ivr sessions N (where N is less than the number of ports and may be zero to deactivate all IVR sessions), or remove the IVR session licenses, or add more port licenses, and then issue the reload command.


http://www.cisco.com/en/US/docs/voice_ip_comm/unity_exp/rel7_1/Licensing/Using_CSL.html#wp1065047



Look @ this command for confirmation;

show license status application voicemail

voicemail disabled, ivr session quantity (x) is equal to or exceeds available ports (x)

Hope this helps!

Rob

New Member

Re: Upgrade Cisco Unity Express from 3.x to 7.1.x

Hello Rob,

Thanks for the quick reply however the problem seems a bit more complicated.

the command show license stats applications returns:

show license status application v
voicemail disabled, no activated port license available

Indicating that there is no port licenses available

the show licenses all gives a little bit more insight of the problem:

License Store: Primary License Storage
StoreIndex:  0  Feature: VMIVR-IVR-SESS                    Version: 1.0
        License Type: Permanent
        License State: Active, In Use
        License Count: 2 /2
        License Priority: Medium
License Store: Primary License Storage
StoreIndex:  1  Feature: VMIVR-VM-MBX                      Version: 1.0
        License Type: Permanent
        License State: Active, In Use
        License Count: 30 /30
        License Priority: Medium
License Store: Evaluation License Storage
StoreIndex:  0  Feature: VMIVR-VM-MBX                      Version: 1.0
        License Type: Evaluation
        License State: Inactive
            Evaluation total period:  8 weeks  4 days
            Evaluation period left:  8 weeks  4 days
        License Count: 600 / 0
        License Priority: None
License Store: Evaluation License Storage
StoreIndex:  1  Feature: VMIVR-PORT                        Version: 1.0
        License Type: Evaluation
        License State: Active, Not in Use, EULA not accepted
            Evaluation total period:  8 weeks  4 days
            Evaluation period left:  8 weeks  4 days
        License Count: 60 / 0
        License Priority: None
License Store: Evaluation License Storage
StoreIndex:  2  Feature: VMIVR-IVR-SESS                    Version: 1.0
        License Type: Evaluation
        License State: Inactive
            Evaluation total period:  8 weeks  4 days
            Evaluation period left:  8 weeks  4 days
        License Count: 60 / 0
        License Priority: None

It is possible to see that there are no Port Licenses, only evaluation ones that expire after eight weeks. witch leeds me to believe that ether they have to be purchased separatly or need to be reactevated somehow.

.

Hall of Fame Super Red

Re: Upgrade Cisco Unity Express from 3.x to 7.1.x

Hi Duarte,

I see.

Did you go through the License Migration to obtain "new" CSL licenses

as shown below??

Overview of Software Activation of Cisco Unity Express

Beginning with Cisco Unity Express 7.1, a new type of license called CSL licensing is supported. With CSL licenses, the mailbox license count includes both personal mailboxes and GDMs. The type of the mailbox is determined when it is configured. Also, the call-agent is no longer specified using licenses and can be configured either as part of post-install process or during bootup.

You can buy CSL licences for the following types of features:

•Mailboxes

•Ports

•IVR

•TimeCardView

As an example, if you purchase CSL licenses for 4 IVR sessions, 10 ports, and 265 mailboxes, then you can use 6 ports for either the Auto-Attendant or voice mail, and 4 ports for IVR.

Note Each IVR session consumes one port and thus reduces the number of ports available for use by voicemail or auto-attendant applications. Please carefully consider how many IVR session licenses you need and only install or activate licenses for that number of IVR sessions.


Obtaining Migration Licenses

There are two methods of obtaining CSL migration licenses:

•Required Information

•Using the Migration Portal

•Using Cisco License Manager

Note There is no cost to obtain migration licenses for CSL.


Required Information

To obtain CSL migration licenses you need to have the following information:

•The SKU for the features that you need.

This is the information that you determined in the "Selecting which Features You Want" section.

•The Product ID (PID)

•The Serial Number (SN) from the device.
Using the Migration Portal

Note You must have a CCO password to access some of the URLs in the following procedure.

Follow these steps to obtain a migration license for your existing Cisco Unity Express 7.1 features:

Step 1 Go to the licensing portal at www.cisco.com/go/license and click the link at the bottom of the page to go to the license migration portal.

Step 2 On the router that is running the features that you want to migrate, enter the show inventory command to see the corresponding product IDs and serial numbers.

Step 3 Enter the appropriate product ID and the serial number and click Continue.

The product ID is the type of Network Module that you are using, such as AIM-CUE.

Step 4 Use the drop-down menus to select the product family, product, and feature (SKU), then click Continue.

For the product, use the SKU that you determined in the previous section for the features that you want to migrate.

Enter your registration information, including your company's name and e-mail address, then click Continue.

Step 5 Verify all of your license information and click Submit to receive the free CSL upgrade license file by e-mail.

Step 6 Repeat the appropriate steps above for each device that is running features that you want to migrate.

Step 7 Copy the license file(s) to a FTP or TFTP server. applications will be disabled due to the lack of available ports. The show license status application command will indicate this condition by stating the error message "voicemail disabled, ivr session quantity (x) is equal to or exceeds available ports (Y)" where X is the number of IVR sessions and Y is the number of ports. To change this condition, either reduce the number of IVR sessions via the command license activate ivr sessions N (where N is less than the number of ports and may be zero to deactivate all IVR sessions), or remove the IVR session licenses, or add more port licenses, and then issue the reload command.

This info is from the doc I linked earlier.

Cheers!

Rob

New Member

Re: Upgrade Cisco Unity Express from 3.x to 7.1.x

This issue was finnaly solved. The port licenses hand to be migrated as rob indicated using the migration licenses link.

1146
Views
9
Helpful
4
Replies
CreatePlease to create content