Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Upgrading FW on 7961G-GE - CME 8.6

Hi All,

I am a little confused on the firmware path to get my 7961s to the latest firmware. I would ultimately like to get them running 9.1(1). They are currently running fw 7.0(3) on CME 8.6. What would the version upgrade path look like to get them to 9.1(1)? I have tried upgrading them to 8.5(3)SR1S but that did not work. Do I need to upgrade to an earlier version? Instead of guessing thought I would ask here.

Thanks in advance.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Red

Upgrading FW on 7961G-GE - CME 8.6

Hi Johnny,

You are most correct

Firmware Upgrade Issues for SCCP


Note For all SCCP firmware upgrades from firmware release versions earlier than 8.3(3) to version 9.1(1)SR1 or greater, you must first upgrade your firmware to an intermediate version (8.3(3) - 8.5(2)) then upgrade to 9.1(1)SR1.



Note This section applies to the Cisco Unified IP Phone 7975G, 7971G-GE, 7970G, 7965G, 7962G, 7961G-GE, 7961G, 7945G, 7942G, 7941G-GE, 7941G, 7911G, and 7906G.


The following upgrade issues apply:

If you are currently running firmware earlier than 6.0(2) on a Cisco Unified IP Phone and want to upgrade to 8.x(x), you must first install an intervening 7.0(x) load to prevent upgrade failure. Cisco recommends using the most recent 7.0(3) load as the intervening load to avoid lengthy upgrade times.

If you are currently running firmware 6.0(2) to 7.0(2) on a Cisco Unified IP Phone and want to upgrade to 8.x(x), you can do so directly. However, expect the upgrade to take twice as long as usual.

Device packs are required to enable IP Phones in the Cisco Unified Communications Manager database. For Cisco Unified CallManager 4.2 and earlier, these device packs are required. For Cisco Unified CallManager 4.3 and Cisco Unified Communications Manager 6.0 and later, you must run the device pack and reboot the Cisco Unified Communications Manager server.

http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/firmware/9_1_1/english/release/notes/7900_911.html#wp42467

Cheers!

Rob

Hall of Fame Super Red

Upgrading FW on 7961G-GE - CME 8.6

Hi Johnny,

Did you try the "no create cnf" and "create cnf" under telephony service after removing the

.loads ??

Cheers!

Rob

7 REPLIES
Hall of Fame Super Red

Upgrading FW on 7961G-GE - CME 8.6

Hi Johnny,

You are most correct

Firmware Upgrade Issues for SCCP


Note For all SCCP firmware upgrades from firmware release versions earlier than 8.3(3) to version 9.1(1)SR1 or greater, you must first upgrade your firmware to an intermediate version (8.3(3) - 8.5(2)) then upgrade to 9.1(1)SR1.



Note This section applies to the Cisco Unified IP Phone 7975G, 7971G-GE, 7970G, 7965G, 7962G, 7961G-GE, 7961G, 7945G, 7942G, 7941G-GE, 7941G, 7911G, and 7906G.


The following upgrade issues apply:

If you are currently running firmware earlier than 6.0(2) on a Cisco Unified IP Phone and want to upgrade to 8.x(x), you must first install an intervening 7.0(x) load to prevent upgrade failure. Cisco recommends using the most recent 7.0(3) load as the intervening load to avoid lengthy upgrade times.

If you are currently running firmware 6.0(2) to 7.0(2) on a Cisco Unified IP Phone and want to upgrade to 8.x(x), you can do so directly. However, expect the upgrade to take twice as long as usual.

Device packs are required to enable IP Phones in the Cisco Unified Communications Manager database. For Cisco Unified CallManager 4.2 and earlier, these device packs are required. For Cisco Unified CallManager 4.3 and Cisco Unified Communications Manager 6.0 and later, you must run the device pack and reboot the Cisco Unified Communications Manager server.

http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/firmware/9_1_1/english/release/notes/7900_911.html#wp42467

Cheers!

Rob

Community Member

Upgrading FW on 7961G-GE - CME 8.6

Thanks Rob,

Not sure what the issue is here now. I downloaded fw 8.5(2) and tftp to flash all 8 files. Entered all 8 tftp-server statements and added "load 7961GE SCCP41.8-5-2S.loads" under telephony service. My phones won't upgrade. Any ideas? Also did the "no create cnf" and "create cnf" under telephony service before resetting.

Hall of Fame Super Red

Upgrading FW on 7961G-GE - CME 8.6

Hi Johnny,

Can you please try (under telephony service);

load 7961GE SCCP41.8-5-2S

without the .loads extension

Cheers!

Rob

Community Member

Upgrading FW on 7961G-GE - CME 8.6

Thanks Rob. I already tried that. But, I went ahead and tried it again with the same results. They still have the old fw. Here is the "debug tftp events" output: It appears it finds the files on flash but doesn't do anything with them.

3RT-2821(config-ephone)#

.Nov  1 09:13:42.413: %IPPHONE-6-UNREGISTER_NORMAL: ephone-30:SEP001BD40BF4A7 IP:192.168.30.72 Socket:7 DeviceType:Phone has unregistered normally.

3RT-2821(config-ephone)#

.Nov  1 09:14:23.957: TFTP: Looking for CTLSEP001BD40BF4A7.tlv

.Nov  1 09:14:24.725: TFTP: Looking for LightSaber.raw

.Nov  1 09:14:24.833: TFTP: Looking for SEP001BD40BF4A7.cnf.xml

.Nov  1 09:14:25.305: TFTP: Opened system:/its/vrf1/XMLDefault7961GE.cnf.xml, fd 10, size 1279 for process 277

3RT-2821(config-ephone)#

.Nov  1 09:14:25.309: TFTP: Finished system:/its/vrf1/XMLDefault7961GE.cnf.xml, time 00:00:00 for process 277

.Nov  1 09:14:25.461: TFTP: Looking for SCCP41.8-5-2S.loads

.Nov  1 09:14:25.465: TFTP: Opened flash:SCCP41.8-5-2S.loads, fd 10, size 650 for process 277

.Nov  1 09:14:25.469: TFTP: Finished flash:SCCP41.8-5-2S.loads, time 00:00:00 for process 277

.Nov  1 09:14:25.989: TFTP: Looking for jar41sccp.8-5-2TH1-9.sbn

.Nov  1 09:14:25.993: TFTP: Opened flash:jar41sccp.8-5-2TH1-9.sbn, fd 10, size 1628113 for process 277

3RT-2821(config-ephone)#

.Nov  1 09:14:31.245: TFTP: Finished flash:jar41sccp.8-5-2TH1-9.sbn, time 00:00:05 for process 277

3RT-2821(config-ephone)#

.Nov  1 09:14:35.553: TFTP: Looking for cnu41.8-5-2TH1-9.sbn

.Nov  1 09:14:35.557: TFTP: Opened flash:cnu41.8-5-2TH1-9.sbn, fd 10, size 498984 for process 277

3RT-2821(config-ephone)#

.Nov  1 09:14:37.129: TFTP: Finished flash:cnu41.8-5-2TH1-9.sbn, time 00:00:01 for process 277

3RT-2821(config-ephone)#

.Nov  1 09:14:38.813: TFTP: Looking for apps41.8-5-2TH1-9.sbn

.Nov  1 09:14:38.817: TFTP: Opened flash:apps41.8-5-2TH1-9.sbn, fd 10, size 2933329 for process 277

3RT-2821(config-ephone)#

.Nov  1 09:14:45.357: TFTP: Finished flash:apps41.8-5-2TH1-9.sbn, time 00:00:06 for process 277

3RT-2821(config-ephone)#

.Nov  1 09:14:46.477: TFTP: Looking for English_United_States/mk-sccp.jar

.Nov  1 09:14:46.761: TFTP: Looking for United_States/g3-tones.xml

3RT-2821(config-ephone)#

.Nov  1 09:14:47.221: %IPPHONE-6-REG_ALARM: 22: Name=SEP001BD40BF4A7 Load= 7.0(3.0S) Last=Reset-Reset

.Nov  1 09:14:47.261: %IPPHONE-6-REGISTER: ephone-30:SEP001BD40BF4A7 IP:192.168.30.72 Socket:12 DeviceType:Phone has registered.

3RT-2821(config-ephone)#

Hall of Fame Super Red

Upgrading FW on 7961G-GE - CME 8.6

Hi Johnny,

Did you try the "no create cnf" and "create cnf" under telephony service after removing the

.loads ??

Cheers!

Rob

Community Member

Upgrading FW on 7961G-GE - CME 8.6

yes sir. I did that before resetting the phone. thanks.

Hall of Fame Super Red

Upgrading FW on 7961G-GE - CME 8.6

Hi Johnny,

I'm sorry but I don't have access to CME in our lab

right now to test this out for you, but here are two related

threads that might help

https://supportforums.cisco.com/message/3050746#3050746

https://supportforums.cisco.com/message/3025214#3025214

Cheers!

Rob

1554
Views
0
Helpful
7
Replies
CreatePlease to create content