Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Use Dhcp server of windows 2003 for my ip-phones

Hey everyone,

I have a cisco router 2811.

Is it possible to use the dhcp server of windows 2003 instead the dhcp of the router ?

in this case which parameters to enter in the scope options?

i added : dns, gateway, tftp, ntp, but it seems missing something...

any ideas?

My phones and computer are on the same subnet, 40 computers/servers, 20 phones

Of course the best/alternative solution could be to make another vlan just for ipphones, and set the router as a dhcp server....

Whats your advices ?

thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: Use Dhcp server of windows 2003 for my ip-phones

Configure the switch for at least one additional VLAN, per linksys manual. Make all ports where there is a PC chained of a phone as "trunks", unless the linksys supports a cisco phone+PC setting.

Configure ports where there is only a PC or phone, as access for that VLAN.

On the router, configure subinterfaces on the interface connecting to the switch. Define the VLAN as encapsulation dot11 XX with XX the VLAN ID for the subinterfaces.

Configure a dhcp pool on the router with the addresses used for CCME. configure in there option 150.

This is enough to keep telephony separated from PC's traffic, that is always a good thing.

10 REPLIES
Hall of Fame Super Gold

Re: Use Dhcp server of windows 2003 for my ip-phones

Which switch do you have ? If it supports VLANs, please separate phones and PC, let the router be DHCP for the phones.

If it doesn't, just add "option 150" with the Ip address of the CCME router, in the dhcp scope on server, until you get a switch suitable for Ip telephony.

Hope this helps, please rate post if it does!

New Member

Re: Use Dhcp server of windows 2003 for my ip-phones

Linksys srw224g4p (poe, qos, smnp, vlans,...)

It supports VLAN.

Any docs to recommand ?

thanks for the informations

Hall of Fame Super Gold

Re: Use Dhcp server of windows 2003 for my ip-phones

Configure the switch for at least one additional VLAN, per linksys manual. Make all ports where there is a PC chained of a phone as "trunks", unless the linksys supports a cisco phone+PC setting.

Configure ports where there is only a PC or phone, as access for that VLAN.

On the router, configure subinterfaces on the interface connecting to the switch. Define the VLAN as encapsulation dot11 XX with XX the VLAN ID for the subinterfaces.

Configure a dhcp pool on the router with the addresses used for CCME. configure in there option 150.

This is enough to keep telephony separated from PC's traffic, that is always a good thing.

New Member

Re: Use Dhcp server of windows 2003 for my ip-phones

thanks again

Hall of Fame Super Gold

Re: Use Dhcp server of windows 2003 for my ip-phones

No problem. I don't know the linksys switch, but it should work fine.

Thanks for the nice rating and good luck!

New Member

Re: Use Dhcp server of windows 2003 for my ip-phones

Hi again

on the switch

I configured with one more vlan :

1- native(data)

2- voice

and set the ports as "trunk" where there are PC chained of a phone and "access" where its only pc or phone.

On my cme/router i created a pool

ip dhcp pool voice

network 192.168.150.0 255.255.255.0

dns-server 192.168.140.3

domain-name ***************

default-router 192.168.150.1

option 150 ip 192.168.150.1

and my two interfaces for 2 vlans

interface FastEthernet0/0.1

description *data_traffic*

encapsulation dot1Q 1 native

ip address 192.168.140.251 255.255.255.0

no snmp trap link-status

!

interface FastEthernet0/0.2

description *voice_traffic*

encapsulation dot1Q 2

ip address 192.168.150.1 255.255.255.0

no snmp trap link-status

but my phones still use the bad vlan(1).... and the bad dhcp (windows2003) instead the one on the router. they have to use the vlan 2

how can i change that ? how can i configure phones to use the vlan 2

sorry i'm novice.

Hall of Fame Super Gold

Re: Use Dhcp server of windows 2003 for my ip-phones

Hi,

the router is configured ok. Now what happens is that the linksys switch doesn't supports CDP so it can't tell the phones which vlan to use.

You must then configure statically the vlan to use into the phone. Enter settings, go to network, press **# admin VLA id-> edit, enter 2, press validate.

That should do it.

New Member

Re: Use Dhcp server of windows 2003 for my ip-phones

thanks, i set a phone on admin vlan id 2

but its staying on "Configuring ip..."

what could be the pb ?

on "show dhcp server" i got:

DHCP server: 192.168.150.1

Leases: 0

Offers: 0 Requests: 0 Acks : 0 Naks: 0

Declines: 0 Releases: 0 Query: 0 Bad: 0

im not sure but i guess it's show the dhcp server on the router is working and available.

any ideas???

Hall of Fame Super Gold

Re: Use Dhcp server of windows 2003 for my ip-phones

Hi, I was wrong, the vlan that matters is the operational, not the admin one.

But, operational vlan cannot be configured from the phone.

I'm afraid you have to keep phones and PC in the smae vlan for now, If I find a solution for this, I will post it here. If you must use the win dhcp server, go in there and add option 150 and tftp with CME's address.

New Member

Re: Use Dhcp server of windows 2003 for my ip-phones

ok thanks, its working now.

631
Views
0
Helpful
10
Replies
CreatePlease login to create content