Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Using second codec in CUCM 7.1 Cluster

Hi all,

I'm having an issue where i'm tyring to setup different codecs for a group of phones where bandwidth is at a premium. I'm trying to convert them over to use g729, but am having some issues. Our main codec is g711u. I created a new region and device pool to assign the phones to. Inbound calling appears to work for the phone I am testing with, as does inter-extension dialing, but outbound calling does not work. I assume the issue is somewhere on our PRI gateway, since the call seems to fail somewhere when the codec is trying to be negotiated. The call signal does come through, but when the call is answered it goes to a fast busy immediately. I can post or give any configs of value. I would really appreciate any help as I have kinda hit a wall.

Thanks,

Ian Mock

9 REPLIES
Hall of Fame Super Silver

Using second codec in CUCM 7.1 Cluster

What protocol are you using to control the GW?

If H323 or SIP make sure you changed the codec approriately on the dial-peers or codec class.

HTH,

Chris

New Member

Using second codec in CUCM 7.1 Cluster

I'm not sure on the protocol. In the CUCM config it says "Digital Access PRI".

Forgive my ignorance, but I inherited this CUCM from an engineer who left the company. I haven't had much training on it's configuration, but I do know where to look to find things.

When you say changed the codec appropriately, do you mean within CUCM or on the PRI gateway?

Thanks,

Ian

Hall of Fame Super Silver

Using second codec in CUCM 7.1 Cluster

Besides changing the codec in CUCM for SIP/H323 GWs you need to define the codec on the dial peer configurtion on the gateway itself, can you post a screen shot of your Gateway page from CUCM?

Chris

New Member

Using second codec in CUCM 7.1 Cluster

I hope this helps:

Here is a cleaned config of the primary PRI gateway:

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname NET-SLCORP-TCR01

!

boot-start-marker

boot bootstrap flash c2800nm-spservicesk9-mz.124-24.t3.bin

boot system flash:c2800nm-spservicesk9-mz.124-24.t3.bin

boot-end-marker

!

card type t1 0 0

logging message-counter syslog

!

aaa new-model

!

!

aaa authorization config-commands

aaa authorization exec default local

!

!

aaa session-id common

network-clock-participate wic 0

network-clock-select 1 T1 0/0/0

!

dot11 syslog

ip source-route

!

!

ip cef

!

!

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-ni

!

!

!

voice service voip

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

!

!

!

voice class codec 2

codec preference 1 g711alaw

codec preference 2 g711ulaw

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

voice-card 0

!

!

!

!

!

archive

log config

  hidekeys

!

!

controller T1 0/0/0

cablelength long 0db

pri-group timeslots 1-24 service mgcp

description 80001/T1ZF

!

controller T1 0/0/1

shutdown

cablelength long 0db

!

!

!

!

!

interface FastEthernet0/0

ip address 10.10.10.21 255.255.255.0

duplex full

speed auto

no mop enabled

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn supp-service name calling

isdn bind-l3 ccm-manager

no cdp enable

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.10.10.1

ip http server

no ip http secure-server

!

!

!

logging 10.10.1.50

!

!

snmp-server community slpub RO

snmp-server community slpriv RW

snmp-server contact WUG

!

control-plane

!

!

!

voice-port 0/0/0:23

echo-cancel coverage 64

!

ccm-manager redundant-host 10.10.2.4

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 10.10.2.5

ccm-manager config

!

mgcp

mgcp call-agent 10.10.2.5 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

mgcp default-package fxr-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax-relay ans-disable

!

mgcp profile default

!

sccp local FastEthernet0/0

sccp ccm 10.10.2.5 identifier 2 version 7.0

sccp ccm 10.10.2.4 identifier 1 version 7.0

sccp

!

sccp ccm group 1

bind interface FastEthernet0/0

associate ccm 1 priority 1

associate ccm 2 priority 2

associate profile 1 register MTP_TCVR01

!

dspfarm profile 1 mtp

codec g711ulaw

codec pass-through

maximum sessions software 20

associate application SCCP

!

dspfarm profile 2 mtp

codec g711ulaw

codec pass-through

maximum sessions software 20

associate application SCCP

shutdown

!

!

dial-peer voice 678 voip

description SR140 Outbound

destination-pattern 9[2-9]..[2-9]......

session protocol sipv2

session target ipv4:10.10.2.5

session transport udp

codec g711ulaw

!

!

privilege exec level 3 show startup-config

privilege exec level 3 show running-config

privilege exec level 3 show

!

line con 0

exec-timeout 15 0

logging synchronous level 5

line aux 0

line vty 0 4

exec-timeout 15 0

privilege level 15

logging synchronous level 5

line vty 5 15

exec-timeout 15 0

privilege level 15

logging synchronous level 5

!

scheduler allocate 20000 1000

end

10.10.2.4 is the pub

10.10.2.5 is the sub

Hall of Fame Super Silver

Using second codec in CUCM 7.1 Cluster

OK, so you are using MGCP, all the configuration for the PRI with MGCP is defined on CallManager.

Look at the PRI port configuration, take a note of the device pool assigned

Find that device pool and see what region it is using

Look at the region configuration and find out what codec is used between this region and the phone you are calling from/to

Chris

New Member

Using second codec in CUCM 7.1 Cluster

It is assigned to the one that uses the default g711 codec. Is there not a way to have it use more than one?

Hall of Fame Super Silver

Using second codec in CUCM 7.1 Cluster

It is more than one, it is anything that is lower than the one you selected, but when the call negotiates it will always attempt to negotiate the highest possible codec defined, in your case G711.  So, with G711 defined and both devices supporting G711 it will always use G711. If you need to force it to something lower i.e. G729 you need to adjust one region.

Chris

New Member

Using second codec in CUCM 7.1 Cluster

I think I did that already. I defined a new region called "Default Low Bandwidth" and set it to use g729. I then defined a new device pool called "Default Low Bandwidth" and added the new region to it. I then added the phones to the new device pool. Stats on the phone show that it's using g729 and I can hear a slight difference in voice quality.

So how would I be able to force the gateway to use g729 if it's already set to use the device pool that has g711 defined?

Hall of Fame Super Silver

Using second codec in CUCM 7.1 Cluster

You force it by assigning proper DP to the GW, so if the intent is to force calls from site A to use g729 when going out of this GW then you need to device a region that is using G729 between it and the one phones are using, then assign DP with that region to the GW. if all local phones need to still use G711 then make sure this region is using G711 between this site's region. Basically you are creating a matrix of whio is going to use what codec.

HTH, please rate all useful posts!

Chris

805
Views
0
Helpful
9
Replies
CreatePlease login to create content