Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VG224 not sending Fax

Hello,

I would like to know if someone can assist me with getting to bottom on an issue I am having.  I have setup my VG224 using SCCP and am getting a dialtone on my fax machine, but it is not sending or receiving any faxes.  I hear the dial tone and fax tone when sending, but nothing is received on the other end.

Config File is below.

VG224#write terminal

Building configuration...

Current configuration : 2605 bytes

!

version 12.4

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

no service dhcp

!

hostname VG224

!

boot-start-marker

boot-end-marker

!

security authentication failure rate 10 log

security passwords min-length 6

logging buffered 4096 debugging

logging console critical

enable secret 5 $1$tIWN$AH0iMJk21mvCkYfO7yle./

enable password 7 0508075E70495C001D

!

no aaa new-model

!

resource policy

!

no ip source-route

no ip routing

no ip gratuitous-arps

ip tftp source-interface FastEthernet0/0

!

!

no ip bootp server

!

stcapp ccm-group 1

stcapp

!

!

trunk group  summary

!

voice-card 0

!

!

!

voice service voip

modem passthrough nse codec g711ulaw

!

!

!

!

!

!

!

!

!

!

!

!

!

application

global

  service alternate default

!

!

username admin privilege 15 password 7 141E06021F10222E262D2021

archive

log config

  logging enable

!

!

!

interface FastEthernet0/0

ip address 172.20.160.15 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

no ip route-cache

duplex full

speed auto

vlan-id dot1q 10

  exit-vlan-config

!

h323-gateway voip interface

!

interface FastEthernet0/1

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

no ip route-cache

shutdown

duplex half

speed auto

vlan-id dot1q 10

  exit-vlan-config

!

!

ip default-gateway 172.20.160.1

ip default-network 172.20.160.10

!

no ip http server

!

logging trap debugging

logging facility local2

dialer-list 1 protocol ip permit

no cdp run

!

tftp-server 172.20.160.10

!

control-plane

!

!

voice-port 2/0

timeouts initial 60

timeouts interdigit 60

timeouts call-disconnect 0

timeouts ringing infinity

caller-id enable

!

voice-port 2/1

!

voice-port 2/2

!

voice-port 2/3

!

voice-port 2/4

!

voice-port 2/5

!

voice-port 2/6

!

voice-port 2/7

!

voice-port 2/8

!

voice-port 2/9

!

voice-port 2/10

!

voice-port 2/11

!

voice-port 2/12

!

voice-port 2/13

!

voice-port 2/14

!

voice-port 2/15

!

voice-port 2/16

!

voice-port 2/17

!

voice-port 2/18

!

voice-port 2/19

!

voice-port 2/20

!

voice-port 2/21

!

voice-port 2/22

!

voice-port 2/23

!

!

!

sccp local FastEthernet0/0

sccp ccm 172.20.160.10 identifier 1 priority 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

switchback method graceful

!

!

dial-peer voice 100 pots

service stcapp

port 2/0

!

!

dial-peer search type voice data

!

line con 0

password 7

login local

line aux 0

line vty 0 4

password 7

login

!

end

VG224#

14 REPLIES
Hall of Fame Super Silver

VG224 not sending Fax

What faxing protocol are you using? Pass-through, relay, NSE T.38?

What is the PSTN GW using?

Chris

New Member

VG224 not sending Fax

At the moment Cisco Fax relay is Enabled.  Pls see attached picture.

voice service voip

modem passthrough nse codec g711ulaw

Hall of Fame Super Silver

VG224 not sending Fax

Well, the following config:

voice service voip

modem passthrough nse codec g711ulaw

enables fax passthrough, you need to select fax protocol and ensure the same protocol is used on all call legs, to enable fax relay you need the following:

voice service voip

fax protocol cisco

What is the configuration on the PSTN GW and what type of trunks are you using there?

Chris

Hall of Fame Super Silver

VG224 not sending Fax

In addition what is your PSTN GW hardware as PVDM3s do not support fax relay, see this thread:

https://supportforums.cisco.com/thread/2130357?tstart=0

HTH,

Chris

New Member

VG224 not sending Fax

Chris,

How can I find out what is my PSTN GW.  At the moment I am getting a dialtone and when I send a fax it has the fax tones, but the fax does not go through.  here is the latest config.

VG224>sh running-config

Building configuration...

Current configuration : 1963 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname VG224

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

enable secret 5 $1$0GS7$wwKWaoczGa7CB2Xv9fryC0

enable password

!

no aaa new-model

ip source-route

no ip routing

no ip cef

!

!

no ipv6 cef

!

stcapp ccm-group 1

stcapp

!

!

!

!

!

voice service voip

fax protocol cisco

modem passthrough nse codec g711ulaw

!

!

!

!

!

!

!

!

!

!

!

!

!

!

voice-card 0

!

!

application

global

  service alternate Default

!

!

archive

log config

  hidekeys

!

!

!

!

!

interface FastEthernet0/0

ip address 172.20.160.15 255.255.255.0

ip broadcast-address 172.20.160.255

no ip route-cache

duplex full

speed auto

vlan-id dot1q 10

  exit-vlan-config

!

!

interface FastEthernet0/1

no ip address

no ip route-cache

shutdown

duplex auto

speed auto

!

!

ip forward-protocol nd

no ip http server

!

!

!

control-plane

!

!

!

voice-port 2/0

timeouts initial 60

timeouts interdigit 60

timeouts call-disconnect 0

timeouts ringing infinity

caller-id enable

!

voice-port 2/1

!

voice-port 2/2

!

voice-port 2/3

!

voice-port 2/4

!

voice-port 2/5

!

voice-port 2/6

!

voice-port 2/7

!

voice-port 2/8

!

voice-port 2/9

!

voice-port 2/10

!

voice-port 2/11

!

voice-port 2/12

!

voice-port 2/13

!

voice-port 2/14

!

voice-port 2/15

!

voice-port 2/16

!

voice-port 2/17

!

voice-port 2/18

!

voice-port 2/19

!

voice-port 2/20

!

voice-port 2/21

!

voice-port 2/22

!

voice-port 2/23

!

!

!

sccp local FastEthernet0/0

sccp ccm 172.20.160.11 identifier 2 priority 2 version 7.0

sccp ccm 172.20.160.10 identifier 1 priority 1 version 7.0

sccp

!

sccp ccm group 1

bind interface FastEthernet0/0

associate ccm 1 priority 1

associate ccm 2 priority 2

switchback method graceful

!

!

dial-peer voice 100 pots

service stcapp

fax rate voice

port 2/0

!

!

!

line con 0

line aux 0

line vty 0 4

password

login

!

end

VG224#

Hall of Fame Super Silver

VG224 not sending Fax

You need to look in CUCM.  You can use Dialed Number Analyzer tool for example which you can find under serviceability page or you can look at the config, do this:

  1. see that Calling Search space is applied to the SCCP port in CUCM
  2. review the CSS configuration and see what paritions are listed
  3. go to Route Patterns and see what patterns are assigned to this partition, you should see patterns such as 9.011! for example for international dialing
  4. See what Route Lists is assigned to this pattern
  5. See what Route Group is assigned to this RL
  6. See what Gateway is assigned to this RG
  7. Login to this GW and post "sh run"

HTH, please rate all useful posts!

Chris

New Member

VG224 not sending Fax

Chris,

1. The calling serach space applied to the SCCP port is the same as applied to all the phones.

2. I do see the correct Route Patterns listed such as 9, 011, 9.911

3. Th Route List assigned is RL_SIP_To_NVT.

4. The Route Group assigned to this pattern are PSTNRouteGroup and RG_SIP_TO_NVT.

5. The Gate assigned it the one that we use for the phone systems not the VG224.

Here is the "sh run" file.

sh run

Building configuration...

Current configuration : 1963 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname VG224

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

enable secret 5 $1$0GS7$wwKWaoczGa7CB2Xv9fryC0

enable password

!

no aaa new-model

ip source-route

no ip routing

no ip cef

!

no ipv6 cef

!

stcapp ccm-group 1

stcapp

!

voice service voip

fax protocol cisco

modem passthrough nse codec g711ulaw

!

voice-card 0

!

application

global

  service alternate Default

!

archive

log config

  hidekeys

!

interface FastEthernet0/0

ip address 172.20.160.15 255.255.255.0

ip broadcast-address 172.20.160.255

no ip route-cache

duplex full

speed auto

vlan-id dot1q 10

  exit-vlan-config

!

!

interface FastEthernet0/1

no ip address

no ip route-cache

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

no ip http server

!

control-plane

!

voice-port 2/0

timeouts initial 60

timeouts interdigit 60

timeouts call-disconnect 0

timeouts ringing infinity

caller-id enable

!

voice-port 2/1

!

voice-port 2/2

!

voice-port 2/3

!

voice-port 2/4

!

voice-port 2/5

!

voice-port 2/6

!

voice-port 2/7

!

voice-port 2/8

!

voice-port 2/9

!

voice-port 2/10

!

voice-port 2/11

!

voice-port 2/12

!

voice-port 2/13

!

voice-port 2/14

!

voice-port 2/15

!

voice-port 2/16

!

voice-port 2/17

!

voice-port 2/18

!

voice-port 2/19

!

voice-port 2/20

!

voice-port 2/21

!

voice-port 2/22

!

voice-port 2/23

!

!

!

sccp local FastEthernet0/0

sccp ccm 172.20.160.11 identifier 2 priority 2 version 7.0

sccp ccm 172.20.160.10 identifier 1 priority 1 version 7.0

sccp

!

sccp ccm group 1

bind interface FastEthernet0/0

associate ccm 1 priority 1

associate ccm 2 priority 2

switchback method graceful

!

dial-peer voice 100 pots

service stcapp

fax rate voice

port 2/0

!

line con 0

line aux 0

line vty 0 4

password

login

!

end

VG224#

Hall of Fame Super Silver

VG224 not sending Fax

Right,

Please post the config from the PSTN voice gateway.  You need to ensure the fax protocol you are using is consistent on all voice gateways, including the VG224 and the PSTN gateway.

HTH,

Chris

New Member

Re: VG224 not sending Fax

Chris,

I don't have access to the voice gateway.  But from looking at the CUCM for both gateways have the following setup.

Modem Passthrough: Enable

Cisco Fax Relay: Disable

T38 Fax Relay: Disable

RTP Package Capability: Enable

MT Package Capability: Disable

Disable

Also when I connect a analog phone, I am able to call a number the person on the other end is not able to hear me.  When I try to fax it starts faxing and then I get a communication failure.  If I call the fax number I get a busy signal and the analog phone does not ring.

Also the Voice Gateway is using the MGCP protocol and the VG224 is using SCCP, it that ok or whould the VG224 be set to use MGCP.

I appreciate the help.

Hall of Fame Super Silver

VG224 not sending Fax

Well, you can clearly see you have only enabled cisco modem passthrough for faxing.  If that is what you want to use then configure the Vg224 for passthrough as well.  If you don't think you fully understand how fax over IP works as that may be challenging to inexperienced folks in this area I suggest you hire a reputable Cisco implementation partner to assist you.

HTH,  please rate all useful posts!

Chris

New Member

Re: VG224 not sending Fax

ok so I setup the VG224 as MGCP and am able to send faxes, but not receive.  when I test sending a fax it says successful, but I do not receive any output.  When I call the fax number, I hear a quick faxtone and then nothing.

Any ideas on what could be causing it not to receive?

Hall of Fame Super Silver

VG224 not sending Fax

Did you read my last post?

You need to ensure consistent fax protocol end to end, and based on your previous post this was not the case here.

Chris

New Member

Re: VG224 not sending Fax

I have modem pass-through enabled on the VG224, see config below.

VG224#sh running-config

Building configuration...

Current configuration : 2476 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname VG224

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

enable secret 5 $1$nagz$.0LyyEORmRE9LfCZizayc0

enable password

!

no aaa new-model

ip source-route

ip cef

!

no ipv6 cef

!

stcapp register capability 2/0 modem-passthrough

!

voice service pots

!

voice service voip

fax protocol pass-through g711ulaw

modem passthrough nse codec g711ulaw

!

voice-card 0

!

archive

log config

  hidekeys

!

interface FastEthernet0/0

ip address 172.20.160.15 255.255.255.0

duplex half

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

no ip http server

!

snmp-server community public RO

!

control-plane

!

voice-port 2/0

timeouts ringing infinity

timing digit 50

timing inter-digit 50

caller-id enable

!

voice-port 2/1

!

voice-port 2/2

!

voice-port 2/3

!

voice-port 2/4

!

voice-port 2/5

!

voice-port 2/6

!

voice-port 2/7

!

voice-port 2/8

!

voice-port 2/9

!

voice-port 2/10

!

voice-port 2/11

!

voice-port 2/12

!

voice-port 2/13

!

voice-port 2/14

!

voice-port 2/15

!

voice-port 2/16

!

voice-port 2/17

!

voice-port 2/18

!

voice-port 2/19

!

voice-port 2/20

!

voice-port 2/21

!

voice-port 2/22

!

voice-port 2/23

!

ccm-manager fallback-mgcp

ccm-manager redundant-host 172.20.160.10

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 172.20.160.10 

ccm-manager config

!

mgcp

mgcp call-agent 172.20.160.10 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp modem passthrough voip redundancy

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp default-package fxr-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp timer net-cont-test 3000

mgcp timer nse-response t38 250

mgcp sdp simple

mgcp fax t38 ecm

no mgcp explicit hookstate

mgcp fax t38 gateway force

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface FastEthernet0/0

mgcp bind media source-interface FastEthernet0/0

!

mgcp profile default

!

!

!

dial-peer voice 1 pots

service mgcpapp

port 2/0

!

line con 0

line aux 0

line vty 0 4

password

login

!

end

VG224#

VG224#sh dial-peer voice summary

dial-peer hunt 0

TAG = 1

PORT = 2/0

TYPE = POTS

AD MIN = up

OPER PREFIX = up

DEST-PATTERN

PRE FER =0

PASS THRU

SESS-TARGET

OUT STAT = down

New Member

Re: VG224 not sending Fax

I finally got it working.  Able to send and receive fax.  I realized I did not put in a destination pattern, once that was done, everything is working great.

1971
Views
0
Helpful
14
Replies