Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VIC2BRI disconnect criteria [SOLVED]

HI,

I'm using an old 1751V with a VIC2B-NT/TE as ISDN gateway for a IP pbx

My problem is:

When a remote caller  calls my phone number through ISDN network , the call is answered by pbx extension . If the remote caller hangs up , the whole call chain (ISDN line--bri port---voip trunk---extension) is disconnected properly.

When a pbx extension places a call to a remote party via ISDN (also to the same phone number that was the caller in previous example) and the voice connection is established, if the remote called party hangs up,  the line is not disconnected like before , instead the disconnect tone from ISDN telephon exchange is heard while the whole chain is still up (the call ends for timeout 30 seconds later).

Is this a 1751V configuration problem or a ISDN network one ??

This is my actual (poor) config on 1751V :

 

 

no voice call carrier capacity active

interface BRI0/0
 no ip address
 isdn switch-type basic-net3
 isdn incoming-voice voice
 isdn answer1 <myphonenumber>

 

voice-port 0/0

 compand-type a-law

 cptone IT

dial-peer voice 1 voip
 destination-pattern <myphonenumber>
 session protocol sipv2
 session target ipv4:<mypbxIP>
 session transport udp
 dtmf-relay rtp-nte
 codec g711alaw
 no vad
!
dial-peer voice 11 pots
 destination-pattern 3T
 no digit-strip
 port 0/0
!
dial-peer voice 10 pots
 destination-pattern 0T
 no digit-strip
 port 0/0
!
dial-peer voice 20 pots
 incoming called-number <myphonenumber>
 direct-inward-dial
!

 

 

 

Thank you for any hint !!

4 REPLIES
New Member

Hi,I think it is in the

Hi,

I think it is in the Gateway BRI configuration. I had the same issue in a H323 gateway.

Try:

 isdn send-alerting
 isdn sending-complete

under BRI interface

Green

Hi,Sounds like the the

Hi,

Sounds like the the disconnect message in the Q931 is being ignored by the router.

Add this to the global config, retest

!
voice call convert-discpi-to-prog
!

Hope this helps
Regards
Alex

Regards, Alex. Please rate useful posts.
New Member

Thanks for

Thanks for replies

Unfortunately none of these suggestions work

I'm going to debug q931 if helps....

Any idea well accepted

New Member

Finally solved !Alex you was

Finally solved !

Alex you was close to it...

the command to add is 

!

voice call disc-pi-off

!

It works perfectly now

Hope it helps

Thank you again.

 

21
Views
0
Helpful
4
Replies