Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

VLAN Issue in IP Phones

Hi,

I am facing a VLAN issue in IP Phones. We have a default vlan, data vlan and voice vlan. When I configure the phones for data and voice vlans, the IP Phones takes the correct IP address from voice dhcp but it does not get register. It gets correct default router, TFTP, DHCP and dns. But it is not getting registered. I use the following commands to configure both data and voice vlan after creating the respective vlans. But when these vlans are removed the phones gets registered. I am configuring these commands in a L2 3750 cisco switch. We also have a 4900 L3 switch.

interface gigabitethernet 1/0/8

switchport mode access

switchport access vlan 10

switchport voice vlan 100

exit

But when I went through the CME admin guide it shows a different set of commands instead of the above given commands. The conf in cme admin guide is as follows.

macro global apply cisco-global

interface slot-number/port-number

macro apply cisco-phone $AVID number $VVID number

interface slot-number/port-number

macro apply cisco-router $NVID number

end

Kindly advice.. Thanks in advance

6 REPLIES
New Member

VLAN Issue in IP Phones

I am using a CME here..

New Member

VLAN Issue in IP Phones

If your phone is getting the correct IP, gateway, tftp etc I suspect your port configuration is working fine. 

If the phone is not registering to the CME i would check that

1.  the IP address of the tftp server (the cme in this case), default gateway, subnet mask, etc is correctly defined in the dhcp server. 

2.  is the phone defined correctly on the CME?  I would double check the mac address on the ephone in cme is correct

3.  Can you ping the CME from the vlan the phone is on?

Does the phone display a specific message such as "registration rejected"?

thanks,

James

New Member

VLAN Issue in IP Phones

Hi James,

Thanks for the reply.

This is my dhcp conf in the cme.

ip dhcp pool VOICE

import all

network 10.60.100.0 255.255.255.0

option 150 ip 10.60.100.10

default-router 10.60.100.254

dns-server 10.60.1.10

1.  the IP address of the tftp server (the cme in this case), default  gateway, subnet mask, etc is correctly defined in the dhcp server. 

Ans.) YEs. Its correctly defined in the dhcp server.

2.  is the phone defined correctly on the CME?  I would double check the mac address on the ephone in cme is correct

Ans.) Yes the phone is defined correctly on the cme. Because when i remove those vlans the phone gets registered.

3.  Can you ping the CME from the vlan the phone is on?

Ans.) That I have not checked. Will check and let you know.

New Member

VLAN Issue in IP Phones

No.. I am not able to ping the ip of cme (10.60.100.10) from the switch..

New Member

VLAN Issue in IP Phones

I can ping to the gateway ip (10.60.100.254)

New Member

VLAN Issue in IP Phones

Whats the IP address of the switch?  is it on the same 10.60.100.0 subnet the phones are on?

281
Views
0
Helpful
6
Replies
CreatePlease to create content