Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Voice and data Vlan issue ,

   Hello All

               

i have  new 3750 switch i have configured voice and data vlan vlan are taking IP from DHCP server , i can ping voice vlan and one voice server from switch but i cant ping voice vlan interface and host in voice vlan from PC. below is the configuration. its a new switch

please advice

no aaa new-model
switch 1 provision ws-c3750x-24p
system mtu routing 1500
ip routing
!

!
!
crypto pki trustpoint TP-self-signed-3938055680
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3938055680
revocation-check none
rsakeypair TP-self-signed-3938055680
!
!
crypto pki certificate chain TP-self-signed-3938055680
certificate self-signed 01
  30820241 308201AA A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33393338 30353536 3830301E 170D3933 30333031 30303031
  31375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 39333830
  35353638 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100DE65 96F3B277 738DBC27 09DAB98F C49D877A 40678424 2DF31587 FE093AAC
  92CA108B 1992C293 07A268CE 0619E78F 4913414D D9BAD57C E07EE00F E61AABEE
  1786925B FE3A9FFB 97DB34B1 78304449 ABBB3129 E65FA772 DF559485 DF93319A
  5E4E6376 938F57B9 882EBC8A DF123514 B741C781 6035886F D71AD1D8 F13478F7
  FC770203 010001A3 69306730 0F060355 1D130101 FF040530 030101FF 30140603
--More--           551D1104 0D300B82 09436F72 655F7377 312E301F 0603551D 23041830 1680141F
  3E19033B 49D8E309 6FE7327A 0415D505 41C78130 1D060355 1D0E0416 04141F3E
  19033B49 D8E3096F E7327A04 15D50541 C781300D 06092A86 4886F70D 01010405
  00038181 0073E4A9 ED61C446 488F88A0 B2C40823 4E232D81 873B44E7 0D4AD10D
  2B74F8BD 5E5E962B 4EDD3A70 6902EF57 A9DAD460 832D09FE 44326969 5CF2ACA9
  28B9DF48 85AAE796 878FEAC5 8EF9044B 7F6EB08E 95A1509D 6FA6CD1A 0B4FFF1D
  803BAE58 F9ECEF67 D826F4A1 56C67262 4133C65C BBC74FED 455271B3 1C0C1560
  501CF866 89
  quit
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0
no ip address
no ip route-cache cef
no ip route-cacheinterface GigabitEthernet1/0/19
switchport access vlan 50
switchport mode access
!
interface GigabitEthernet1/0/20
switchport access vlan 50
switchport mode access
switchport voice vlan 20
spanning-tree portfast
--More--         !
interface GigabitEthernet1/0/21
switchport access vlan 50
switchport mode access
switchport voice vlan 20
spanning-tree portfast
!
interface GigabitEthernet1/0/22
switchport access vlan 50
switchport mode access
switchport voice vlan 20
spanning-tree portfast

interface Vlan1
no ip address
!
interface Vlan20
ip address 10.14.7.1 255.255.255.0
ip helper-address 10.14.6.6
!
interface Vlan50
ip address 10.14.6.4 255.255.255.0
ip helper-address 10.14.6.6
!
ip classless
ip http server
ip http secure-server
!

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Voice and data Vlan issue ,

Then you need to reconfigure port 1/0/22 to:

interface GigabitEthernet1/0/22

switchport access vlan 20

voice servers do not negotiate vlan.

Chris

10 REPLIES
Hall of Fame Super Silver

Voice and data Vlan issue ,

What is the default GW defined on the devices? Your vlan50 has default GW defined as .4, is this the default GW defined in your data DHCP scope and what the PC got? Why did you make the default GW .4?

Chris

New Member

Voice and data Vlan issue ,

thanks for your reply Chris,

On DHCP server gateway is 6.4 and DHCP server IP is 6.6 . PC are getting default gateway 6.4

Hall of Fame Super Silver

Voice and data Vlan issue ,

Can you ping 10.14.6.4 from the PC?

Can you post "sh ip route" from the switch?

Chris

New Member

Voice and data Vlan issue ,

yes i can ping the 10.14.6.6 from the PC but i can not ping 10.14.7.1 from the PC.

i can not post the "show ip route " right now as i dont have access to this switch as its on customer site --sorry

i but remember the out put of the command ..

i was show 2 directly connted route

10.14.6.4 for vlan 50 ------  = data vlan

10.14.7.1 for vlan 20  -------= voice vlan

thanks

Hall of Fame Super Silver

Voice and data Vlan issue ,

I know you can ping 10.14.6.6, but I asked about .4.

Can you provide "ipconfig /all" from the PC?

Chris

New Member

Voice and data Vlan issue ,

Yes i was able to ping 6.4 also ... infact all data network (10.14.6.X) is working fine , issue is with Voice network .

right now i cant provide  the  "ipconfig /all" from the PC , as i dont have the access to switch - sorry

Hall of Fame Super Silver

Voice and data Vlan issue ,

Sounds like your switch is not doing proper L3 routing, though the snippet you provided looks fine. With that said it is difficult to continue without access to the devices.

What is the "voice" server you added, and which switch port is it connected to as I dont see any ports configured with access vlan as voice, voice servers dont negotiate the vlan and the port needs to be defined as "switchport access 20".

New Member

Voice and data Vlan issue ,

voice server with static IP X.X.7.3 is configured with port number 1/0/22 and my PC is connected with 1/0/21 and DHCP server is with 1/0/6

interface GigabitEthernet1/0/6

description ----- connected with DHCP SERVER --------

switchport access vlan 50

switchport mode access

spanning-tree portfast interface

!

interface GigabitEthernet1/0/21

switchport access vlan 50

switchport mode access

switchport voice vlan 20

spanning-tree portfast

!

interface GigabitEthernet1/0/22

switchport access vlan 50

switchport mode access

switchport voice vlan 20

spanning-tree portfast

Hall of Fame Super Silver

Voice and data Vlan issue ,

Then you need to reconfigure port 1/0/22 to:

interface GigabitEthernet1/0/22

switchport access vlan 20

voice servers do not negotiate vlan.

Chris

New Member

Voice and data Vlan issue ,

thanks you very much Chris ,

i will be able to make these changes by tomorrow morning and then i will let you know ....

many thanks for your time

130
Views
0
Helpful
10
Replies