Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Voice call disconnection issue

Hi,

I have installed the cisco 2911 as a voice gateway (CME),.Now I am facing two issues.

1. Whenever I make a call out or receive a call from outside during the conversation the voice call gets disconnects abrubtly.This is not always some times,this issue is not in particular time and not particular with one IP phone,it is random.

2. This below error is occuring.

Mar 11 12:00:45.856 AST: voice_file_acct_initiate_dump_to_file: Both file modes have failed in earlier attempt

Mar 11 12:00:45.856 AST:  Use file-acct reset when the problem is recovered

Mar 11 12:00:45.856 AST: voice_file_acct_initiate_dump_to_file: Both file modes have failed in earlier attempt

Mar 11 12:00:45.856 AST:  Use file-acct reset when the problem is recovered

RTJVGW01#

I am using only one E1 card.Using all the 31 channels and the firmware c2900-universalk9-mz.SPA.151-4.M1.bin

Part of the configuration is given below.

card type e1 0 0

logging buffered 51200 warnings

!

aaa new-model

!

!

aaa authentication login default none

aaa accounting connection h323

action-type start-stop

group radius

!

!

aaa session-id common

memory-size iomem 25

clock timezone AST 3 0

network-clock-participate wic 0

!

no ipv6 cef

ip source-route

ip cef

!

!

!

no ip dhcp use vrf connected

!

!

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-net5

!

voice-card 0

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

no supplementary-service sip refer

supplementary-service media-renegotiate

supplementary-service ringback h225-info

fax protocol pass-through g711alaw

h323

  emptycapability

  no h225 timeout keepalive

  h245 passthru tcsnonstd-passthru

modem passthrough nse codec g711ulaw

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

codec preference 3 g729r8

!

!

voice register global

mode cme

voicemail 6000

!

voice logout-profile 1

!

!

!

voice translation-rule 1

rule 1 /^.*/ /5353/

!

voice translation-rule 9

rule 1 /^999$/ /999/

rule 2 /^9\(.*\)/ /\1/

!

!

voice translation-profile incomming-call

translate calling 1

!

!

!

application

service didapps flash:/app-cme-did-2.0.0.0.tcl

  paramspace english language en

  paramspace english index 1

!

service queue flash:app-b-acd-2.1.2.2.tcl

  param aa-hunt3 5353

  param queue-len 10

!

!

license udi pid CISCO2911/K9 sn FCZ153320Z7

license accept end user agreement

hw-module pvdm 0/0

!

!

!

username admin privilege 15 password 0 admin@123

!

redundancy

!

!

controller E1 0/0/0

framing NO-CRC4

pri-group timeslots 1-10,16

!

ip tcp synwait-time 10

!

class-map match-all L3-to-L2_VoIP-Cntrl

match ip dscp af31

class-map match-all L3-to-L2_VoIP-RTP

match ip dscp ef

class-map match-all SIP

match protocol sip

class-map match-all RTP

match protocol rtp

!

!

policy-map EthOut

class RTP

policy-map output-L3-to-L2

class L3-to-L2_VoIP-RTP

  set cos 5

class L3-to-L2_VoIP-Cntrl

  set cos 3

!

!

translation-rule 10

Rule 0 71.% 1

Rule 1 73.% 3

Rule 2 700.% 00

Rule 3 81.% 0

Rule 4 83.% 3

Rule 5 800.% 00

!

!

translation-rule 1

Rule 0 53.. 5353

!

gw-accounting file

!

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

ip forward-protocol nd

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip http path flash:GUI

!

ip route 0.0.0.0 0.0.0.0 192.168.10.254

!

tftp-server flash:P003-08-9-00.bin

tftp-server flash:P0S3-08-9-00.loads

tftp-server flash:P0S3-08-9-00.sb2

tftp-server flash:P003-08-9-00.sbn

tftp-server flash:ATA030204SCCP090202A

tftp-server flash:ATA030204SCCP090202A.zup

!

!

!

control-plane

!

!

voice-port 0/0/0:15

timeouts interdigit 5

!

!

!

mgcp profile default

!

!

dial-peer cor custom

name local

name international

!

!

dial-peer cor list International-calls

member local

member international

!

dial-peer cor list Local-call

member local

!

!

dial-peer voice 14 pots

corlist outgoing International-calls

destination-pattern 00T

port 0/0/0:15

forward-digits all

!

dial-peer voice 10 pots

destination-pattern 1.......

port 0/0/0:15

forward-digits all

!

dial-peer voice 12 pots

destination-pattern 3.......

port 0/0/0:15

forward-digits all

!

dial-peer voice 11 pots

incoming called-number 60..

direct-inward-dial

port 0/0/0:15

!

dial-peer voice 20 pots

destination-pattern 91.......

port 0/0/0:15

forward-digits 8

!

dial-peer voice 21 pots

destination-pattern 973........

translate-outgoing calling 1

port 0/0/0:15

forward-digits all

!

dial-peer voice 13 pots

destination-pattern 8.......

port 0/0/0:15

forward-digits all

!

dial-peer voice 70 pots

destination-pattern 71.......

port 0/0/0:15

forward-digits 8

!

dial-peer voice 71 pots

destination-pattern 73.......

port 0/0/0:15

forward-digits 8

!

dial-peer voice 80 pots

destination-pattern 81.......

port 0/0/0:15

forward-digits 8

!

dial-peer voice 81 pots

destination-pattern 83.......

port 0/0/0:15

forward-digits 8

!

dial-peer voice 7777 pots

destination-pattern 7.......

port 0/0/0:15

forward-digits 8

!

dial-peer voice 181 pots

destination-pattern 181

port 0/0/0:15

forward-digits 3

!

dial-peer voice 175 pots

destination-pattern 1.......

port 0/0/0:15

forward-digits all

!

dial-peer voice 196 pots

destination-pattern 196

port 0/0/0:15

forward-digits 3

!

dial-peer voice 141 pots

destination-pattern 141

port 0/0/0:15

forward-digits 3

!

dial-peer voice 121 pots

destination-pattern 121

port 0/0/0:15

forward-digits 3

!

dial-peer voice 999 pots

destination-pattern 999

port 0/0/0:15

forward-digits 3

!

dial-peer voice 66 pots

destination-pattern 6.......

port 0/0/0:15

forward-digits 8

!

dial-peer voice 5000 pots

mailbox-selection last-redirect-num

destination-pattern 600.

!

!

!

!

gatekeeper

no shutdown

!

!

telephony-service

privacy-on-hold

em logout 12:0

xml user cisco password cisco 15

max-ephones 58

max-dn 192

ip source-address 192.168.13.254 port 2000

calling-number initiator

service phone videoCapability 1

service dnis overlay

service dnis dir-lookup

system message RETAJ

url directories http://192.168.13.254/localdirectory

url services http://192.168.13.254/voiceview/common/login.do

url authentication http://192.168.13.254/voiceview/authentication/authenticate.do 

cnf-file location flash:

load 7915-12 B015-1-0-4.SBN

load 7931 SCCP31.9-1-1SR1S

load 7960-7940 P003-08-9-00

load 7942 flSIP42.9-1-1SR1S.loads

load 7962 term62.default.loads

time-zone 31

time-format 24

date-format dd-mm-yy

dialplan-pattern 1 171353.. extension-length 4 extension-pattern 53..

live-record 6000

voicemail 6000

max-conferences 8 gain -6

call-forward pattern .T

call-forward system redirecting-expanded

moh music-on-hold.au

web admin system name ccmeadmin secret 5 $1$DF/B$2OIPsjF1esd/.JIMPfQyh1

dn-webedit

time-webedit

transfer-system full-consult

transfer-pattern .T

after-hours block pattern 1 00 7-24

directory last-name-first

directory entry 1 5355 name Nader Murad

directory entry 2 5333 name Kitchen

directory entry 3 5336 name Board Room

directory entry 4 5361 name Mai Salah

directory entry 5 5341 name Muna Alalaiwi

directory entry 6 5345 name Subhas Chandra

directory entry 7 5351 name Al Saher

directory entry 8 5352 name Susan Saeed

directory entry 9 5353 name Reception

directory entry 10 5363 name Mohamed Ateeq

directory entry 11 5368 name Kalid Abdulrahim

directory entry 12 5330 name Meeting Room

directory entry 13 5350 name Main FAX

directory entry 14 5362 name Fatema Alnajjar

create cnf-files version-stamp 7960 Jan 28 2012 12:56:16

!

!

Show commands:

Voice Gateway#sh controllers e1

E1 0/0/0 is up.

  Applique type is Channelized E1 - balanced

  No alarms detected.

  alarm-trigger is not set

  Version info Firmware: 20100222, FPGA: 13, spm_count = 0

  Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line.

  Data in current interval (316 seconds elapsed):

     0 Line Code Violations, 0 Path Code Violations

     10 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     10 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

  Total Data (last 24 hours)

     0 Line Code Violations, 0 Path Code Violations,

     2676 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

     2675 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 15 Unavail Secs

Voice Gateway#

Voice Gateway#sh int serial 0/0/0:15

Serial0/0/0:15 is up, line protocol is up (spoofing)

  Hardware is DSX1

  MTU 1500 bytes, BW 64 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation HDLC, loopback not set

  Keepalive set (10 sec)

  Last input 00:00:08, output 00:00:08, output hang never

  Last clearing of "show interface" counters 2w3d

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/1/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 48 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     161745 packets input, 748458 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicasts)

     2 runts, 0 giants, 0 throttles

     3 input errors, 3 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     161754 packets output, 754303 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     488 carrier transitions

  Timeslot(s) Used:16, SCC: 0, Transmitter delay is 0 flags

Voice Gateway#

Please help me to resolve the issue.

Regards,

2 REPLIES

Voice call disconnection issue

I'd check if the router CPU usage ( high for significant time ) is causing call drops. Usually that's the common cause for such issues. Reload would certainly help.

GP.

Pls rate helpful posts !!

Blue

Voice call disconnection issue

Hi,

You have 2676 Slip Secs. Slip error are shown due to clock problem.

Have you configured network clock commands like

network-clock-select x E1 x/x

Regards

Ronak Patel

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.
1114
Views
0
Helpful
2
Replies
CreatePlease to create content