Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Voice DHCP and IP helper-address

I have a quick question regarding the correct use of ip helper-addresses. I have a typical setup: voice and data on separate vlans, with a Windows DHCP server giving out addresses for both.

Data Vlan: 1

Voice vlan: 100

DHCP Server: 172.16.99.1

Data DHCP Scope: 172.16.96.XXX

Voice DHCP Scope: 10.16.96.XXX

I have one site whose phones will not get a DHCP lease, unless I disable the data DHCP scope on the server - which suggests to me that the ip helper-address is not configured correctly. As soon as I disable the 172 scope, the phones grab an IP.

On the router, the helper address is currently set on the voice vlan subinterface:

Interface FastEthernet0/0.100

encapsulation dot1q 100

ip dhcp relay information trusted

ip address 10.16.96.1 255.255.255.0

ip helper-address 172.16.99.1

The switchports are configured as such:

Interface FastEthernet0/1

switchport mode access

switchport voice vlan 100

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

Is this the correct way to do this? If not, where exactly should the helper address be configured? Is there something else I am missing?

7 REPLIES
Hall of Fame Super Gold

Re: Voice DHCP and IP helper-address

Hi,

I would recommend you to configure dhcp for the phones only, in the router or switch itself. That will eliminate any helper issue, and guarantee phones will get an address no matter what.

New Member

Re: Voice DHCP and IP helper-address

i think you are missing the "switchport access vlan X" command

New Member

Re: Voice DHCP and IP helper-address

That's been entered, but for some reason doesn't show in the config.

Hall of Fame Super Gold

Re: Voice DHCP and IP helper-address

Because it's the default of 1.

New Member

Re: Voice DHCP and IP helper-address

Hello,

Try adding the ip helper at the voice vlan interface

interface vlan100

ip helper-address x.x.x.x

Hope this helps

Mark

New Member

Re: Voice DHCP and IP helper-address

Well I think I figured it out, getting some help from another thread with a similar problem. Our DHCP server was connected to a switch with a default config, including:

switchport voice vlan 100

I removed this and it the phones are not struggling for an IP anymore it seems.

New Member

Re: Voice DHCP and IP helper-address

(1) Do not use Vlan 1 as the data vlan

(2) where did you define Option 150 for the TFTP server to know that vlan 100 is the voice vlan ?

345
Views
0
Helpful
7
Replies