Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Voice Gateway Failover to CCM SUB

Can someone please give me some suggestions on how to make sure changes to this config to allow call procvessing failover to the CCM-Subscriber? I have a publisher, in impending failure which will necessitate new drives and complete reinstall, and i need to make sure calls will still be processed by the CCM-Sub, thanks

Exisiting gateway config:

Current configuration : 3877 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname PSTN_Gateway

!

boot-start-marker

boot system flash c1700-ipvoice-mz.123-8.T.bin

boot-end-marker

!

enable secret 5 $1$ZkZf$OJQS/IrGNGyBH.AyIF5P10

!

tdm clock T1 0/0 both export line

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

voice-card 0

!

voice-card 1

!

voice-card 2

!

no aaa new-model

ip subnet-zero

ip cef

!

!

ip tcp synwait-time 5

!

!

no ip domain lookup

no ftp-server write-enable

isdn switch-type primary-ni

!

!

!

!

!

!

!

!

!

!

!

!

ccm-manager redundant-host 192.168.10.1

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 192.168.10.1

ccm-manager config

!

!

controller T1 0/0

framing esf

linecode b8zs

pri-group timeslots 1-24 service mgcp

!

!

!

interface FastEthernet0/0

ip address 192.168.10.4 255.255.255.0

speed auto

!

interface Serial0/0:23

no ip address

no logging event link-status

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.10.213

no ip http server

!

!

control-plane

!

!

!

voice-port 0/0:23

!

voice-port 1/0

timing hookflash-out 50

!

voice-port 1/1

timing hookflash-out 50

!

voice-port 2/0

timing hookflash-out 50

!

voice-port 2/1

timing hookflash-out 50

!

mgcp

mgcp call-agent 192.168.10.2 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

!

!

dial-peer cor custom

!

!

!

dial-peer voice 10 pots

application mgcpapp

port 0/0:23

!

dial-peer voice 99910 pots

application mgcpapp

port 1/0

!

dial-peer voice 99911 pots

application mgcpapp

port 1/1

!

dial-peer voice 99920 pots

application mgcpapp

port 2/0

!

dial-peer voice 99921 pots

application mgcpapp

port 2/1

!

!

line con 0

line aux 0

line vty 0 4

password cisco

login

line vty 5

password cisco

login

line vty 6 15

no login

!

end

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Voice Gateway Failover to CCM SUB

In this case, your gateway will stay registered when you take the publisher down.

Now, if calls will still be processed will make sure that the phones that you're calling are available and that they are also registered on the sub.

But from a gateway perspective - you shouldn't have a problem.

hth,

nick

5 REPLIES

Re: Voice Gateway Failover to CCM SUB

Hi James,

You should be set.

This command:

ccm-manager redundant-host 192.168.10.1

Is what will allow you to fall back to the SUB/PUB.

You can do 'show ccm' and see what state this CUCM is in.

hth,

nick

Community Member

Re: Voice Gateway Failover to CCM SUB

Sorry, I forgot to say that 192.168.10.1 IS the PUB, 192.168.10.3 is the sub. So, if I change that to read ccm-manager redundant-host 192.168.10.2, i should be ok?

Community Member

Re: Voice Gateway Failover to CCM SUB

Here is the output of the show ccm: won't I need to add something for MGCP fallback, or no? If I read this correctly, 10.2 (the sub) is the active ccm-manager, and redundant host is the Publisher at 10.1, which I need to rebuild from scratch, SO, I am assuming then, that according to the current config, when the Pub is down being rebuilt, calls will still process?

PSTN_Gateway#show ccm

MGCP Domain Name: PSTN_Gateway

Priority Status Host

============================================================

Primary Registered 192.168.10.2

First Backup Backup Ready 192.168.10.1

Second Backup None

Current active Call Manager: 192.168.10.2

Backhaul/Redundant link port: 2428

Failover Interval: 30 seconds

Keepalive Interval: 15 seconds

Last keepalive sent: 17:34:41 UTC Mar 31 2002 (elapsed time: 00:00:11)

Last MGCP traffic time: 17:34:41 UTC Mar 31 2002 (elapsed time: 00:00:11)

Last failover time: 19:13:41 UTC Mar 11 2002 from (192.168.10.2)

Last switchback time: 19:15:11 UTC Mar 11 2002 from (192.168.10.1)

Switchback mode: Graceful

MGCP Fallback mode: Not Selected

Last MGCP Fallback start time: None

Last MGCP Fallback end time: None

MGCP Download Tones: Disabled

Backhaul Link info:

Link Protocol: TCP

Remote Port Number: 2428

Remote IP Address: 192.168.10.2

Current Link State: OPEN

Statistics:

Packets recvd: 53744

Recv failures: 0

Packets xmitted: 46710

Xmit failures: 0

PRI Ports being backhauled:

Slot 0, port 0

Configuration Auto-Download Information

Re: Voice Gateway Failover to CCM SUB

In this case, your gateway will stay registered when you take the publisher down.

Now, if calls will still be processed will make sure that the phones that you're calling are available and that they are also registered on the sub.

But from a gateway perspective - you shouldn't have a problem.

hth,

nick

Community Member

Re: Voice Gateway Failover to CCM SUB

thanks, I did a test by shutting down the pub and had no issues, looks like I can now proceed with inserting new drives in the pub and start the rebuild from scratch (install OS, patches, CCM, etc)

240
Views
0
Helpful
5
Replies
CreatePlease to create content