Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Voice PRI problem

I have a h323 gateway (a 3825 router) that is having inbound calling problems I haven't been able to figure out.

When calling to the system, users are getting busy signals.

show ip int brie shows

Serial0/0/0:0              unassigned      YES unset  down                  down   

Serial0/0/0:1              unassigned      YES unset  down                  down   

Serial0/0/0:2              unassigned      YES unset  down                  down   

Serial0/0/0:3              unassigned      YES unset  down                  down   

Serial0/0/0:4              unassigned      YES unset  down                  down   

Serial0/0/0:5              unassigned      YES unset  down                  down   

Serial0/0/0:6              unassigned      YES unset  down                  down   

Serial0/0/0:7              unassigned      YES unset  down                  down   

Serial0/0/0:8              unassigned      YES unset  down                  down   

Serial0/0/0:9              unassigned      YES unset  down                  down   

Serial0/0/0:10             unassigned      YES unset  down                  down   

Serial0/0/0:11             unassigned      YES unset  down                  down   

Serial0/0/0:12             unassigned      YES unset  down                  down   

Serial0/0/0:13             unassigned      YES unset  down                  down   

Serial0/0/0:14             unassigned      YES unset  down                  down   

Serial0/0/0:15             unassigned      YES unset  down                  down   

Serial0/0/0:16             unassigned      YES unset  down                  down   

Serial0/0/0:17             unassigned      YES unset  down                  down   

Serial0/0/0:18             unassigned      YES unset  down                  down   

Serial0/0/0:19             unassigned      YES unset  down                  down   

Serial0/0/0:20             unassigned      YES unset  down                  down   

Serial0/0/0:21             unassigned      YES unset  down                  down   

Serial0/0/0:22             unassigned      YES unset  down                  down   

Serial0/0/0:23             unassigned      YES NVRAM  up                    up 

If I do a show isdn stat I get

Global ISDN Switchtype = primary-ni

ISDN Serial0/0/0:23 interface

dsl 0, interface ISDN Switchtype = primary-ni

    Layer 1 Status:

ACTIVE

    Layer 2 Status:

TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

    Layer 3 Status:

0 Active Layer 3 Call(s)

    Active dsl 0 CCBs = 0

    The Free Channel Mask:  0x807FFFFF

    Number of L2 Discards = 0, L2 Session ID = 227

    Total Allocated ISDN CCBs = 0

When doing debug isdn q921 & 931 I get

Dec 29 04:59:20.097: ISDN Se0/0/0:23 Q921: User RX <- SABMEp sapi=0 tei=0

Dec 29 04:59:20.097: ISDN Se0/0/0:23 Q921: User TX -> UAf sapi=0 tei=0rm mo

And I see this when someone attempts an outbound call (which seems to work, although I see errors here)

Dec 29 01:46:48.055: ISDN Se0/0/0:23 Q921: User TX -> INFOp sapi=0 tei=0, ns=0 nr=0

Dec 29 01:46:48.055: ISDN Se0/0/0:23 Q931: SETUP pd = 8  callref = 0x0080

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech 

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98397

Exclusive, Channel 23

Facility i = 0x9F8B0100A11A02010202010080124F68696F20436F6D707574657220526F6F6D

Protocol Profile =  Networking Extensions

0xA11A02010202010080124F68696F20436F6D707574657220526F6F6D

Component = Invoke component

Invoke Id = 2

Operation = CallingName

Name Presentation Allowed Extended

Name = Ohio Computer Room

Calling Party Number i = 0x2181, '9373259254'

Plan:ISDN, Type:National

Called Party Number i = 0x80, '19378645356'

Plan:Unknown, Type:Unknown

Dec 29 01:46:49.055: ISDN Se0/0/0:23 Q921: L2_EstablishDataLink: sending SABME

Dec 29 01:46:49.055: ISDN Se0/0/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

Dec 29 01:46:50.055: ISDN Se0/0/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

Dec 29 01:46:51.055: ISDN Se0/0/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

Dec 29 01:46:52.055: ISDN Se0/0/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

Dec 28 20:46:53.055 est: %ISDN-6-LAYER2DOWN: Layer 2 for Interface Se0/0/0:23, TEI 0 changed to down

Dec 29 01:46:53.055: ISDN Se0/0/0:23 **ERROR**: CCPCC_CallOrigination: SETUP timed-out (2nd T303) to NETWORK.  The SETUP failed.

My provider says that they are not seeing anything from the D channel

I have powered off the router and reseated the T1 card, but it didn't help.

Any advice here would be great, because I'm not sure where or what the issue is

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Voice PRI problem

Hi,

Please

"

debug isdn q931

debug isdn q921

"

And then "ter mon" if you're connected by vty line.

After these commands try make test call and put output here please.

Also,  "sh isdn timers"

There is some config mismatch with your Provider i think.

6 REPLIES
New Member

Voice PRI problem

Hi,

Please

"

debug isdn q931

debug isdn q921

"

And then "ter mon" if you're connected by vty line.

After these commands try make test call and put output here please.

Also,  "sh isdn timers"

There is some config mismatch with your Provider i think.

New Member

Voice PRI problem

People are able to dial out through this gateway, but I only get busy signals when trying to dial in through it.

When dialing out, here is the output for debug isdn q931

Dec 29 13:58:03.969: ISDN Se0/0/0:23 Q931: SETUP pd = 8  callref = 0x0080

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech 

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98397

Exclusive, Channel 23

Facility i = 0x9F8B0100A11A02011902010080124F68696F20436F6D707574657220526F6F6D

Protocol Profile =  Networking Extensions

0xA11A02011902010080124F68696F20436F6D707574657220526F6F6D

Component = Invoke component

Invoke Id = 25

Operation = CallingName

Name Presentation Allowed Extended

Name = Ohio Computer Room

Calling Party Number i = 0x2181, 'XXXXXXXXXX'

Plan:ISDN, Type:National

Called Party Number i = 0x80, 'XXXXXXXXXX'

Plan:Unknown, Type:Unknown

Dec 29 13:58:04.968: ISDN Se0/0/0:23 Q921: L2_EstablishDataLink: sending SABME

Dec 29 13:58:04.968: ISDN Se0/0/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

Dec 29 13:58:04.968: ISDN Se0/0/0:23 **ERROR**: CCPCC_CallOrigination: SETUP timed-out (2nd T303) to NETWORK.  The SETUP failed.

show isdn timers

SPR-c3825-RTR-MDF-01#sho isdn timers

    ISDN Serial0/0/0:23 Timers (dsl 0) Switchtype = primary-ni

ISDN Layer 2 values

K     =   7 outstanding I-frames

N200  =   3 max number of retransmits

T200  =   1.000 seconds

T202  =   2.000 seconds

T203  =  30.000 seconds

ISDN Layer 3 values

T301  = 300.000 seconds

T303  =   4.000 seconds

T304  =  20.000 seconds

T305  =  30.000 seconds

T306  =  60.000 seconds

T307  = 180.000 seconds

T308  =   4.000 seconds

T309    Disabled

T310  =  30.000 seconds

T313  =   4.000 seconds

T316  =  30.000 seconds

T318  =   4.000 seconds

T319  =   4.000 seconds

T322  =   4.000 seconds

T323  = 120.000 seconds

T3OOS =   5.000 seconds

TGUARD=   8.000 seconds, Expiry = REJECT_CALL

*** dsl 1 is not configured

*** dsl 2 is not configured

*** dsl 3 is not configured

*** dsl 4 is not configured

*** dsl 5 is not configured

*** dsl 6 is not configured

*** dsl 7 is not configured

*** dsl 8 is not configured

*** dsl 9 is not configured

*** dsl 10 is not configured

*** dsl 11 is not configured

*** dsl 12 is not configured

*** dsl 13 is not configured

*** dsl 14 is not configured

*** dsl 15 is not configured

*** dsl 16 is not configured

*** dsl 17 is not configured

*** dsl 18 is not configured

*** dsl 19 is not configured

*** dsl 20 is not configured

*** dsl 21 is not configured

*** dsl 22 is not configured

*** dsl 23 is not configured

*** dsl 24 is not configured

*** dsl 25 is not configured

*** dsl 26 is not configured

*** dsl 27 is not configured

*** dsl 28 is not configured

*** dsl 29 is not configured

*** dsl 30 is not configured

*** dsl 31 is not configured

*** dsl 32 is not configured

*** dsl 33 is not configured

*** dsl 34 is not configured

*** dsl 35 is not configured

*** dsl 36 is not configured

*** dsl 37 is not configured

*** dsl 38 is not configured

        *** dsl 39 is not configured

*** dsl 40 is not configured

*** dsl 41 is not configured

*** dsl 42 is not configured

*** dsl 43 is not configured

*** dsl 44 is not configured

*** dsl 45 is not configured

*** dsl 46 is not configured

*** dsl 47 is not configured

The telco insists that the isdn switch type is primary-ni

New Member

Voice PRI problem

Ask your TELCO Provider to check it's channels (1-10) settings.

It seems They've blocked incoming calls to your side.

I've faced with that kind of mistake,but outgoing only in my case.

New Member

Re: Voice PRI problem

Are you sure that isdn switch type is realy primary-ni?

Sent from Cisco Technical Support iPad App

Cisco Employee

Voice PRI problem

Telco is not sending anything back to you, a setup ACK or a CALL_PROCEED, and the SETUP message is timing out after 4 seconds.

Other than making sure the T1 card is OK, I'd call the telco to find out why they're not replying to the setup message you're sending.

Show them that SETUP you're sending and ask them if they're sure the config and link they're looking at from their side is correct.

HTH

java

If this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

Voice PRI problem

Yup I agree with Java,

Ask telco to verify their configs

1345
Views
0
Helpful
6
Replies
CreatePlease to create content