Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

voice vlan

What is the diff between voicevlan and aux.vlan?

Is it a must to configure the switchport as trunk while using voicevlan?

if so why?

18 REPLIES

Re: voice vlan

both r essentially the same. its called aux vlan in cat os based switches (6500). its recommended to keep voice and data separate in two vlans if the pc is plugged in through the back of phone. when you configure a port with voice vlan (aux vlan), yes the port is essentially a trunk port with dot1q from switchport to the phone.

int fa0/1

switchport voice vlan 100

switchport access vlan 101

or in Catos switches

set vlan 101 6/1

set port auxiliaryvlan 6/1 100

HTh

Sankar

PS: please remember to rate posts!

New Member

Re: voice vlan

My question is pc is plugged in through the back of a phone is it a must to configure that

port as a trunk port

int fa0/1

switchport voice vlan 100

swithport mode trunk ? <--- is this command needed to configure in switch

From cisco site i got this information

Q. What is the difference between an auxiliary VLAN for the Cisco Catalyst switches and the voice VLAN for the Cisco EtherSwitch HWICs?

A. Voice VLANs require that the port be configured as a trunk port, whereas auxiliary VLANs do not. The Cisco EtherSwitch HWICs do not support auxiliary VLAN and must be configured as trunk ports for voice VLANs.

New Member

Re: voice vlan

Does anyone know of an alternative to using the Auxiliaryvlan command? Fiber interfaces do not support it. I need to trunk both the data and voice VLAN to the phone,have the phone communicate via the voice vlan, and pass traffic on the data VLAN to the workstation. Thanks in advance.

New Member

Re: voice vlan

on a 3560 switch I would config the switchport like this for phone with PC; am I missing something?

int fa0/1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan X

spanning tree portfast

auto qos voip cisco-phone

New Member

Re: voice vlan

You need to specify a native VLAN to pass your workstation traffic, unless your workstation traffic resides in the default native VLAN (1). You can also remove the trunk commands which allow you to implement port security if desired. Traditionally, port security cannot be applied to a trunked interface.

int fa0/1

switchport access vlan XXX

switchport voice vlan XXX

switchport port-security

switchport port-security mac-address sticky

New Member

Re: voice vlan

I don't remember which document I pulled this from, but we had the same question a while ago, and this seemed to be the best explanation.

A Cisco IP Phone can use an 802.1Q trunk to transport packets from two VLANs: the voice VLAN (voice packets) and the native VLAN (data packets, untagged). By default, a Cisco IP Phone transports both its voice packets and the data packets from a connected device over the native VLAN. All data is untagged.

After a switch has been configured to instruct an IP Phone to support a VVID number, the switch and phone must use an 802.1Q trunk between them. On Catalyst 3500XL switches, trunk negotiation is not supported and the 802.1Q trunk must be manually configured. The IP Phone will automatically use an 802.1Q trunk on its end of the connection.

For Catalyst 4000 and 6000 switches, a special-case 802.1Q trunk is negotiated with the IP Phone using CDP and the DTP. Once the phone is detected, the switch port becomes a vlan2-access port, supporting only the two voice and data VLANs. The port won't be shown in trunking mode from the show trunk command. In fact, it doesn't matter which trunking mode (auto, desirable, on, or off) is configured on the port?the special trunk will be negotiated through the DTP. Be sure that the trunk is not configured using the nonegotiate keyword, as DTP messages will not be sent or received and the trunk will not be automatically established.

The Spanning Tree Protocol (STP) is automatically supported over the IP Phone trunk as well. The show spantree command displays the STP state for both of the VLANs on the trunk.

New Member

Re: voice vlan

Hi all,

we have a problem with this configuration.

When we have a PC connected to an IP phone an this is connected to a Catalyst 3500XL the phone is registered and runs correctly, but the PC doesn't have connectivity.

Anyone knows wha's happening and if we've forgotten any command??

This is the config of the port with IP phone and PC:

switchport access vlan 50 (data vlan)

switchport trunk encapsulation dot1q

switchport trunk native vlan 61

switchport mode trunk

switchport voice vlan 250 (voice vlan)

spanning-tree portfast

and this is the config of the Gigabit port:

switchport trunk encapsulation dot1q

switchport trunk native vlan 61

switchport mode trunk

if we connect only the PC to this port with the followinf config, it runs correctly:

switchport access vlan 50

spanning-tree portfast

Thanks in advance.

Hall of Fame Super Gold

Re: voice vlan

Hi,

ports with a phone and PC should be configure as:

switchport mode access

switchport access vlan 50

switchport voice vlan 250

That's it.

Please rate this post if useful!

New Member

Re: voice vlan

With the config you've told me the PC runs correctly but the phone doesn't have connectivity or it doesn't get an IP address from DHCP...

Gold

Re: voice vlan

What is the phone model you have ?? And is your DHCP server in the same VLAN as the IP Phones, incase it is in a different vlan, then you will have to configure the default gateway of this vlan to send DHCP requests to ur DHCP Server using "ip helper-address "

New Member

Re: voice vlan

the model is 7912G. The DHCP server is in different VLAN but is reachable.

Hall of Fame Super Gold

Re: voice vlan

mchandak is correct, when DHCP server is in a different VLAN, you must configure "ip helper address". The configuration "trunk" is for trunks and not for phones.

New Member

Re: voice vlan

but the "ip helper addres" must be configured in the interface or in globlal mode??

Gold

Re: voice vlan

it has to be used on the interface which is working as the default gateway for this vlan/subnet

New Member

Re: voice vlan

Why do you recommend "switchport mode access" when there are two VLANs coming from the phone? Shouldn't it be a trunk port? I've been instructed to use the following commands on a such a port:

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 5

switchport access vlan 3

switchport trunk native vlan 3

spanning-tree portfast

This has always worked fine. I don't understand why you are suggesting using "access mode". How can that possibly separate the voice and data VLANs?

Gold

Re: voice vlan

Most of the Layer 3 capable switches now support 2 vlans (1 for Voice and 1 for Data). This would work only if the Phone being connected is a Cisco IP Phone. When the Switch sees a Cisco Phone connected to the port (using CDP) it allows 2 vlan.

If you are connecting a non-cisco phone, then you would need the port to be configured as trunk.

In simple, most of the current cisco switches, you can configure the port as access, configure access vlan and voice vlan and both the vlans would work, with CDP enabled on the port. And if the phone is a non Cisco Phone,then the port has to be configured as trunk.

EDIT: Check the following TAC CC document for more information about how to configure the switch to support both voice and data http://www.ciscotaccc.com/kaidara-advisor/voice/showcase?case=K14820688

New Member

Re: voice vlan

Hello All ,

We are having the same setup you are derscribing ( PC Connected to the Back of 7960 IP Phone ) and everything is working fine with the following configuration :

FasEthernet 0/2 Acces Switch 3524XL :

Switchport Trunk Encapsulation dot1q

Switchport Mode Trunk

Switchport Trunk Native Vlan 26 (PC Vlan)

Switchport Voice Vlan 23 (IP Phone Vlan)

Spanning Tree PortFast

Giga Interface 0/1 :

Switchport Trunk Encapsulation dot1q

Switchport Mode Trunk

Spanning-Tree Vlan 26 Cost 1

Spanning-Tree Vlan 23 Cost 1

For Sure both Vlan 26 and Vlan 23 should have the Intertface Vlan created and the IP-HELPER-Address Command under both Interface Vlans Pointing to the DHCP Server IP Address.

Regards

M.Tag

Hall of Fame Super Gold

Re: voice vlan

Hello,

the configuration reccomended by mradak is the correct one. Switchport mode access and voice vlan configured. There is no need to configure the port as trunk, neither should be done, because this can give unwanted access to all VLAN to any device connected to the port.

462
Views
8
Helpful
18
Replies
CreatePlease to create content