Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VOIP communication problem

there is a HuaWei U2990 Communicated with Cisco 2821 throuth sip,here are sip message collected from 2821 router,

the problem is some Invite from U2990,Cisco 2821 did not give the correct response,anybody can give some suggestion?

please see the explain below which mark with color

Oct 22 12:03:54.498 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:888001@192.168.1.1:5060;user=phone SIP/2.0
Via: SIP/2.0/UDP 192.168.2.27:5062;branch=z9hG4bK6y4e44vz0g05gez2x3nx01x9v;X-DispMsg=216
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>
CSeq: 1 INVITE
Contact: <sip:9001@192.168.2.27:5060>
Allow: INVITE,ACK,OPTIONS,BYE,CANCEL,REGISTER,INFO,PRACK,SUBSCRIBE,NOTIFY,UPDATE,MESSAGE,REFER
User-Agent: Huawei eSpace U2990 V200R0
Supported: 100rel
Max-Forwards: 70
Content-Length: 474
Content-Type: application/sdp

v=0
o=HuaWeiUAP6600 478150935 478150935 IN IP4 192.168.3.17
s=Sip Call
c=IN IP4 192.168.2.38
t=0 0
m=audio 1104 RTP/AVP 8 0 125 122 18 9 124 4
a=rtpmap:8 PCMA/8000
a=rtpmap:0 PCMU/8000
a=rtpmap:125 iLBC/8000
a=rtpmap:122 AMR-WB/16000
a=rtpmap:18 G729/8000
a=rtpmap:9 G722/8000
a=rtpmap:124 G7221/16000
a=rtpmap:4 G723/8000
a=ptime:20
a=fmtp:125 mode=20
a=fmtp:122 mode-set=0,1,2,3,4,5,6,7,8
a=fmtp:124 bitrate=24000
a=fmtp:18 annexb=no
a=fmtp:4 annexa=no

Oct 22 12:03:54.506 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 192.168.2.27:5062;branch=z9hG4bK6y4e44vz0g05gez2x3nx01x9v;X-DispMsg=216
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
Date: Tue, 22 Oct 2013 04:03:54 GMT
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 1 INVITE
Allow-Events: telephone-event
Content-Length: 0

Oct 22 12:03:56.090 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 183 Session Progress
Via: SIP/2.0/UDP 192.168.2.27:5062;branch=z9hG4bK6y4e44vz0g05gez2x3nx01x9v;X-DispMsg=216
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
Date: Tue, 22 Oct 2013 04:03:54 GMT
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 1 INVITE
Require: 100rel
RSeq: 2791
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, COMET, REFER, SUBSCRIBE, NOTIFY, INFO, UPDATE, REGISTER
Allow-Events: telephone-event
Contact: <sip:888001@192.168.1.1:5060>
Content-Disposition: session;handling=required
Content-Type: application/sdp
Content-Length: 191

v=0
o=CiscoSystemsSIP-GW-UserAgent 8094 2363 IN IP4 192.168.1.1
s=SIP Call
c=IN IP4 192.168.1.1
t=0 0
m=audio 16892 RTP/AVP 8
c=IN IP4 192.168.1.1
a=rtpmap:8 PCMA/8000
a=ptime:20

Oct 22 12:03:56.110 HKT: %ISDN-6-CONNECT: Interface Serial1/0:0 is now connected to 63119001 N/A
Oct 22 12:03:56.114 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.2.27:5062;branch=z9hG4bK6y4e44vz0g05gez2x3nx01x9v;X-DispMsg=216
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
Date: Tue, 22 Oct 2013 04:03:54 GMT
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 1 INVITE
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, COMET, REFER, SUBSCRIBE, NOTIFY, INFO, UPDATE, REGISTER
Allow-Events: telephone-event
Contact: <sip:888001@192.168.1.1:5060>
Content-Type: application/sdp
Content-Length: 191

v=0
o=CiscoSystemsSIP-GW-UserAgent 8094 2363 IN IP4 192.168.1.1
s=SIP Call
c=IN IP4 192.168.1.1
t=0 0
m=audio 16892 RTP/AVP 8
c=IN IP4 192.168.1.1
a=rtpmap:8 PCMA/8000
a=ptime:20

Oct 22 12:03:56.138 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
PRACK sip:888001@192.168.1.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.2.27:5064;branch=z9hG4bKn145z24rnnyyx63n3ggyz0014;X-DispMsg=218
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
CSeq: 2 PRACK
Max-Forwards: 70
RAck: 2791 1 INVITE
Content-Length: 0

Oct 22 12:03:56.142 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.2.27:5064;branch=z9hG4bKn145z24rnnyyx63n3ggyz0014;X-DispMsg=218
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
Date: Tue, 22 Oct 2013 04:03:56 GMT
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 2 PRACK
Content-Length: 0

Oct 22 12:03:56.210 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:888001@192.168.1.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.2.27:5060;branch=z9hG4bK49ynyr0x3xz0yzgggyx0x1v5x
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
CSeq: 1 ACK
Max-Forwards: 70
Content-Length: 0

Oct 22 12:03:56.210 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
OPTIONS sip:888001@192.168.1.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.2.27:5065;branch=z9hG4bKrzryygzn693ne6035zr54zrn3;X-DispMsg=219
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
CSeq: 3 OPTIONS
Max-Forwards: 70
Content-Length: 0

Oct 22 12:03:56.214 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.2.27:5065;branch=z9hG4bKrzryygzn693ne6035zr54zrn3;X-DispMsg=219
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
Date: Tue, 22 Oct 2013 04:03:56 GMT
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 3 OPTIONS
Supported: 100rel,replaces
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, COMET, REFER, SUBSCRIBE, NOTIFY, INFO, UPDATE, REGISTER
Accept: application/sdp
Allow-Events: telephone-event
Content-Length: 191
Content-Type: application/sdp

v=0
o=CiscoSystemsSIP-GW-UserAgent 8094 2363 IN IP4 192.168.1.1
s=SIP Call
c=IN IP4 192.168.1.1
t=0 0
m=audio 16892 RTP/AVP 8
c=IN IP4 192.168.1.1
a=rtpmap:8 PCMA/8000
a=ptime:20

Oct 22 12:03:56.378 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:888001@192.168.1.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.2.27:5062;branch=z9hG4bKn04yyr0gr3xy3g4xegyrn61rx;X-DispMsg=216
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
CSeq: 4 INVITE
Contact: <sip:192.168.2.27:5060>
Max-Forwards: 70
Content-Length: 187
Content-Type: application/sdp

v=0
o=HuaWeiUAP6600 478150935 478150936 IN IP4 192.168.3.17
s=Sip Call
c=IN IP4 192.168.8.200
t=0 0
m=audio 10500 RTP/AVP 8 0
a=rtpmap:8 PCMA/8000
a=rtpmap:0 PCMU/8000
a=ptime:20

Oct 22 12:03:56.382 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 192.168.2.27:5062;branch=z9hG4bKn04yyr0gr3xy3g4xegyrn61rx;X-DispMsg=216
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
Date: Tue, 22 Oct 2013 04:03:56 GMT
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 4 INVITE
Allow-Events: telephone-event
Content-Length: 0

Oct 22 12:03:56.386 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.2.27:5062;branch=z9hG4bKn04yyr0gr3xy3g4xegyrn61rx;X-DispMsg=216
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
Date: Tue, 22 Oct 2013 04:03:56 GMT
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 4 INVITE
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, COMET, REFER, SUBSCRIBE, NOTIFY, INFO, UPDATE, REGISTER
Allow-Events: telephone-event
Contact: <sip:888001@192.168.1.1:5060>
Content-Type: application/sdp
Content-Length: 191

v=0
o=CiscoSystemsSIP-GW-UserAgent 8094 2364 IN IP4 192.168.1.1
s=SIP Call
c=IN IP4 192.168.1.1
t=0 0
m=audio 16892 RTP/AVP 8
c=IN IP4 192.168.1.1
a=rtpmap:8 PCMA/8000
a=ptime:20

Oct 22 12:03:56.450 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
OPTIONS sip:888001@192.168.1.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.2.27:5063;branch=z9hG4bK5nv61e15eevze5rvnvrgn4g9z;X-DispMsg=217
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
CSeq: 5 OPTIONS
Max-Forwards: 70
Content-Length: 0

Oct 22 12:03:56.450 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 491 Request Pending
Via: SIP/2.0/UDP 192.168.2.27:5063;branch=z9hG4bK5nv61e15eevze5rvnvrgn4g9z;X-DispMsg=217
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
CSeq: 5 OPTIONS
Content-Length: 0

Oct 22 12:03:56.454 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:888001@192.168.1.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.2.27:5060;branch=z9hG4bK32r00vn61ry2re103303454ev
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
CSeq: 4 ACK
Max-Forwards: 70
Content-Length: 0

before has send this 200 ok message,here send again,upon has recive the ack message,why send again.

Oct 22 12:03:56.882 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.2.27:5062;branch=z9hG4bKn04yyr0gr3xy3g4xegyrn61rx;X-DispMsg=216
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
Date: Tue, 22 Oct 2013 04:03:56 GMT
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 4 INVITE
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, COMET, REFER, SUBSCRIBE, NOTIFY, INFO, UPDATE, REGISTER
Allow-Events: telephone-event
Contact: <sip:888001@192.168.1.1:5060>
Content-Type: application/sdp
Content-Length: 191

v=0
o=CiscoSystemsSIP-GW-UserAgent 8094 2364 IN IP4 192.168.1.1
s=SIP Call
c=IN IP4 192.168.1.1
t=0 0
m=audio 16892 RTP/AVP 8
c=IN IP4 192.168.1.1
a=rtpmap:8 PCMA/8000
a=ptime:20

Oct 22 12:03:56.894 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:888001@192.168.1.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.2.27:5064;branch=z9hG4bKnny21zy4xn931x03n1r19z9zr;X-DispMsg=218
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
CSeq: 6 INVITE
Contact: <sip:192.168.2.27:5060>
Max-Forwards: 70
Content-Length: 161
Content-Type: application/sdp

v=0
o=HuaWeiUAP6600 478150935 478150937 IN IP4 192.168.3.17
s=Sip Call
c=IN IP4 192.168.2.34
t=0 0
m=audio 1160 RTP/AVP 8
a=rtpmap:8 PCMA/8000
a=ptime:20

here X-DispMsg should be 218,response to upon invite,but 2821 router still made it 216 which made the u2990 drop it.

Oct 22 12:03:56.898 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 192.168.2.27:5062;branch=z9hG4bKn04yyr0gr3xy3g4xegyrn61rx;X-DispMsg=216
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
Date: Tue, 22 Oct 2013 04:03:56 GMT
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 6 INVITE
Allow-Events: telephone-event
Content-Length: 0

Oct 22 12:03:56.942 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:888001@192.168.1.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.2.27:5060;branch=z9hG4bK32r00vn61ry2re103303454ev
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
CSeq: 4 ACK
Max-Forwards: 70
Content-Length: 0

Oct 22 12:03:57.398 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:888001@192.168.1.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.2.27:5064;branch=z9hG4bKnny21zy4xn931x03n1r19z9zr;X-DispMsg=218
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
CSeq: 6 INVITE
Contact: <sip:192.168.2.27:5060>
Max-Forwards: 70
Content-Length: 161
Content-Type: application/sdp

v=0
o=HuaWeiUAP6600 478150935 478150937 IN IP4 192.168.3.17
s=Sip Call
c=IN IP4 192.168.2.34
t=0 0
m=audio 1160 RTP/AVP 8
a=rtpmap:8 PCMA/8000
a=ptime:20

here the same situation made again,X-DispMsg should be 218,but it made 216

Oct 22 12:03:57.402 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 192.168.2.27:5062;branch=z9hG4bKn04yyr0gr3xy3g4xegyrn61rx;X-DispMsg=216
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
Date: Tue, 22 Oct 2013 04:03:57 GMT
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 6 INVITE
Allow-Events: telephone-event
Content-Length: 0

Oct 22 12:03:57.882 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.2.27:5062;branch=z9hG4bKn04yyr0gr3xy3g4xegyrn61rx;X-DispMsg=216
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
Date: Tue, 22 Oct 2013 04:03:57 GMT
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 6 INVITE
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, COMET, REFER, SUBSCRIBE, NOTIFY, INFO, UPDATE, REGISTER
Allow-Events: telephone-event
Contact: <sip:888001@192.168.1.1:5060>
Content-Type: application/sdp
Content-Length: 191

v=0
o=CiscoSystemsSIP-GW-UserAgent 8094 2364 IN IP4 192.168.1.1
s=SIP Call
c=IN IP4 192.168.1.1
t=0 0
m=audio 16892 RTP/AVP 8
c=IN IP4 192.168.1.1
a=rtpmap:8 PCMA/8000
a=ptime:20

Oct 22 12:03:57.938 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
OPTIONS sip:888001@192.168.1.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.2.27:5063;branch=z9hG4bK005y656rv4n3y9xx92g3r4yn4;X-DispMsg=217
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
CSeq: 7 OPTIONS
Max-Forwards: 70
Content-Length: 0

Oct 22 12:03:57.942 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 491 Request Pending
Via: SIP/2.0/UDP 192.168.2.27:5063;branch=z9hG4bK005y656rv4n3y9xx92g3r4yn4;X-DispMsg=217
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
CSeq: 7 OPTIONS
Content-Length: 0

Oct 22 12:03:57.942 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:888001@192.168.1.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.2.27:5060;branch=z9hG4bK2gx5ny4r0g2z1302y9v6r6yrx
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
CSeq: 6 ACK
Max-Forwards: 70
Content-Length: 0

Oct 22 12:03:58.238 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:888001@192.168.1.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.2.27:5065;branch=z9hG4bK6n10e0exe6gn9e6xy9gvvz9x0;X-DispMsg=219
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
CSeq: 8 INVITE
Contact: <sip:192.168.2.27:5060>
Max-Forwards: 70
Content-Length: 161
Content-Type: application/sdp

v=0
o=HuaWeiUAP6600 478150935 478150938 IN IP4 192.168.3.17
s=Sip Call
c=IN IP4 192.168.2.37
t=0 0
m=audio 1090 RTP/AVP 8
a=rtpmap:8 PCMA/8000
a=ptime:20

here the same situation made again,X-DispMsg should be 219,but it made 216

Oct 22 12:03:58.242 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 192.168.2.27:5062;branch=z9hG4bKn04yyr0gr3xy3g4xegyrn61rx;X-DispMsg=216
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
Date: Tue, 22 Oct 2013 04:03:58 GMT
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 8 INVITE
Allow-Events: telephone-event
Content-Length: 0

U2990 did not recive the correct response,it send the Internal Server Error message,after that send the bye message

Oct 22 12:03:58.406 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:888001@192.168.1.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.2.27:5064;branch=z9hG4bKnny21zy4xn931x03n1r19z9zr;X-DispMsg=218
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
CSeq: 6 INVITE
Contact: <sip:192.168.2.27:5060>
Max-Forwards: 70
Content-Length: 161
Content-Type: application/sdp

v=0
o=HuaWeiUAP6600 478150935 478150937 IN IP4 192.168.3.17
s=Sip Call
c=IN IP4 192.168.2.34
t=0 0
m=audio 1160 RTP/AVP 8
a=rtpmap:8 PCMA/8000
a=ptime:20

Oct 22 12:03:58.410 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 500 Internal Server Error
Via: SIP/2.0/UDP 192.168.2.27:5064;branch=z9hG4bKnny21zy4xn931x03n1r19z9zr;X-DispMsg=218
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
CSeq: 6 INVITE
Content-Length: 0

Oct 22 12:03:58.454 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:888001@192.168.1.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.2.27:5064;branch=z9hG4bKnny21zy4xn931x03n1r19z9zr;X-DispMsg=218
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
CSeq: 6 ACK
Max-Forwards: 70
Content-Length: 0

Oct 22 12:03:58.466 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
OPTIONS sip:888001@192.168.1.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.2.27:5062;branch=z9hG4bK3r5xx32rn31n09zz2g30y9nyn;X-DispMsg=216
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
CSeq: 9 OPTIONS
Max-Forwards: 70
Content-Length: 0

Oct 22 12:03:58.466 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 491 Request Pending
Via: SIP/2.0/UDP 192.168.2.27:5062;branch=z9hG4bK3r5xx32rn31n09zz2g30y9nyn;X-DispMsg=216
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
CSeq: 9 OPTIONS
Content-Length: 0

Oct 22 12:03:58.470 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
BYE sip:888001@192.168.1.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.2.27:5064;branch=z9hG4bK39934zxez4r3zxve9xe9nz26x;X-DispMsg=218
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
CSeq: 10 BYE
Max-Forwards: 70
Content-Length: 0

Oct 22 12:03:58.474 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.2.27:5064;branch=z9hG4bK39934zxez4r3zxve9xe9nz26x;X-DispMsg=218
From: <sip:9001@192.168.2.27;user=phone>;tag=2xggg0ge-CC-57
To: <sip:888001@192.168.1.1;user=phone>;tag=A5E20104-1631
Date: Tue, 22 Oct 2013 04:03:58 GMT
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0
CSeq: 10 BYE

10 REPLIES
New Member

VOIP communication problem

anybody can give some suggestion?

thanks a lot!

New Member

VOIP communication problem

Oct 22 12:03:56.450 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 491 Request Pending
Via: SIP/2.0/UDP 192.168.2.27:5063;branch=z9hG4bK5nv61e15eevze5rvnvrgn4g9z;X-DispMsg=217
From: <9001>;tag=2xggg0ge-CC-57
To: <888001>;tag=A5E20104-1631
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
CSeq: 5 OPTIONS
Content-Length: 0

Oct 22 12:03:56.454 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:888001@192.168.1.1:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.2.27:5060;branch=z9hG4bK32r00vn61ry2re103303454ev
Call-ID: 2e36e2z3zry5y62xg2z146z21445101e@UAP6600
From: <9001>;tag=2xggg0ge-CC-57
To: <888001>;tag=A5E20104-1631
CSeq: 4 ACK
Max-Forwards: 70
Content-Length: 0

before has send this 200 ok message,here send again,upon has recive the ack message,why send again.

Oct 22 12:03:56.882 HKT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:

I dont know alot, but it seems Ack message is getting delayed. May be some timer change can give more waiting time.

Also, your question is not clear at all.

Please provide the architecture and , what issue you are facing in real, what are these messages related to.

Then only someone can help.

“If you have knowledge, let others light their candles in it.”
New Member

Re: VOIP communication problem

thank for reply

the architecture like this:

    the client register into the u2990,then  initiate a sip call to cisco 2821,cisco 2821 connect to a pbx throuth T1,then pbx connect to PSTN throuth T1,

finally the client set up a call to PSTN

VOIP communication problem

Hi Gelare.

Can you please post the 2821 config and mention the IOS version?

Thanks

Regards

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
New Member

Re: VOIP communication problem

hi,the router ios is 12.4(13r)T, the router config:

Building configuration...

Current configuration : 4912 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname 2800a
!
boot-start-marker
boot-end-marker
!
card type t1 1 1
logging buffered 4096 debugging
!
aaa new-model
!
!
aaa authentication login securid group tacacs+ local
aaa authorization exec securid group tacacs+ local
aaa authorization commands 15 securid group tacacs+ local
aaa accounting exec default start-stop group tacacs+
aaa accounting commands 15 default start-stop group tacacs+
aaa accounting network default start-stop group tacacs+
aaa accounting system default start-stop group tacacs+
!
aaa session-id common
!
resource policy
!
clock timezone HKT 8
network-clock-participate slot 1
network-clock-select 1 T1 1/1
ip subnet-zero
no ip source-route
no ip gratuitous-arps
!
!
ip cef
!
!
no ip bootp server
no ip domain lookup
isdn switch-type primary-4ess
!
voice-card 0
dspfarm
!
voice-card 1
dspfarm
!
!
voice rtp send-recv
!
!
!
!
!
!
!
!
!
!
!
!
!
controller T1 1/0
framing esf
clock source line primary
linecode b8zs
cablelength short 133
pri-group timeslots 1-24
description *** to Avaya IPO Unit A P:9 ***
!
controller T1 1/1
framing esf
linecode b8zs
pri-group timeslots 1-24
description *** to Dialogic T1 ***
!
!
!
interface Tunnel1
no ip address
!
interface GigabitEthernet0/0
description New VOIP
ip address 192.168.0.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
ip route-cache flow
duplex auto
speed auto
!
interface Serial0/0/0
description *** IPLC ***
bandwidth 2048
ip address 192.168.1.1 255.255.255.248
ip nat outside
!
interface Serial1/0:23
no ip address
isdn switch-type primary-4ess
isdn protocol-emulate network
isdn incoming-voice voice
no cdp enable
!
interface Serial1/1:23
no ip address
isdn switch-type primary-4ess
isdn incoming-voice voice
no cdp enable
!
ip classless
ip route 192.168.2.0 255.255.255.0 192.168.1.2
!
!
no ip http server
no ip http secure-server
ip nat inside source static 192.168.0.2 192.168.1.3

ip tacacs source-interface Serial0/0/0
!
access-list 92 permit 192.168.0.2
access-list 92 permit 192.168.1.2
!
!
tacacs-server host 192.168.0.34
tacacs-server timeout 20
tacacs-server directed-request
tacacs-server key 7 ********
!
control-plane
!
!
!
voice-port 1/0:23
!
voice-port 1/1:23
!
!
!
!
!
dial-peer voice 3 pots
destination-pattern 88.T
port 1/0:23
!
dial-peer voice 2 voip
destination-pattern 98888
session target ipv4:192.168.2.27
req-qos guaranteed-delay
!
dial-peer voice 1 pots
destination-pattern 9....
direct-inward-dial
port 1/1:23
!
!
!
line con 0
exec-timeout 5 0
logging synchronous
line aux 0
line vty 0 4
session-timeout 10
access-class 92 in
exec-timeout 5 0
logging synchronous
login authentication securid
transport input telnet ssh
!
no scheduler allocate
ntp clock-period 17180239
ntp server 192.168.0.245
!
end

2800a#

best regards!

New Member

VOIP communication problem

anybody can give more suggestion,the problem is still an obsession for me

VOIP communication problem

Hi Gelare.

Can you also post a debug isdn q931 during al call?

Thanks

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
New Member

Re: VOIP communication problem

hi,the call sometime is right,sometimes can't hear anything then release.the ios image file name is c2800nm-spservicesk9-mz.124-3g.bin.

the debug info like this:

Nov  1 16:03:45.230 HKT: ISDN Se1/0:23 Q931: Applying typeplan for sw-type 0x2 i
s 0x2 0x1, Calling num 9001
Nov  1 16:03:45.234 HKT: ISDN Se1/0:23 Q931: Applying typeplan for sw-type 0x2 i
s 0x2 0x1, Called num 888001
Nov  1 16:03:45.234 HKT: ISDN Se1/0:23 Q931: TX -> SETUP pd = 8  callref = 0x128
6
        Bearer Capability i = 0x8090A2
                Standard = CCITT
                Transfer Capability = Speech
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA98383
                Exclusive, Channel 3
        Calling Party Number i = 0x2180, '9001'
                Plan:ISDN, Type:National
        Called Party Number i = 0xA1, '888001'
                Plan:ISDN, Type:National
Nov  1 16:03:45.254 HKT: ISDN Se1/0:23 Q931: RX <- CALL_PROC pd = 8  callref = 0
x9286
        Channel ID i = 0xA98383
                Exclusive, Channel 3
Nov  1 16:03:47.406 HKT: ISDN Se1/0:23 Q931: RX <- ALERTING pd = 8  callref = 0x
9286
        Progress Ind i = 0x8288 - In-band info or appropriate now available
        Progress Ind i = 0x8288 - In-band info or appropriate now available
Nov  1 16:03:47.410 HKT: ISDN Se1/0:23 Q931: RX <- CONNECT pd = 8  callref = 0x9
286
Nov  1 16:03:47.414 HKT: %ISDN-6-CONNECT: Interface Serial1/0:2 is now connected
to 888001 N/A
Nov  1 16:03:47.414 HKT: ISDN Se1/0:23 Q931: TX -> CONNECT_ACK pd = 8  callref =
0x1286
Nov  1 16:04:10.118 HKT: %ISDN-6-DISCONNECT: Interface Serial1/0:2  disconnected
from 888001 , call lasted 22 seconds
Nov  1 16:04:10.118 HKT: ISDN Se1/0:23 Q931: TX -> DISCONNECT pd = 8  callref =
0x1286
        Cause i = 0x8290 - Normal call clearing
Nov  1 16:04:10.126 HKT: ISDN Se1/0:23 Q931: RX <- RELEASE pd = 8  callref = 0x9
286
Nov  1 16:04:10.126 HKT: ISDN Se1/0:23 Q931: TX -> RELEASE_COMP pd = 8  callref
= 0x1286
Nov  1 16:05:10.920 HKT: ISDN Se1/0:23 Q931: Applying typeplan for sw-type 0x2 i
s 0x2 0x1, Calling num 9001
Nov  1 16:05:10.924 HKT: ISDN Se1/0:23 Q931: Applying typeplan for sw-type 0x2 i
s 0x2 0x1, Called num 888001
Nov  1 16:05:10.924 HKT: ISDN Se1/0:23 Q931: TX -> SETUP pd = 8  callref = 0x128
7
        Bearer Capability i = 0x8090A2
                Standard = CCITT
                Transfer Capability = Speech
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA98383
                Exclusive, Channel 3
        Calling Party Number i = 0x2180, '9001'
                Plan:ISDN, Type:National
        Called Party Number i = 0xA1, '888001'
                Plan:ISDN, Type:National
Nov  1 16:05:10.944 HKT: ISDN Se1/0:23 Q931: RX <- CALL_PROC pd = 8  callref = 0
x9287
        Channel ID i = 0xA98383
                Exclusive, Channel 3
Nov  1 16:05:12.604 HKT: ISDN Se1/0:23 Q931: RX <- ALERTING pd = 8  callref = 0x
9287
        Progress Ind i = 0x8288 - In-band info or appropriate now available
        Progress Ind i = 0x8288 - In-band info or appropriate now available
Nov  1 16:05:12.608 HKT: ISDN Se1/0:23 Q931: RX <- CONNECT pd = 8  callref = 0x9
287
Nov  1 16:05:12.612 HKT: %ISDN-6-CONNECT: Interface Serial1/0:2 is now connected
to 888001 N/A
Nov  1 16:05:12.612 HKT: ISDN Se1/0:23 Q931: TX -> CONNECT_ACK pd = 8  callref =
0x1287
Nov  1 16:05:56.245 HKT: ISDN Se1/0:23 Q931: Applying typeplan for sw-type 0x2 i
s 0x2 0x1, Calling num 9001
Nov  1 16:05:56.249 HKT: ISDN Se1/0:23 Q931: Applying typeplan for sw-type 0x2 i
s 0x2 0x1, Called num 888001
Nov  1 16:05:56.249 HKT: ISDN Se1/0:23 Q931: TX -> SETUP pd = 8  callref = 0x128
8
        Bearer Capability i = 0x8090A2
                Standard = CCITT
                Transfer Capability = Speech
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA98384
                Exclusive, Channel 4
        Calling Party Number i = 0x2180, '9001'
                Plan:ISDN, Type:National
        Called Party Number i = 0xA1, '888001'
                Plan:ISDN, Type:National
Nov  1 16:05:56.269 HKT: ISDN Se1/0:23 Q931: RX <- CALL_PROC pd = 8  callref = 0
x9288
        Channel ID i = 0xA98384
                Exclusive, Channel 4
Nov  1 16:05:57.753 HKT: %ISDN-6-DISCONNECT: Interface Serial1/0:2  disconnected
from 888001 , call lasted 45 seconds
Nov  1 16:05:57.757 HKT: ISDN Se1/0:23 Q931: TX -> DISCONNECT pd = 8  callref =
0x1287
        Cause i = 0x8290 - Normal call clearing
Nov  1 16:05:57.757 HKT: ISDN Se1/0:23 Q931: RX <- ALERTING pd = 8  callref = 0x
9288
        Progress Ind i = 0x8288 - In-band info or appropriate now available
        Progress Ind i = 0x8288 - In-band info or appropriate now available
Nov  1 16:05:57.761 HKT: ISDN Se1/0:23 Q931: RX <- RELEASE pd = 8  callref = 0x9
287
Nov  1 16:05:57.765 HKT: ISDN Se1/0:23 Q931: TX -> RELEASE_COMP pd = 8  callref
= 0x1287
Nov  1 16:05:57.777 HKT: ISDN Se1/0:23 Q931: RX <- CONNECT pd = 8  callref = 0x9
288
Nov  1 16:05:57.777 HKT: %ISDN-6-CONNECT: Interface Serial1/0:3 is now connected
to 888001 N/A
Nov  1 16:05:57.777 HKT: ISDN Se1/0:23 Q931: TX -> CONNECT_ACK pd = 8  callref =
0x1288
Nov  1 16:06:19.149 HKT: %ISDN-6-DISCONNECT: Interface Serial1/0:3  disconnected
from 888001 , call lasted 21 seconds
Nov  1 16:06:19.153 HKT: ISDN Se1/0:23 Q931: TX -> DISCONNECT pd = 8  callref =
0x1288
        Cause i = 0x8290 - Normal call clearing
Nov  1 16:06:19.157 HKT: ISDN Se1/0:23 Q931: RX <- RELEASE pd = 8  callref = 0x9
288
Nov  1 16:06:19.161 HKT: ISDN Se1/0:23 Q931: TX -> RELEASE_COMP pd = 8  callref
= 0x1288

when the call can't hear anything,the debug output seems lack this infomations(My ideas):

Nov  1 16:05:56.245 HKT: ISDN Se1/0:23 Q931: Applying typeplan for sw-type 0x2 i
s 0x2 0x1, Calling num 9001
Nov  1 16:05:56.249 HKT: ISDN Se1/0:23 Q931: Applying typeplan for sw-type 0x2 i
s 0x2 0x1, Called num 888001
Nov  1 16:05:56.249 HKT: ISDN Se1/0:23 Q931: TX -> SETUP pd = 8  callref = 0x128
8
        Bearer Capability i = 0x8090A2
                Standard = CCITT
                Transfer Capability = Speech
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA98384
                Exclusive, Channel 4
        Calling Party Number i = 0x2180, '9001'
                Plan:ISDN, Type:National
        Called Party Number i = 0xA1, '888001'
                Plan:ISDN, Type:National
Nov  1 16:05:56.269 HKT: ISDN Se1/0:23 Q931: RX <- CALL_PROC pd = 8  callref = 0
x9288
        Channel ID i = 0xA98384
                Exclusive, Channel 4

Best Regards !      

      

New Member

VOIP communication problem

up up up

VOIP communication problem

Hi Gelare.

Sorry for my late.

If I well understood your issue is that sometimes you can't here the other end of a call right?

If so please send the output of a show voip rtp connection during both a working and a non working call.

Also send a show voice call status.

Thanks

Regards

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
982
Views
0
Helpful
10
Replies