Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VOIP over ADSL

Hi, I am baffeled I am trying to run VOIP traffic from an elastix server over a Cisco 870 router. Call quality is fine untill more then a few people start surfing the internet. I have tried to enable some QOS on the router but with it  I can make one call and the rest just drops. I spend nearly a day surfing Cisco website and managed to come up with this config:

ip access-list extended DATA_TRAFFIC

permit tcp any any eq www

permit tcp any any eq 443

ip access-list extended VOIP_TRAFFIC

permit udp any any eq

permit tcp any any eq 5060

permit tcp any any eq 5061

permit tcp any any eq 10000

permit udp any any range 16348 32768

permit tcp any any eq 5060

permit ip 10.6.49.66 255.255.255.255 any

class-map  VOIP_TRAFFIC

match access-name VOIP_TRAFFIC

class-map  DATA_TRAFFIC

match DATA_TRAFFIC

policy-map VOICE_QOS

class VOIP_TRAFFIC

priority percent 30

policy-map DATA_TRAFFIC

class DATA_TRAFFIC

bandwith percent 50

policy-map class-default

fairqeue

I have tried applying it to the Dialer and ATM interface. The show policy map command shows hits on every class, but call quality still drops and line availaibility drops to one line availaible. Does any know what I am doing wrong or of a better config?

Everyone's tags (3)
2 REPLIES
Blue

VOIP over ADSL

Hi

Have you tried config example present in QOS SRND, This is one of the best document for QOS for VOIP

http://www.cisco.com/univercd/cc/td/doc/solution/esm/qossrnd.pdf

Regards

Ronak Patel

Please rate helpful posts by clicking starts below the answer.

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.

VOIP over ADSL

ip access-list extended VOIP_TRAFFIC

permit udp any any eq

permit tcp any any eq 5060

permit tcp any any eq 5061

permit tcp any any eq 10000

permit udp any any range 16348 32768

permit tcp any any eq 5060

permit ip 10.6.49.66 255.255.255.255 any

class-map  VOIP_TRAFFIC

match access-name VOIP_TRAFFIC

match protocol rtp              ----- this will match all real time voice traffic

and what is total bandwidth ?

and you will need one child policy and one parent

like this

class-map match-all voice

match protocol rtp

policy-map pm1                   ----- this is child policy

class voice

  priority 500                        ------ priority for all voice calls in kbps

  set precedence 5

class class-default

policy-map Shape                ----- this is parent policy, and should be applyed to interface

class class-default            

  shape average 2000000          -----put here total bandwidth of your adsl line in bits per sec

  service-policy pm1

Please rate helpful post

447
Views
0
Helpful
2
Replies