Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Si
Community Member

VoIP switch/Siemens Config

Hi,

Im just after some information of whether ive configure my VoIP test network correctly. Im using 48Port POE 2960 and Siemens Openstage 15 phones.

Switch Config

lldp run

interface FastEthernet0/1

switchport access vlan 125

switchport mode access

switchport nonegotiate

switchport voice vlan 169

switchport port-security maximum 2

switchport port-security

switchport port-security violation restrict

srr-queue bandwidth share 10 10 60 20

priority-queue out

mls qos trust dscp

auto qos voip trust

spanning-tree portfast

service-policy input qospolicy

The DHCP Subnet, im using Opt 43 with the manufactures code + the VlanID all in hex.
This seems to work, but is this the best way of making VoIP work? Without the Hex sting, the VoIP phone will not work saying telephony down. It would be tidier to have all the config on the switch to get this to work. I have a test bed of around 100 phones at the moment.

Many thanks

S

1 ACCEPTED SOLUTION

Accepted Solutions
Super Bronze

VoIP switch/Siemens Config

Hi

Config looks fine - you have a qos input policy AND mls qos trust dscp, one will override the other so pick one and stick with it.

Otherwise assuming your phones are correctly landing in vlan 169 you're fine.

It is common practice to run DHCP on a server so there's no problem with the config you have in that regard - you can typically run it on the switch but centralised admin by the folks who are already looking after DHCP for the data VLANs is the way forward.

Regards

Aaron

Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
3 REPLIES
Super Bronze

VoIP switch/Siemens Config

Hi

Config looks fine - you have a qos input policy AND mls qos trust dscp, one will override the other so pick one and stick with it.

Otherwise assuming your phones are correctly landing in vlan 169 you're fine.

It is common practice to run DHCP on a server so there's no problem with the config you have in that regard - you can typically run it on the switch but centralised admin by the folks who are already looking after DHCP for the data VLANs is the way forward.

Regards

Aaron

Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
Si
Community Member

VoIP switch/Siemens Config

Thanks Harrison. Is it possible to use Lldp to tell the phone what tag to use instead of Opt43? Or is it best practise to use the current method.

I'm having a few issues of the pcs not dhcping via the phone a restart usually resolves this but not ideal on a larger scale

Si

Si
Community Member

VoIP switch/Siemens Config

Should add dhcp is via centralised servers

1761
Views
0
Helpful
3
Replies
CreatePlease to create content