Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Webdialer service & Click to Call

Hi Everyone,

I'm hoping someone can help me out with a Web Dialer/Click to Call issue I'm trying to work out.  I'm using my PC as a test box for testing click to call. Here's what I'm running.

- CUCM Cluster version: 6.1.5.12900-7

- Click to Call version 8  (downloaded clicktocall-Install-ffr.8-0-2540.zip)

- PC = Win XP SP2 with Office 2003 SP3

We don't have CUCM hooked into our AD so all user accounts for the phones are local to CUCM. I followed this doc for setting up the stuff in CUCM.

http://www.cisco.com/en/US/docs/voice_ip_comm/cupa/click_to_call/8.0/english/install/guide/Installation_Guide_for_Click_to_Call_Release_80.pdf

1) Under Cisco Unified Serviceability > Tools > Service Activation, I see Cisco  WebDialer Web Service is checked and activated on both servers in the cluster.

2) When I go to test to see if the Webdialer service is running, I go to https://<CUCM server IP address>/webdialer/webdialer, I get the following message.

"Cisco WebDialer - Service Unavailable. Service not enabled for you, please contact your administrator"

3) Under Cisco Unified Serviceability > Tools > Control Center - Feature Services, I  see Cisco CTIManager is started and activated. Same for the Cisco WebDialer Web Service.

4) Under Cisco Unified Serviceability > Tools > Control Center - Network Services, I see the Cisco CallManager Cisco IP Phone Services is running.

5) Under Cisco Unified CM Administration > User Management > End User, I've verified that the right user (me in this case) is associated with the correct controlled devices.

6) Under Cisco Unified CM Administration > Call Routing > Dial Rules > Application Dial Rules, I've configured dial rules as per the document.

7) Under Cisco Unified CM Administration > System > Service Parameters, I go to select Cisco WebDialer Web Service from the Service menu and I notice it's "Inactive".

     - Since I saw it as activated in step 1, I'm confused as to why it's inactive here.

8) Under Cisco Unified CM Administration > System > Service Parameters & the Web Service, it's set to "True"  for the Apply Application Dial Rules on Dial parameter &  "True" for the Apply Application Dial Rules on SOAP Dial parameter.

9) I restarted the Web Service as documented.

10) I installed the client and when I go to configure, I enter my username/password for my CUCM user account and enter the CUCM server IP address in the field for the webdialer service. When I click the save button, I get this message

"WebDialer service cannot be found. Please ensure you entered the correct address"

So from point #2, #7, and #10, it looks like the webdialer service isn't running but I'm scratching my head as to why.

Has anyone else seen this and have a way to resolve? I've read through everything I can get my hands on that relates to the webdialer service but I'm still stuck.

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Webdialer service & Click to Call

Ensure that the web dialer service parameter under system --> service parameters --> --> Cisco WebDialer references proper CTI server IP addresses. Default is 127.0.0.1, so if you are accessing the page from CUCM server that does not have CTI Manager running it will fail.

HTH,

Chris

9 REPLIES
Hall of Fame Super Silver

Webdialer service & Click to Call

Ensure that the web dialer service parameter under system --> service parameters --> --> Cisco WebDialer references proper CTI server IP addresses. Default is 127.0.0.1, so if you are accessing the page from CUCM server that does not have CTI Manager running it will fail.

HTH,

Chris

New Member

Webdialer service & Click to Call

Hi Chris,

Thanks for the help. In system --> service parameters --> --> Cisco WebDialer, I have the following set.

List of WebDialers = 127.0.0.1

Primary Cisco CTIManager = 127.0.0.1

Backup Cisco CTIManager =

User Session Expiry = 0

Duration of End Call Dialog = 15

Apply Application Dial Rules on Dial= True

Apply Application Dial Rules on SOAP Dial Request= True

CTI Manager Connection Security Flag= Not Secure

Based on your reply, should I change the 127.0.0.1 to the IP address of the CUCM server, such as 10.100.1.1 ?

Thanks for the help

Hall of Fame Super Silver

Webdialer service & Click to Call

Yes. You can also specify a backup CTI Mgr.

HTH, please rate all helpful posts!

Chris

New Member

Webdialer service & Click to Call

Hi Chris,

Perhaps a dumb question but will changing the IP address from 127.0.0.1 to my internal addresses going to break anything?

Thanks!

Hall of Fame Super Silver

Webdialer service & Click to Call

No, as long as the referenced IP address is of a CUCM server with running CTI Manager service.

Chris

New Member

Webdialer service & Click to Call

Hi Chris

I set the proper IP addresses for my CUCM servers and I restarted the Webdialer service and it appears to work OK now from the webpage but the click to call app isn't working still.

If I go to https://:8443/webdialer/Webdialer , it works. I log in with my CUCM user ID/password and then enter a phone number and it works ok.

If I open the click to call app on my laptop, I enter my CUCM user ID/password and enter various things for the WebDialer service and I can't seem to find the correct permutation of things to get it working.

For the "WebDialer service field", I've tried the entire https URL above to juse the IP address to IP address plus the 8443 port number and nothing works.

Thanks

Hall of Fame Super Silver

Re: Webdialer service & Click to Call

which click to call app are you using?

Sent from Cisco Technical Support iPhone App

New Member

Re: Webdialer service & Click to Call

Hi Chris

8.0.2540.0  which appears to be the latest.

Thanks

New Member

Re: Webdialer service & Click to Call

Hi Chris,

I ended up downgrading the client from 8.0.2540.0 to 7.0.12.0 and it looks like it's working fine now.

Thanks for your help.

2187
Views
0
Helpful
9
Replies