Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

What exactly does 'switchport voice vlan xxx' do?

I read somewhere that if I'm using Avaya IP phones (which we are) connected to a Cisco switch (we're using 3750s and 6500s in the access layer) that I don't need the 'switchport voice vlan xxx' statement in the interface config.

Is this true and if so what is the purpose of the statement?

Here is a config example we use in our Cisco 3750 switches:

interface FastEthernet1/0/5

description Phone in PC-phone config

switchport access vlan 10

switchport mode access

switchport voice vlan 910

speed 100

duplex full

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust dscp

auto qos voip trust

spanning-tree portfast

1 ACCEPTED SOLUTION

Accepted Solutions

Re: What exactly does 'switchport voice vlan xxx' do?

The "switchport priority extend cos X" command will use CDP to tell a Cisco phone to remark packets attached to its switchport to X. It will also remark untagged packets to this value.

The only way I'm aware of to accomplish this in your scenario is to remark packets based on vlan. Depending on your switch, you can also do this at that level.

Brandon

7 REPLIES
New Member

Re: What exactly does 'switchport voice vlan xxx' do?

If you want to do VoIP, and you want your voice vlan to be separate from your data vlan, then you do have to use the command you described. That way, you can have that cisco switch port pass both vlans for voice and data (phone and pc), instead of just the one with the switchport access vlan xxx.

Re: What exactly does 'switchport voice vlan xxx' do?

The command "switchport voice vlan" tells a phone which vlan to use for voice traffic. With Cisco phones, this information is passed to the phone using CDP. With an Avaya phone, the phone first boots up using the data vlan and obtains an IP address from the DHCP server as well as information regarding the voice vlan. It then reboots using the voice vlan to obtain DHCP information.

Hope this helps. If so, please rate the post.

Brandon

New Member

Re: What exactly does 'switchport voice vlan xxx' do?

One more question if you please. Your explanation does help.

With a Cisco phone attached to a Cisco switch port I understand that there is a switch command that will instruct the Cisco phone to mark all packets coming into its extra ethernet port (the one a PC is plugged into) to '0'.

Since we have Avaya phones I don't think this will work. Do you know of a way for us to tell the Avaya phones to do the same thing?

I asked on an Avaya forum and the only answer I got was to create an ACL on the router that feeds the switch to re-mark all packets on the data vlan to '0'.

Is that the only way with Avaya phones?

Re: What exactly does 'switchport voice vlan xxx' do?

The "switchport priority extend cos X" command will use CDP to tell a Cisco phone to remark packets attached to its switchport to X. It will also remark untagged packets to this value.

The only way I'm aware of to accomplish this in your scenario is to remark packets based on vlan. Depending on your switch, you can also do this at that level.

Brandon

New Member

Re: What exactly does 'switchport voice vlan xxx' do?

i have this dhcp pool configured for both data and voic on 3560 switch:

ip dhcp pool DATA

. network 10.10.10.0 255.255.255.0

. default-router 10.10.10.1

ip dhcp pool Voice

. network 10.10.50.0 255.255.255.0

. default-router 10.10.50.1

Interface gig0/1

. Description connect to AVAYA IP Telephone

. Switchport mode trunk

. Switchport trunk encapsulation dot1q

. Switchport trunk native VLAN 1

. Switchport voice VLAN 5

. Spanning-tree portfast

. No cdp enable

. Auto qos voip trust

when i give the AVAYA IP Phone with static IP address it's working fine. but using dhcp is able to get any IP address ?????

please advice

Thanks

Hasan

New Member

Re: What exactly does 'switchport voice vlan xxx' do?

Have you configured VLAN interfaces?

eg.

int vlan 1

ip address 10.10.10.1 255.255.255.0

int vlan 5

ip address 10.10.50.1 255.255.255.0

New Member

Re: What exactly does 'switchport voice vlan xxx' do?

yes,

it's working now

i configured the option 176 on both data and voice DHCP scops :)

Thanks,

1031
Views
0
Helpful
7
Replies