Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

when I dial extensions its not sending a digit

Hi all,

when I dial USA numbers and its asking me for Press 1 for sales, press 2 for management, press 3 for...., or if you know the extension number please dial it now, these things not working when I dial 1,2 or 3 it doesn't make any changes, even if I dial the extensions nothing will change. 

by the way I'm in Middle east its working for everywhere except USA numbers. I Have E1 PRI line, my provider telling me its DTMF problem but DTMF is not working on POTS dial peer working only on VOIP dialpeers.

Please help.

4 REPLIES
Silver

Hi Alan,It certainly sounds

Hi Alan,

It certainly sounds like a DTMF issue, can you supply the config from your gateway?  Also, what version of UCM are you using?

Thanks

Tony

Please rate helpful posts

Please rate helpful posts
Thanks,
Tony
New Member

tonyperla thanks for your

tonyperla thanks for your reply,

here is my Config, some of the commands omitted

 

 


!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec localtime
no service password-encryption
!
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
!
aaa new-model
!
!
!
!
!
!
!
!
aaa session-id common
network-clock-participate wic 0
!
no ipv6 cef
ip source-route
ip cef
!
!
!
ip dhcp pool voice
   network 172.16.100.0 255.255.255.0
   option 150 ip 172.16.100.1
   default-router 172.16.100.1
!
!

multilink bundle-name authenticated
!
vpdn enable
!
!
!
!
!
isdn switch-type primary-net5
!
!

!
!
voice-card 0
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service h450.2
 no supplementary-service h450.3
 no supplementary-service h450.7
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g711alaw
 codec preference 3 g729r8
!
!
voice register global
 mode cme
 max-dn 150
 max-pool 150
!
voice hunt-group 1 parallel
 list 8760,8761,8762,8763,8764,8765,8766,8767,8768,8769
 timeout 60
 pilot 8888
!
!
voice hunt-group 2 parallel
 list 8720,8721,8722,8723,8724,8725
 pilot 9999
!
!
!
voice translation-rule 1
 rule 1 /876./ /0662112525/
 rule 3 /874[56]/ /0662112501/
 rule 4 /8741/ /0662112502/
 rule 5 /8701/ /0662112503/
 rule 6 /8743/ /0662112504/
 rule 7 /87[0-3]./ /0662112505/
 rule 8 /8752/ /0662112506/
 rule 9 /8755/ /0662112507/
 rule 10 /8778/ /0662112508/
 rule 15 /87../ /0662112509/
!
voice translation-rule 2
 rule 1 /660662112525/ /8888/
 rule 2 /660662112501/ /8745/
 rule 3 /660662112502/ /8741/
 rule 4 /660662112503/ /8701/
 rule 5 /660662112504/ /8743/
 rule 6 /660662112505/ /9999/
 rule 7 /660662112506/ /8752/
 rule 9 /660662112507/ /8755/
 rule 10 /660662112508/ /8778/
 rule 15 /6606621125../ /8888/
!
!
voice translation-profile in
 translate called 2
!
voice translation-profile out
 translate calling 1
!
!
license udi pid CISCO2951/K9 sn FCZ151520MX
license boot module c2951 technology-package uck9
hw-module pvdm 0/0
!
!
!
dial-control-mib retain-timer 35791
dial-control-mib max-size 1200
!
redundancy
!
!
controller E1 0/0/0
 framing NO-CRC4
 pri-group timeslots 1-31
!
no ip ftp passive
ip ssh version 2
gw-accounting syslog
!
!
!
!
interface Loopback0
 no ip address
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 ip flow ingress
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.1
 encapsulation dot1Q 1 native
 ip address 172.16.1.2 255.255.255.0
 ip flow ingress
!
interface GigabitEthernet0/1.20
 encapsulation dot1Q 20
 ip address 172.16.100.1 255.255.255.0
 ip flow ingress
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip http server
ip http authentication local
ip http secure-server
ip http path flash0:
!
ip route 0.0.0.0 0.0.0.0 95.170.215.65
ip route 192.168.0.0 255.255.0.0 172.16.1.1
!
logging 172.16.201.254
!
nls resp-timeout 1
cpd cr-id 1
!
snmp-server community XXXX RO
snmp-server enable traps snmp authentication linkdown linkup
snmp-server host 172.X.X.X version 2c 
!
control-plane
!
!
voice-port 0/0/0:15
 translation-profile incoming in
 translation-profile outgoing out
!
!
!
!
dial-peer cor custom
 name 911call
 name localcall
 name ldcall
 name internationalcall
!
!
dial-peer cor list EMERGENCY
 member 911call
!
dial-peer cor list LOCAL
 member localcall
!
dial-peer cor list LONGDIS
 member 911call
 member localcall
 member ldcall
!
dial-peer cor list INTERNATIONAL
 member 911call
 member localcall
 member ldcall
 member internationalcall
!
!
dial-peer voice 30 pots
 translation-profile incoming in
 translation-profile outgoing out
 incoming called-number .
 direct-inward-dial
 port 0/0/0:15
!
dial-peer voice 1 pots
 translation-profile incoming in
 translation-profile outgoing out
 destination-pattern 907.........
 port 0/0/0:15
 forward-digits 11
!
dial-peer voice 2 pots
 translation-profile incoming in
 translation-profile outgoing out
 destination-pattern 90[1-6][0-6].......
 port 0/0/0:15
 forward-digits 10
!
dial-peer voice 3 pots
 corlist outgoing INTERNATIONAL
 translation-profile incoming in
 translation-profile outgoing out
 destination-pattern 9T
 port 0/0/0:15
!
dial-peer voice 4 pots
 destination-pattern 90661..
 port 0/0/0:15
 forward-digits 6
!
dial-peer voice 5 pots
 description Emergency Calls
 destination-pattern 91[0128].
 port 0/0/0:15
 forward-digits 3
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 sdspfarm conference mute-on 111 mute-off 222
 sdspfarm units 1
 sdspfarm tag 1 CME_CONF
 conference hardware
 no auto-reg-ephone
 authentication credential 
 max-ephones 150
 max-dn 200
 ip source-address 172.16.100.1 port 2000
 system message honesty is the best policy
 url services http://172.16.100.1/voiceview/common/login.do
 url authentication http://172.16.100.1/CCMCIP/authenticate.asp
 cnf-file location flash:
 cnf-file perphone
 load 7906 term06.default
 load 7911 sip11.9-2-1S
 load 7937 apps37sccp.1-1-1-1
 load 7960-7940 P00308000500
 load 7942 SCCP42.8-3-3SR2S
 time-zone 31
 max-conferences 8 gain -6
 moh moh1.au
 multicast moh 239.1.1.255 port 16384
 web admin system name XXXXX password XXXXX
 web admin customer name XXXX password XXXXX
 dn-webedit
 time-webedit
 transfer-system full-consult
 secondary-dialtone 9
 
 directory entry 78 8778 name Ary Sulayman
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-template  1
 conference drop-mode local
 conference add-mode creator
 conference admin
 softkeys hold  Resume Newcall Select Join
 softkeys idle  Newcall Cfwdall Redial Dnd
 softkeys seized  Endcall Redial Meetme Pickup
 softkeys connected  Hold Endcall Trnsfer Confrn ConfList RmLstC Join Park Select
 type 7911
 features blocked  CFwdAll
!
!
ephone-template  8
 type 7942
!
!
ephone-dn  1  dual-line
 number 8701
 label William 
 name William 
 corlist incoming INTERNATIONAL
!
!
ephone-dn  2  dual-line
 number 8702
 label  Sami
 name  Sami
 corlist incoming LONGDIS
!

!
!
ephone  1
 mac-address 0008.308A.09F1
 ephone-template 1
 type 7942
 button  1:1
!
!
!
ephone  2
 mac-address B8BE.BF22.9FDE
 type 7911
 button  1:2
!
!
!

 

Silver

Hi Alan,For some reason I am

Hi Alan,

For some reason I am not seeing the voip dial peers within your config.  Are you using Communications Manager?  If for whatever reason they are there, can you tell me if your voip dial peer's have the following command attached to them? -

 

"dtmf-relay h245-alphanumeric"

 

If not, can you add this under each of your voip dial peer's and test?

 

Thanks

Tony

Please rate helpful posts

Please rate helpful posts
Thanks,
Tony
New Member

Dear Tony,I'm not using dial

Dear Tony,

I'm not using dial-peer VOIP, because my connection is through one E1 line, what I know is Dial-peer voip is for IP based voice, I have only one CME with E1 line and 100 DID number from the provider. and this command " dtmf-relay" can't be used under POTS dial peer.

96
Views
0
Helpful
4
Replies
CreatePlease to create content