Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Which PVDM2 ?

I have Cisco 2811  as a Voice Gateway for 6 IP phones. It has right now PVDM2-16 installed

Is it enough for 6 phones to have SRST or I need upgrade it to PVDM2-32?  (which is suggested by our consultant)

I would appreciate your help

7 REPLIES
Cisco Employee

Re: Which PVDM2 ?

IP phones don't require DSP resources to work. DSP resources are only needed for analog/TDM endpoints or media resources (transcoding/MTP/conference). Is the gateway using any FXO, FXS, T1/E1 cards? That will determine how many DSPs/PVDMs are needed.

-Felipe

New Member

Re: Which PVDM2 ?

Here is how my consultant explained me an issue (SRST is not working properly):

"If you check the DSP farm, it not allowing to setup conf. And transcoder. Still in shutdown mode. Due to low dsp.
If add another 16 then you will get 12,to 16 channels in codecs"


He suggest to upgrade PVDM2-16 to PVDM-32 to fix this issue.

Is he correct?

Here is a show sh version:

Cisco 2811 (revision 53.51) with 249856K/12288K bytes of memory.
Processor board ID FTX1335A1H8
2 FastEthernet interfaces
11 Serial interfaces
1 Channelized T1/PRI port
4 Voice FXO interfaces

Here is a config:

version 12.4
!
hostname VG1
!
boot-start-marker
boot-end-marker
!
card type t1 0 0
!
network-clock-participate wic 0
network-clock-select 1 T1 0/0/0
dot11 syslog
!
ip cef
!
ip host callmanager 10.81.194.20
multilink bundle-name authenticated
!
isdn switch-type primary-dms100
!
voice-card 0
dspfarm
dsp services dspfarm
!
voice translation-rule 1
rule 1 /.*\(3395\)$/ /56052/
!
voice translation-profile IN
translate called 1
!
controller T1 0/0/0
framing esf
linecode b8zs
cablelength short 110
pri-group timeslots 1-10,24 service mgcp
description First T1
!
class-map match-any VoiceSig
match access-group 120
class-map match-all VoiceBearer
match ip dscp ef
match access-group 130
!
policy-map VAN_QoS
class VoiceBearer
  set ip dscp ef
class VoiceSig
  set ip dscp cs3
class class-default
  fair-queue
!
translation-rule 3395
!
interface FastEthernet0/0
ip address 10.80.188.51 255.255.255.0
duplex auto
speed auto
service-policy output VAN_QoS
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-dms100
isdn incoming-voice voice
isdn bind-l3 ccm-manager
isdn bchan-number-order ascending
no cdp enable
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 120 permit ip any host 10.81.194.20
access-list 120 permit ip any host 10.81.194.21
access-list 130 permit ip any host 10.81.194.25
access-list 130 permit ip any host 10.81.194.30
access-list 130 permit ip any 10.80.190.0 0.0.0.255
!
voice-port 0/0/0:23
!
voice-port 0/1/0
timing hookflash-out 50
!
voice-port 0/1/1
timing hookflash-out 50
!
voice-port 0/1/2
timing hookflash-out 50
!
voice-port 0/1/3
timing hookflash-out 50
!
ccm-manager fallback-mgcp
ccm-manager redundant-host 10.81.194.20
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 10.81.194.21 
ccm-manager config
!
mgcp
mgcp call-agent 10.81.194.21 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode nte-ca
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface FastEthernet0/0
mgcp bind media source-interface FastEthernet0/0
!
mgcp profile default
!
sccp local FastEthernet0/0
sccp ccm 10.81.194.21 identifier 1
sccp ccm 10.81.194.20 identifier 2
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate ccm 2 priority 2
associate profile 2 register VAN-XCODE-GW3
associate profile 1 register VAN-CONF-GW3
!
dspfarm profile 2 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
maximum sessions 1
associate application SCCP
!
dspfarm profile 1 conference
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
codec g729br8
associate application SCCP
shutdown
!
dial-peer voice 1011 pots
preference 1
destination-pattern 9T
port 0/0/0:23
!
dial-peer voice 101 pots
incoming called-number .
direct-inward-dial
port 0/0/0:23
!
dial-peer voice 106 pots
service mgcpapp
port 0/1/0
!
dial-peer voice 105 pots
service mgcpapp
port 0/0/0:23
!
dial-peer voice 107 pots
port 0/1/1
!
dial-peer voice 108 pots
port 0/1/2
!
dial-peer voice 109 pots
port 0/1/3
!
dial-peer voice 1012 pots
port 0/1/3
!
call-manager-fallback
max-conferences 8 gain -6
transfer-system full-consult
ip source-address 10.80.188.51 port 2000
max-ephones 42
max-dn 84
system message primary SRST Mode
system message secondary SRST Mode
transfer-pattern .T

Cisco Employee

Re: Which PVDM2 ?

When the gateway and phones are in SRST mode, media resources will not be accessible as they will unregister from the CUCM node as well. They will not register to the SRST gateway as the phones do. To confirm, the actual problem is that inbound/outbound calls are failing while in SRST mode, correct?

Are the IP phones registering to the SRST router? Can they call between themselves?

If the problem description is not accurate, can you provide us wit the correct one?

-Felipe

New Member

Re: Which PVDM2 ?

Maybe I should explain an initial problem:

When IP phones loose connection to Call Manager they should be able to fallback to SRST and be able to dial and to receive calls. It is not happening right now. Our consultant explained to me that this is because there are not enough DSP resources and suggested to upgrade PVDM2-16 to PVDM2-32

Cisco Employee

Re: Which PVDM2 ?

What is not happening?

IP phones not able to register with SRST router when CCM/WAN goes down ?

OR

Phones register fine but are unable to call external ?

Phone falling back to SRST router has nothing to do with DSP/PVDM.

You shd be able to make internal calls between the ip phones without

any DSP in the box. Assuming  in normal/SRST mode, all calls work,

I don't see how it could be DSP related?

Since this is MGCP GW, you'd need to add following so that default app takes

over when mgcapp goes down:

application

  global
    service alternate Default

New Member

Re: Which PVDM2 ?

Phones fall to SRST. It shows on the phone screen. IP phones can call themselves and they can call outside to PSTN but they cannot receive call from PSTN while in SRST mode

Cisco Employee

Re: Which PVDM2 ?

It may be a DID issue. What are the extensions on the phones? Do they match what the telco is sending? Can you collect the following debugs for an inbound call while in SRST.

debug isdn q931

debug voip ccapi inout

Also, collect the following command output for when the phones are registered to the SRST gateway.

show dial-peer voice summary

-Felipe

512
Views
0
Helpful
7
Replies
CreatePlease to create content