Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

New Member

Why use service policy input command (macro)

Hello

I'm a little confused.

interface FastEthernet0/1

description IP Phones

switchport access vlan 20

switchport mode access

switchport voice vlan 30

switchport port-security maximum 2

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

srr-queue bandwidth share 10 10 60 20

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

spanning-tree bpduguard enable

service-policy input AutoQoS-Police-CiscoPhone

Why do you use the service-policy input command when you already use mls qos trust commands? Is it layer 2 or layer 3 qos? If both, also why?

Wouter

2 REPLIES
Silver

Re: Why use service policy input command (macro)

To attach a policy map to an interface, use the service-policy input command.

service-policy input policy-map name

The "mls qos trust" and "service-policy input" cannot be used together. The policy-map and the trust commands are mutually exclusive.

New Member

Re: Why use service policy input command (macro)

This service-policy is added automatically when you type "auto qos voip cisco-phone" on interface. If "mls qos trust" and "service-policy input" cannot be used together why it is both added?

1225
Views
0
Helpful
2
Replies
CreatePlease to create content