Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Windows DHCP issues on startup when connected to Cisco IP Phone

We are experience random problems, when booting Windows PC's connected to Cisco IP Phones 7911: the PC is unable to get an IP address of the DHCP server.

If, after the PC finishes booting up, we perform an "ipconfig renew" the PC is able to get an IP address from the DHCP server.

The DHCP server is the Catalyst 6500 core switch-router, and when the PC is booting up we see no DHCP request reaching the Catalyst 6500.

We have no problems when the PC is directly connected to the access switch (Catalyst 3560), instead of being connected through the Cisco IP Phone.

The IP Phones configuration, on the CallManager, have the "Forwarding Delay" set to disabled.

Here is the configuration of the switch port:

interface GigabitEthernet0/x

switchport access vlan 10

switchport mode access

switchport access vlan 4

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

spanning-tree portfast

It seems as if the Cisco IP Phone internal switch is not implementing Spanning-tree PortFast functionality on the 10/100 PC port.

Anyone has seen this happen?

Thanks

2 REPLIES
New Member

Re: Windows DHCP issues on startup when connected to Cisco IP Ph

hi,

Assuming your voice vlan is 4, is it switchport access vlan or voice vlan 4?

Re: Windows DHCP issues on startup when connected to Cisco IP Ph

Sorry, typo:

switchport voice vlan 4

341
Views
0
Helpful
2
Replies
CreatePlease to create content