Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Wrong DTMF detection

 

Dear All,

 

I have Cisco Voice router 2801 with Two FXO ports and we have terminated two PSTN lines over it. Suddently, we are facing some DTMF detection issues.

 

Once the Router give us the dial Tone and we tried to dialed the desired numbers but unfortunately some times router recived the wrong digits. Successful ratio is 30% means 3 calls are passing correctly out of 10.

 

For Example:

 

Dailed: 923332631696

Recived Sample 1: 92233326631116

Recived Sample 2: 9223266

 

Please help me to sort out this issue. Thanks.

 

Note: its works perfectly since couple of years.

 

 

 

11 REPLIES

You are using ip phone or

You are using ip phone or analog phone to dial and are you facing this issue from all phones or any specific phone model ?

I have seen this issue when dialing from analog phone due to different pulse/tone settings on phone.

Suresh
 

Community Member

Suresh, Thanks for your

Suresh, Thanks for your Response.

 

I am using analog phone in order to reach the router. Below are the call flow

 

Analog Phone ---> FXO (PSTN Line) ----> Voice Dial Peer VOIP (SIP)

 

Please let me know if you any settings. I have tried to change dial type to pulse from DTMF but not much improvement.

 

Thanks.

Can you test dialing on

Can you test dialing on speaker mode or plz test with other/new analog phone.

Suresh

Community Member

Already tested via different

Already tested via different phones even via different country.

 

I suspected the issue related to Telco side. It seems they are sending DTMF at very high Decibel level.

 

If anyone face the same issue, please share the experience.

 

Thanks a lot!

Community Member

 Can you share the dial-peer

 

Can you share the dial-peer configs?

 

Thankyou

      PC

Community Member

Please find the below

Please find the below requested info

//

dial-peer voice 111 voip
 huntstop
 destination-pattern 9T
 session protocol sipv2
 session target ipv4:X.X.X.X
 dtmf-relay rtp-nte
!

voice-port 0/3/1
 dial-type pulse
 timeouts call-disconnect 0
 timeouts ringing 30

//

Community Member

 Instead of  " rtp-nte " can

 

Instead of  " rtp-nte " can you try " sip-notify " and reload the router post wr memory

 

Thankyou

    PC

Community Member

I tried this but obseverd

I tried this but obseverd same behaviour. like below

 

Dailed: 923332631696

Recived Sample 1: 2333631696

Recived Sample 2: 923332631696 - correct

Recived Sample 3: 923332631696 - correct

Recived Sample 4: 9233631696

Try putting connection plar

Try putting connection plar opx 923332631696 under the voice port.

If you dont have any POTS dial-peer pointing to FXO port , you need it to make oubound call from that FXO port.

Community Member

Thanks Manish This workaround

Thanks Manish

 

This workaround already implemented but i want to sort out the DTMF issues. we have to dial several different numbers on daily basis.

 

Thanks..

Can you attach debug vpm

Can you attach debug vpm signal and debug voice ccapi inout after enabling caller id on fxo port.

115
Views
0
Helpful
11
Replies
CreatePlease to create content