Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

6to4 on 1841 doesn't work

Hy everyone,

My english is not verry good, but I do the best I can.

 

There is my Infrastructure

Schema

For information, the link between the 1841 and the 3560 is in IPv6

 

My local area works, I can ping every devices and every hosts. What I want to do is to connect the hosts (only IPv6) with the "IPv6 NET" trought an IPv4 access. For doing it, I'm using 6to4 and I folow the commands here.

I can't communicate with outside and I don't know why.

Someone could help me please ?

 

 

My 1841 configurations:

 

Building configuration...

Current configuration : 1702 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$1PUw$zDwFcBZjklxBuVvQe3DJl1
enable password *******
!
no aaa new-model
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
interface Tunnel10
 no ip address
 no ip redirects
 ipv6 address 2002:5503:D70::1/48
 tunnel source FastEthernet0/1
 tunnel mode ipv6ip 6to4
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address FD4F:ABD4:AB05:FFFF::2/64
 ipv6 enable
 ipv6 nd prefix FD4F:ABD4:AB05:FFFF::/64
 ipv6 nd managed-config-flag
 ipv6 nd other-config-flag
 ipv6 dhcp relay destination FD4F:ABD4:AB05:6A14::FFFF
!
interface FastEthernet0/1
 ip address dhcp client-id FastEthernet0/1 hostname 1841
 duplex auto
 speed auto
!
interface FastEthernet0/0/0
!
interface FastEthernet0/0/1
!
interface FastEthernet0/0/2
!
interface FastEthernet0/0/3
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
!
!
ip http server
no ip http secure-server
!
ipv6 route 2002::/16 FastEthernet0/1
ipv6 route 2000::/3 FastEthernet0/1
ipv6 route FD4F:ABD4:AB05:115E::/64 FD4F:ABD4:AB05:FFFF::1
ipv6 route FD4F:ABD4:AB05:6A14::/64 FD4F:ABD4:AB05:FFFF::1
ipv6 route FD4F:ABD4:AB05:EC96::/64 FD4F:ABD4:AB05:FFFF::1
ipv6 route FD4F:ABD4:AB05:FFFE::/64 FD4F:ABD4:AB05:FFFE::3
ipv6 route FD4F:ABD4:AB05:FFFF::/64 FastEthernet0/0
ipv6 route ::/0 FastEthernet0/1
!
!
!
control-plane
!
!
!
line con 0
 password ******
 login
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end

 

and the routes

IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C   2002:5503:D70::/48 [0/0]
     via ::, Tunnel10
L   2002:5503:D70::1/128 [0/0]
     via ::, Tunnel10
S   FD4F:ABD4:AB05:115E::/64 [1/0]
     via FD4F:ABD4:AB05:FFFF::1
S   FD4F:ABD4:AB05:6A14::/64 [1/0]
     via FD4F:ABD4:AB05:FFFF::1
S   FD4F:ABD4:AB05:EC96::/64 [1/0]
     via FD4F:ABD4:AB05:FFFF::1
C   FD4F:ABD4:AB05:FFFF::/64 [0/0]
     via ::, FastEthernet0/0
L   FD4F:ABD4:AB05:FFFF::2/128 [0/0]
     via ::, FastEthernet0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

 

Thanks 

 

Sacha Treffer

Everyone's tags (1)
2 REPLIES

Hi Sacha,I'll admit I have

Hi Sacha,

I'll admit I have never delpoyed 6RD, but I can tell you you design is missing some key components.

In a 6RD network your 1841 is (one of many) CE routers, but you need a BR router as part of your 6RD domain which will receive your encapsulated traffic and forward it into a dual-stack v4/v6 network, off to the internet.

Without a BR router and a tunnel endpoint you cannot forward traffic.

 

Do you have a secondary site which is dual-stack? If not you may want to look at:

NAT64/DNS64 which in your case would need to translate all IPv6 traffic into IPv4, perhaps not ideal for a production network?

Or ipv6ip tunnels which would send your IPv6 traffic to a third-party tunnel endpoint. From security perspective perhaps not ideal?

 

cheers,

Seb.

New Member

SachaIt's not very clear what

Sacha

It's not very clear what you are trying to do

are you trying to setup 6to4 relay ?

do you have a global unicast ipv6 block ?

Fdf4 from my knowledge is not something you should use

lastly 6to4 is an old technology being deprecated. You should ask your isp for native v6 or if this is not possible, you can use a static tunnel over the v4 internet to a tunnelbroker like hurricane electric or sixxs

 

Hope this helps

 

mark

 

94
Views
0
Helpful
2
Replies