Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

basic IPV6 setup question

I am experimenting with IPV6 and have three devices in my test network.  They are setup as follows:

UC520 using BVI:   FD:0:0:1::1/64

Windows Server1:  FD:0:0:1::5/64

Windows Server2:  FD:0:0:1::6/64

I am using the following commands on the Cisco

ipv6 unicast-routing

ipv6 cef

int BVI100

  ipv6 address FD:0:0:1::1/64

  ipv6 enable

The Windows servers can ping each other, the Cisco can ping itself.  However I can't get pings from either Windows server to the Cisco.  I also tried pinging the Cisco using link-local IP but that doesn't work either.  Seems like I am missing something very basic, or so I hope.

Any ideas?



basic IPV6 setup question


Can you ping a server from Cisco device and then do a sh ipv6 nei and also sh ipv6 int bvi100.



Don't forget to rate helpful posts.
Community Member

basic IPV6 setup question

Here's what that looks like:

UC520#ping fd:0:0:1::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FD:0:0:1::1, timeout is 2 seconds:
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/4 ms

UC520#ping fd:0:0:1::5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FD:0:0:1::5, timeout is 2 seconds:
Success rate is 0 percent (0/5)

UC520#sho ipv6 nei

UC520#sho ipv6 int bvi100
BVI100 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::21C:58FF:FEE4:52A0
  No Virtual link-local address(es):
  Description: Test LAN
  Global unicast address(es):
    FD:0:0:1::1, subnet is FD:0:0:1::/64
  Joined group address(es):
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  ND DAD is not supported
  ND reachable time is 30000 milliseconds (using 30000)
  Hosts use stateless autoconfig for addresses.

Cisco Employee

Re: basic IPV6 setup question

I had a similar behavioural issue with my setup at home when trying to setup my Dual stack ADSL service.

I found it worked once the following had been enabled

bridge irb

bridge 100 route ip (where 100 is the bridge group being configured)

I will add that IPv6 is not supported on BVI where one of the points is a dot11 radio (as per the bug notes supplied). I did get this working between the LAN switchports and the DSL interface.

Also as an aside if I can comment on the addressing you are using, I would recommend a change as you are using non IANA ratified address space.

FD:0:0:1::1 is infact 00fd:0000:0000:0001::1. (leading zeros stripped) which is reserved by IANA. I assume you are attempting to use the Unique local address scope and your address should infact be:


I hope this helps

Cisco Employee

basic IPV6 setup question


Are are you running a software version which has this enhancement integrated?


Community Member

basic IPV6 setup question

My IOS is on the bug list.  I am running 15.0(1)XA2.

So I will certainly try to get it upgraded.  However is what I am having truly a routing issue?  I am not trying to route per se, my device only has one int with IPV6.  I am merely trying to communicate on the local LAN.



Cisco Employee

basic IPV6 setup question


What you describe (ping between windows hosts works, but not to/from router) means that bridging is working but routing is failing.

I'd give upgrade a try and report back (maybe some issues we don't see).


Community Member

Re: basic IPV6 setup question

Thanks to all who gave helpful suggestions.  In the end the problem was simple.  Basically I am an idiot.  I was enabling IPV6 on BVI100 which is my voice VLAN but the servers are in the data LAN!!  So I moved the IPV6 to BVI1 and everybody can talk to everybody now.

I upgraded to 15.1(2)T4 before I realized my stupidity so I don't know if I was being affected by the bug or not.  Also would like to thank stmillet for pointing out that I was using 00fd instead of what I meant to use which is fd00 so I did fix that also.

Thank you.


CreatePlease to create content