Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BGP ipv6 Implementation

We started to test dual-stack bgp implementation. although we established neighbour over ipv6, seems still we couldnt advertise our networks on internet and we couldnt reach anywhere over ipv6 address.

Here our related configs and outputs;

router bgp 3xxx

no bgp default ipv4-unicast

bgp log-neighbor-changes

neighbor 2A02:E0:0:xx::1 remote-as 34xxx

neighbor x.x.x.x remote-as 34xxx

neighbor x.x.x.x remote-as 91xx

maximum-paths 4

!

address-family ipv4

  .

  .

exit-address-family

!

address-family ipv6

  neighbor 2A02:E0:0:xx::1 activate

  neighbor 2A02:E0:0:xx::1 prefix-list v6in in

  neighbor 2A02:E0:0:xx::1 prefix-list v6out out

  network 2001:67C:xxxx::/48

  no synchronization

exit-address-family

.

.

.

ipv6 prefix-list v6in seq 5 permit ::/0 le 128

!

ipv6 prefix-list v6out seq 5 permit 2001:67C:xxxx::/48

.

.

.

.

.

interface GigabitEthernet0/2

ip address 92.45.xxx.x 255.255.255.252

no ip redirects

no ip proxy-arp

ip flow ingress

load-interval 30

duplex auto

speed auto

media-type rj45

negotiation auto

ipv6 address 2A02:E0:0:xx::2/126

ipv6 enable

7200-1_KULE#sh bgp ipv6 unicast

BGP table version is 4, local router ID is 212.156.xx.xx

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*> ::/0             2A02:E0:0:xx::1                        0 34xx 34xx 130xx 94xx i

What we supposed to do ?

Best regards.

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

BGP ipv6 Implementation

Hi,

I see you have a network statement in your BGP configuration. Do you have a matching route installed in your local RIB? This is required to originate the route in BGP. Normally, just a static route to null0 is sufficient.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
8 REPLIES
Cisco Employee

BGP ipv6 Implementation

Hi,

I see you have a network statement in your BGP configuration. Do you have a matching route installed in your local RIB? This is required to originate the route in BGP. Normally, just a static route to null0 is sufficient.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

BGP ipv6 Implementation

Hello;

As you say i add ;

ipv6 route 2001:67C:xxxx::/48 Null0

statement and working now. Thank you

But why we need this ? I'll be very appreciated if  you explain a little.

In ipv4 bgp we dont use similar statements

Best regards

Cisco Employee

BGP ipv6 Implementation

Hi,

For BGP to originate a route using the network statement, there needs to be a matching route in the RIB. This also applies to ipv4. Of course, you could use a "redistribute statement" instead but the network statement for the aggregate route with a static route to null0 is part of the best practices.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Cisco Employee

Re: BGP ipv6 Implementation

Hi,

One more thing. The reason you do not need to have a static route for ipv4 might be that one of the local subnets already matches the network statement you use.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: BGP ipv6 Implementation

Yes, we have three  C class networks and one of them is used for firewall side.

May i ask aother question?

On ipv4 bgp conf. we use route maps for coming and outgoing traffic on 3 different metro ethernet internet connections. We have 3 c class ipv4. so we configured load sharing for each networks between net connections. We use local-pref, weight or as path prepend.

Could we do the same thing for ipv6 connections ? We have ::/48 . for example we want to use ::/56 and share networks on internet lines. 

Best regards

Cisco Employee

Re: BGP ipv6 Implementation

Hi,

The /48 is the longest prefix that ISPs will generally accept. So if you break your /48, it is very unlikely that the longer prefixes will propagate on the Internet. On the other hand, if you do advertise the /48 out to each of your ISPs some load sharing will take place inbound.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

BGP ipv6 Implementation

Thank you for your support

Best regards.

Cisco Employee
2141
Views
0
Helpful
8
Replies
CreatePlease to create content