Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configure IPv6 MTU on a GRE tunnel interface


I’m using a C3750 on which I would like to modify the IPv6 MTU for a GRE tunnel interface.

I’m running a 12.2(46)SE release of IOS and the “ipv6 mtu” command is not available.

Is there a way to change this value ?

Why I need this change ?

I’ve a GRE tunnel configured between this 3750 and a Juniper router. I noticed that a ping (IPv4 & IPv6) with a packet larger than 1414b didn’t work. (maybe due to the equipments between those 2 routers, fw, ipsec tunnel, etc…but not sure why...)

I’ve changed the MTU value for IPv4 on both sides (set to 1414b), after this change ping (ipv4) is now working fine with any packet size.

I would like to do the same for the IPv6 packets. I can easily do it on Juniper side but wasn’t able to do it on the 3750.

Right now the default MTU for IPv6 packet on the Cisco side is 1514b.

I already tried to set this value on the Juniper, but it doesn’t work.

(This tunnel is used for an OSPF3 session to progagate ipv6 routes, the OSPF session is stuck in an EXCHANGE state. Cisco router send its DBD but it seems that packets never arrive on the Juniper and the Cisco try to retransmit the DBD again and again...)

Really appreciate if someone can help,

Thx, Olivier.

Everyone's tags (5)

Configure IPv6 MTU on a GRE tunnel interface

I am not 100% sure but I believe you can't set IP6 MTU on a router because the sending host must do MTU discovery and the sender must fragment the packet.

Are you allowing ICMPv6 packets end to end ?


Posted by WebUser Stuart Gall

New Member

Configure IPv6 MTU on a GRE tunnel interface

Thx Stuart for your answer,

ICMPv6 packets should be authorized end to end, i do not have any ACL.

If I understood how it works, IPv6 is encapsulated into IPv4 packets in this tunnel. IPv4 seems to work well with any packet size so I thought that with the same MTU value (v6) on both sides it should be ok... but not !

If a ipv6 packet leaves my Cisco router with a size of 1514 (default mtu), this packet should be "ipv4 fragmented" and should arrive on the other end with its initial size... with a 1514 mtu (v6) on my juniper, the juniper should accept the packet...

I tried this conf and it doesn't work.

I've activated the ICMP packet debug on the cisco, I didn't see any ICMP packet excepted my "Echo request".

With a packet with a small size I also saw the "Echo Reply".


New Member

Configure IPv6 MTU on a GRE tunnel interface


If it can help... I've performed additional tests.

IPv6 MTU on the cisco is (by default) 1514, on the Juniper set (manualy) to 1414

(it seems that the value on the Juniper has not impact on my tests)

Just to remind you : ipv4 packets are working fine over my GRE tunnel regardless the size.

I did a ping6 from the Cisco to the Juniper.

If the packet size is lower than 1414 -> Working fine

If the packet size is > 1414 and < 1514 -> Nothing received on my Juniper

If the packet size is larger than 1514 -> Receive on the Juniper the second fragment of the packet.

It seems that the IPv6 packet is properly fragmented when the size exceed 1514 and only fragment wich is smaller than 1414 arrives on the Juniper.

For some reasons packets larger than 1414 do not cross my GRE tunnel. I'm quite sur that if I find a way to set this ipv6 mtu to 1414, none of my packets will exceed this size and it should work.

Any ideas are welcome,