Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Help with a 6RD Basic config!

Hi there,

I am trying to start a basic setup to demonstrate 6RD and I am in trouble for a few hours. I just found an excellent pdf on this site and I tried to use it to start something using the same config but I did not have any success for the ulimated "ping" test !

I am using a very simple and basci setup using a:      

        CE ------ IP Router --------BR

This is my relevant config for the CE :

interface Loopback0

ip address 10.0.0.10 255.255.255.255

!

interface Tunnel0

no ip address

no ip redirects

ipv6 address 2001:DB80:A0A:100::/128

ipv6 rip fred enable

tunnel source Loopback0

tunnel mode ipv6ip 6rd

tunnel 6rd ipv4 prefix-len 16

tunnel 6rd prefix 2001:DB80::/32

tunnel 6rd br 10.0.0.1

ipv6 route 2001:DB80::/32 Tunnel0

And at the BR I got the following relevant info:

interface Tunnel0

no ip address

no ip redirects

tunnel source Loopback0

tunnel mode ipv6ip 6rd

tunnel 6rd ipv4 prefix-len 16

tunnel 6rd prefix 2001:DB80::/32

This is my version:

P1R3#sh ver

Cisco IOS Software, 1841 Software (C1841-ADVIPSERVICESK9-M), Version 15.1(3)T2, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2011 by Cisco Systems, Inc.

Compiled Wed 10-Aug-11 03:46 by prod_rel_team

More info about tunnels and intf:

P1R3#sh tunn 6rd

Interface Tunnel0:

  Tunnel Source: 10.0.0.10

  6RD: Operational, V6 Prefix: 2001:DB80::/32

       V4 Prefix, Length: 16, Value: 10.0.0.0

       V4 Suffix, Length: 0, Value: 0.0.0.0

       Border Relay address: 10.0.0.1

  General Prefix: 2001:DB80:A::/48

P1R3#sh ipv6int tu0

            ^

% Invalid input detected at '^' marker.

P1R3#sh ipv6i nt tu0

            ^

% Invalid input detected at '^' marker.

P1R3#sh ipv6i nt tu0

*Oct 30 22:06:13.266: Tunnel0 count tx, adding 20 encap bytes

P1R3#sh ipv6 int tu0

Tunnel0 is up, line protocol is up

  IPv6 is enabled, link-local address is FE80::A00:A

  No Virtual link-local address(es):

  Global unicast address(es):

    2001:DB80:A0A:100::, subnet is 2001:DB80:A0A:100::/128

  Joined group address(es):

    FF02::1

    FF02::2

    FF02::9

    FF02::1:FF00:0

    FF02::1:FF00:A

  MTU is 1480 bytes

  ICMP error messages limited to one every 100 milliseconds

  ICMP redirects are enabled

  ICMP unreachables are sent

  Post_Encap features: Tunnel 6RD

  ND DAD is not supported

  ND reachable time is 30000 milliseconds (using 30000)

  Hosts use stateless autoconfig for addresses.

P1R3#

1R3#

*Oct 30 22:08:40.146: Tunnel0 count tx, adding 20 encap bytes

P1R3#show ipv6 route

IPv6 Routing Table - default - 5 entries

Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP

       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

       D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery

       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

C   2001:DB8:BAD:F00D::/64 [0/0]

     via FastEthernet0/0, directly connected

L   2001:DB8:BAD:F00D::1/128 [0/0]

     via FastEthernet0/0, receive

S   2001:DB80::/32 [1/0]

     via Tunnel0, directly connected

LC  2001:DB80:A0A:100::/128 [0/0]

     via Tunnel0, receive

L   FF00::/8 [0/0]

     via Null0, receive

P1R3#

*Oct 30 22:09:07.226: Tunnel0 count tx, adding 20 encap bytes

P1R3#

P1R2#show ipv6 route

IPv6 Routing Table - default - 5 entries

Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP

       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

       D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery

       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

LC  2001:DB8:CAFE:1::1:2/128 [0/0]

     via Loopback0, receive

C   2001:DB80:6400:FECA::/64 [0/0]

     via Loopback99, directly connected

L   2001:DB80:6400:FECA:CACA::1/128 [0/0]

     via Loopback99, receive

LC  2020:1:1:1::1/128 [0/0]

     via Loopback99, receive

L   FF00::/8 [0/0]

     via Null0, receive

P1R2#

Sending on one side:

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2020:1:1:1::1, timeout is 2 seconds:

Packet sent with a source address of 2001:DB8:BAD:F00D::1

*Oct 30 22:12:28.318: Tunnel0 count tx, adding 20 encap bytes

*Oct 30 22:12:28.958: ICMPv6: Sent echo request, Src=2001:DB8:BAD:F00D::1, Dst=2020:1:1:1::1.

*Oct 30 22:12:30.958: ICMPv6: Sent echo request, Src=2001:DB8:BAD:F00D::1, Dst=2020:1:1:1::1.

*Oct 30 22:12:32.958: ICMPv6: Sent echo request, Src=2001:DB8:BAD:F00D::1, Dst=2020:1:1:1::1.

*Oct 30 22:12:34.958: ICMPv6: Sent echo request, Src=2001:DB8:BAD:F00D::1, Dst=2020:1:1:1::1.

*Oct 30 22:12:36.958: ICMPv6: Sent echo request, Src=2001:DB8:BAD:F00D::1, Dst=2020:1:1:1::1.

Success rate is 0 percent (0/5)

P1R3#

Does not show up on the other side:

Invalid input detected at '^' marker.

P1R2#deb ipv6 icmp

  ICMP Packet debugging is on

P1R2#

Any idea of something missing or wrong ?

Setups can be accessed remotely...

TIA

Fred

7 REPLIES
Cisco Employee

Help with a 6RD Basic config!

Bonjour Frédéric,

You are trying to ping an address outside the 6RD domain so you need to configure a default route on the CE as follow.

ipv6 route ::/0 2001:db80:1::0

Note that the next hop address incorporates the last 16 bits of the BR ipv4 address.

Regards

P.S.: the "tunnel 6rd br" command is not used to indicate the default gateway to exit the 6RD domain. it is simply configured so the CE can accept a different IPv4 source address than the embedded source address when packets come from outside the 6RD domain.

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Cisco Employee

Help with a 6RD Basic config!

BTW, I just noticed that the IPv6 address on the CE tunnel interface, uses 0xA0A as the embedded ipv4 address. This does not correspond to the last 16 bits (since you use a 16 bits ipv4 prefix length) of the local ipv4 address (10.0.0.10). This should be fixed as well.

Also, you do not absolutely need an IPv6 address on the tunnel interface but you should at least configure "ipv6 enable" on the tunnel interface on the BR.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Community Member

Re: Help with a 6RD Basic config!

thank you harold!

actually I did this lab after a few nights and days with almost no sleep to prepare a nice new training I have developped from an existing CISCO training

The first sessions are for you (cisco) ;-) and I wanted it to be perfect... 

I was sure to have done some BIG mistakes that I would have discover after a good night sleep ;-)

The first session is currently running this week.

I am going to try again tonight so maybe I will show this to my students tomorrow

http://www.fastlaneus.com/course/fl-ipv6spse

Cisco Employee

Help with a 6RD Basic config!

Great to hear that you have put an advanced IPv6 training together. I look at the class description and looks promising. Good IPv6 classes are kind of rare these days. I will definitely recommend that class to some of my customers. Do not hesitate to let me know if you come across any issue with your testing.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Community Member

Re: Help with a 6RD Basic config!

Thank you very much!

Community Member

Re: Help with a 6RD Basic config!

you are sure about

ipv6 route ::/0 2001:db80:1::0

???

::0 This is weird.. no ?

Cisco Employee

Help with a 6RD Basic config!

Hi Fred,

Well, 2001:db80:1::0 or 2001:db80:1:: would do. Only the first 48 bits are important here (32 bits 6rd ipv6 prefix + 16 bits embedded ipv4 suffix). The CE extracts the embedded ipv4 suffix, adds it to the local prefix (derived from the tunnel source) and use the result as the destination ipv4 address to forward packets to the BR.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
1526
Views
0
Helpful
7
Replies
CreatePlease to create content