Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

IPV6 and IPV4 ACLs

                   As we begin  deployment  IPV6 we are going to be in a mixed IPV4/6 environment - we have required access lists  implemented for IPV4 and must applty the same ACL defined for  for IPV6. Is it possible to apply IPV4 and IPV6 access lists concurrently on an interface or is a single access list containing both IPV4 and IPV6 addresses called for?

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

IPV6 and IPV4 ACLs

You will need to have concurrent ACLs applied to an interface.

The access lists are address familiy specific in their syntax and features so they cannot be mixed. An indicative example is shown below.

!

interface Ethernet1/1

ip access-group test-v4 in

ipv6 traffic-filter test-v6 in

!

ip access-list extended test-v4

permit ip any host 1.1.1.1

deny   ip any any

!

ipv6 access-list test-v6

permit ipv6 any host 2001:DB8::1

deny ipv6 any any

!

2 REPLIES
Cisco Employee

IPV6 and IPV4 ACLs

You will need to have concurrent ACLs applied to an interface.

The access lists are address familiy specific in their syntax and features so they cannot be mixed. An indicative example is shown below.

!

interface Ethernet1/1

ip access-group test-v4 in

ipv6 traffic-filter test-v6 in

!

ip access-list extended test-v4

permit ip any host 1.1.1.1

deny   ip any any

!

ipv6 access-list test-v6

permit ipv6 any host 2001:DB8::1

deny ipv6 any any

!

New Member

IPV6 and IPV4 ACLs

Thanks that was what I was looking for as I was worried about having two inbound access lists applied to the same interface

1012
Views
0
Helpful
2
Replies
CreatePlease to create content