Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

Hello , I am trying to setup nat-pt so that an ipv6-only network can communicate with an ipv4-only network and vice-versa..

I have followed the cisco ipv6 configuration guide and the following link http://cciethebeginning.wordpress.com/2009/07/27/ipv6-nat-pt-transition/

- Static NAT-PT, Dynamic NAT-PT and PAT overload were working

- however IPv4-mapped is not working and unfortunately for me it's what i have to implement on a network

I really need some help

nat-pt v4mapped.png

Routers' configuration with important commands;

Router0 config;
ipv6 unicast-routing
!
interface FastEthernet0/0
no ip address
ipv6 address 2001:A:B:C::4/64
ipv6 nat prefix 2001::/96 v4-mapped WHAT_to_IPv4
ipv6 enable
ipv6 nat
!
interface FastEthernet0/1
ip address 192.168.40.199 255.255.255.0

ipv6 nat
!
ipv6 nat v4v6 source 192.168.40.104 2001::C0A8:2868
ipv6 nat v6v4 source list list_to-ipv4 interface FastEthernet0/1 overload


ipv6 access-list list_to-ipv4
permit ipv6 2001:A:B:C::/64 any


ipv6 access-list WHAT_to_IPv4
permit ipv6 any 2001::/96
!

end

Router2 config;

ipv6 unicast-routing
!
interface FastEthernet0/0
no ip address
ipv6 address 2001:A:B:C::1/64
ipv6 enable
!
ipv6 route ::/0 2001:A:B:C::4
!
end

Router1 config;
interface FastEthernet0/0

ip address 192.168.40.200 255.255.255.0
!
end

Now, when i ping ''server'' from ''router2'', even static is not working. i.e "ping  ipv6  2001::C0A8:2868" says unreachable.

ALso when testing v4mapped i.e "ping 2001::192.168.40.200", same result.

After lots of trial,testing,web research, i still have no clue what configuration is wrong.

note ; i have also attached the packet tracer simulation file.

4 REPLIES
New Member

IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

really need some help on this

IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

look this link:

http://www.cisco.com/en/US/prod/collateral/iosswrel/ps6537/ps6553/white_paper_c11-676278.html

NAT-PT is more or less depricated, now it's all about NAT64 but I think  it's supported only on ASR or C7600, not on the low end devices.

to your config, I think the configuration of NAT64 prefix:

ipv6 nat prefix 2001::/96 v4-mapped WHAT_to_IPv4

should stay on global config mode, not under Interface mode

New Member

Hello,

Hello,

Am trying to simulate ipv6 to ipv4 network .The simulated isp will be on ipv4 network which 100.1.1.1.

the LAN-ROUTER will be on ipv6 network but the link that connects ipv6 to ipv4 will be on 100.1.1.10/29 network.

I created ipv6 nat pool as follows

ipv6 nat  v6v4 pool IPV4-ISP 100.1.1.2 100.1.1.6 prefix length 29

i also enabled ipv6 nat on the lan-router interfaces 

i try to ping 100.1.1.2 from ipv6 host but unsuccessful

can someone help ?

Cisco Employee

IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

If you absolutely have to use NAT-PT, then you will have to disable both IPv4 and IPv6 CEF.  NAT-PT does not work in the CEF path for either transport.  I would suggest looking to NAT64 vs NAT-PT

hth,

-jim

4557
Views
0
Helpful
4
Replies
CreatePlease login to create content